Back to the main site

Very Brief tutorial on manually installing a game in Lutris


#1

Hi there, I noticed that a few people were looking for information on installing games manually in lutris.
I threw this together in a few minutes and posted it on reddit, it is not exact and needs a bit of tweaking and cleaning up, but it does give a good idea on how to set up a bottle/prefix and install a game.

Easy steps for installing any game in Lutris:

Start lutris and then click on second icon from left at top of the window “Manage Runners”. Scroll down to wine and select “Manage Versions” Lots of versions pop up, you can install whatever one you like, although ge3.6 is a great base for many games. NB. you don’t have to do this every game, this is just grabbing the bottles for future use.
Now click on the + “Manually add a game” icon. In the first window “Game Info” give the game a name (can be anything). Choose “Wine” as a runner from the pull down. In the second tab “Game options” locate your installer from gog or wherever you got it from and select it as your “Executable” (we will change this later. Ignore arguments and working directory unless you need to put stuff in there specific to your game. “Wine Prefix” I choose /Games/fallout for example, and generallly select 64bit for prefix architecture. Under “Runner options” you can choose different wine versions for your bottle. This can be changed at any time to update to a new or different version. Ignore “System options” you can come in here later if you need to. “Save” and it will exit. if you don’t see you game in the list in Lutris, restart as there is a minor bug that won’t show launch banners until you have at least “one game” installed.

Ok now you run your game and it should start up your installer, install the game as you would in windows and it will automatically be pushed into the prefix you selected earlier.

Once all of that is done, last little bit. Right click your game banner in the Lutris main screen and select “Configure”, go to the “Game Options” tab and change the “Executable” to point to the actual .exe of the game you installed instead of the installer.
It will probably be in /Games/your prefix/Drive_c/program files (X86) directory somewhere. Now just “Save” and give your game a try.

Hope this helps.

Quick addendum regarding DXVK. To install DXVK to the bottle/prefix you have created, when you are in “Runner options” simply tick the enable DXVK box. Don’t select any DXVK version, instead simply type “0,54” in the version pulldown box and it will download and install 0.54 directly to your prefix.
Oh and I have found that wine 3.9 firerat is probably your best version for getting many games to run at this time.


#2

This was very helpful! Should really have something like this on the site/wiki.
Thank you :slight_smile:


#3

When I manually installed a game it is showing a generic icon for my desktop shortcut. When I go into the game info and try to change the icon it is not showing me one to use when I navigate to the game folder.

If I install the same game under play on linux, it does utilize the icon that is included with the game. Is there a way for Lutris to use the icon that is probably embedded in the game exe like other wine apps can?


#4

correction I found the prefixes under ~/.wine. I made the mistake of installing playonlinux and assuming that lutrix uses that underneath, and even managed to play the games there without really installing them.


#5

I am using Linux Mint 19.1 and can’t seem to get World of Warcraft up and running in Lutris. I followed instructions that I found by Fratm on Youtube but I’m afraid those instructions may not be the most specific to my current environment. I don’t know if I could post a link to the video but I will if necessary.

What I mean to ask is should I go back to an older desktop to make this work or search the forums more to see if I missed my answer in previous searches?

Edit*
Please ignore this message. I tried a newer version of Wine and it looks like it may work. I was not expecting this because it had not worked for me in the past.