Back to the main site

Ubisoft Connect installs fine but can't get internet

lutris --submit-issue

https://paste.ubuntu.com/p/n8G7Pd8FNk/

lutris -d

https://paste.ubuntu.com/p/6DPTxJf9pb/

Like the title says, pretty simple. Ubisoft Connect installed flawlessly, runs flawlessly, the only problem being that when I try to log in it says that it has no internet connection. No amount of restarting has fixed this. Other games (all through SteamPlay) work with internet just fine.

Thanks!

Debug log:
https://paste.ubuntu.com/p/JYFYsxCdr5/

(Had to put this in a comment because I’m a new user and am restricted to 2 links, even though the Please Read said topics require 3 different pastebins lol)

I had this too you’re missing a dependency as the log suggests. In this case it’s going to be gnutls/lib32-gnutls but I would recommend installing all the wine dependencies listed here to avoid any future issues.

2 Likes

Thanks big boss. Multilib was already enabled but downloading libgnutls and reinstalling solved. :smiling_face_with_three_hearts:

2 Likes

Ubuntu 22.04 does not have lib32-gnutls available only gnutls-bin. any workaround anyone is aware of? or do I just have no way of using Lutris any longer on Ubuntu 22.04?

The name in Ubuntu is not lib32-gnutls, I don’t know exactly what name it is but it should have the i386 in the name. You probably need to enable multilib support.

not sure what you mean multilib. there is no multilib package for gnutls. I already added i386 architecture and my assassins creed odyssey game in steam starts ubisoft connect and connects to the internet so not sure why Lutris has such a problem with it but here we are.

I added g++ and gcc multilib packages still nothing

This is the only gnutls reference I have with i386 in it and it is already installed.

research tells me that is the file that should make everything work but still get connection lost

Do you have a pastebin with your log?

where would the log be? ~/.local/share/lutris? or in the ~/Games2 folder?

I found a luncher_log.txt in the ubisoft sub-folder in the epic games launcher folder I pasted only today’s attempts. Ubisoft Connect Loses Connection - Pastebin.com

No that is not it, check the main pinned thread to see how to get the log that could probably tell us what is missing. Also what instructions or instller script did you use to install the program?

I used the latest install script from Lutris. are there other options? okay, I started lutris in a console with lutris -d and copied and pasted it here. lutris debug info for ubisoft connection lost - Pastebin.com

I also tried using the default wine for Lutris instead of a the GE Proton and got the same error. but the pastebin keeps getting deleted as soon as I create it so can’t provide that info apparently.

You need to use the Ubuntu pastebin that is a batter pastebin for linux topics. Are you having an issue with the Ubisoft Connect or the Epic Games Store?

They both use ubisoft connect to start the game. The ubisoft launcher works until it gets to login where it loses connection and if you try offline it says you need to log in once online to use offline mode. The epic store starts and works just like it should but when I try to run the game it trys to log in to the ubisoft connect account and I get the same errors.

here is the ubuntu pastebin using the default wine that Lutris wants to use. Ubuntu Pastebin

I believe this is your Problem:

(wine:33471): GStreamer-WARNING **: 12:01:11.052: Failed to load plugin ‘/home/bartb1959/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib64/gstreamer-1.0/libgstdtls.so’: libcrypto.so.1.1: cannot open shared object file: No such file or directory

Do you have that installed? There is another warning of a failed plugin.

I remember in one case I had to “patch” my wine package you might have to do the same. Basically you search in your system the libcrypto.so.1.1 for example and paste it in the path where the warning message points to.

Also is the Epic Store connecting or also it does not have connection?

epic store connects. I downloaded and installed the game but it won’t run because of ubisoft

I installed the old, outdated library so that libcrypto.so.1.1 was installed but that didn’t make a difference. This is quite a lot of work just to try to get a single game running. This is why I primarily use Steam and don’t mess with Lutris, I was just hoping it was better than in the past but unfortunately that is just not the case. I do thank you very much for the effort though.