Ubisoft Connect can't connect to the internet

I tried installing the Ubisoft Connect Launcher to play Trackmania (2020).

Once the launcher is installed it launches successfully, but it can’t connect to the internet. I already installed lib32-gnutls and also tried installing the additional dependencies described in this post. Additionally i tried running the launcher using Wine-GE (installed through protonup-qt) as runner, with the same result. I also tried allowing the ports described here in my firewall (i’m using firewalld) and also tried disabling the firewall entirely with no success.

The output of lutris --submit-issue can be found here

The output of lutris -d can be found here

Some general Information about my system

OS: EndavourOS (kernel 6.1.4-arch1-1)
CPU: Intel i5-12600K
GPU: Nvidia GTX 1050Ti (with proprietary driver version 525.78.01)
RAM: 32GB DDR4 RAM @ 3600 MHz

Has anybody managed to successfully log into Ubisoft Connect on Linux? Connecting my Ubisoft Account to my Lutris library worked without issues, i can’t install any of the games in my Ubisoft library though.


For me it worked after I installed lib32-gnutls. I don’t know exactly which wine works. I think on my pc it uses Winetricks instead (If I’m ont mistaking).

UPDATE: It “worked” but since a few days Ubisoft Connect won’t connect to internet as well over here. Luckely after I installed the game so for the time beeing I’m possible to play it in “offline-mode”. But if anyone finds a way to fix the connectin with internet for this one I would like as well.

A possible solution I found on the internet was to use a VPN. (Seems the free version of ProtonVPN would do for example).
Also found possible solutions in Windows. Maybe there’s a workaround for these on Linux.

Ubisoft helpdesk asks me to post them DXdiag and MSinfo. Since this does not exist on Linux I’m going to create a file with inxi -Fzx. I’ll give an update if this will be to any help to them. If anyone knows an other way 'round this problem in the meantime I’ll be happy to hear. (Still haven’t tried with VPN yet)

1 Like

This fixed it for me:

sudo sysctl net.ipv4.tcp_mtu_probing=1


I had the same issue with steam and proton and it had to do with the fact that ubisoft connect was starting in offline mode every time so I just had to relaunch ubisoft connect in online mode then restart it.

This worked for me, too! What does the command do exactly? Why does it fix the issue, do you know that?

What does the command do exactly?


It is a sysctl directive, for the Linux kernel. It prevents a “black hole” situation when silly firewalls or routers are blocking the ICMP messages needed to tell your stack to adjust MTU size (“Maximum Transmission Unit”, essentially packet size).

On black hole detection, this tells your tcp/ip stack to send probes to determine MTU size, preventing the black hole situation from stalling the connection request.

net.ipv4.tcp_mtu_probing=2 (not really recommended, too much overhead) will always send probes.

1 Like

By the way folks, simply typing that command doesn’t set that sysctl parameter permanently, only until you reboot.

You would need to add it to your distribution’s configuration so it sets that directive at every boot.

Usually, this is done in .conf files in the /etc/sysctl.d directory. You can add it to an existing one if your distro put something there (perhaps not recommended, as your distributor may replace it) or create a new one for your own directives.

For example, if I created a file named 02-mtu.conf (or anything .conf) and put it in there, with the directive:


on a line by itself, your init system will see to it that the directive is processed (it would use the sysctl program to do that)

The .conf files in /etc/sysctl.d are the usual practice these days, but it’s also possible to have an /etc/sysctl.conf file for such directives.


worked for me as well on Ubuntu 22.04

Tried with this command. Didn’t work, however after reinstalling Ubisoft Connect I now have part of my list of games visible on lutris.

Re-installed Lutris and Ubisoft Connect.
Still gives the list of games (not complete), but no way to open the game.
Instal of the game possible, but not to play.
At least now I can log into my ubisoft account.
But the log in gives the list and games to install, not the account itself.

EDIT1: Seems like ubisoft connect actually launches after a hell of a time.
Trying to connect: update to come if it worked or not. …

EDIT2: Apparently while “connecting to ubisoft” I was already connected (icon right bottom).
So, … connected and acces to all the games.
Trying to install a game never played before and see if it will run this time.

EDIT3: Game installed and launched. Go AC Syndicate

I had this happen when playing TM2020 offline and I had to just go to ubisoft settings and turn online mode on somehow. Ubisoft just wasn’t trying to connect to the internet.