Back to the main site

[Solved]Overwatch general error when using DXVK

The game runs when using Opengl, but it’s below 60 fps. On Windows 10 the game runs above 100 fps most of the times.

But when I try to use DXVK by ticking the box in the settings, the game gives me a “General Error” after pressing “Play” in the Blizzard app.

I have an AMD RX 460 2GB on Manjaro 17.1.12 XFCE (It gave me the same error also when I was using Ubuntu 18.04)

Hearthstone, HotS and Diablo 3 work on DXVK flawlessly.
Proton on Steam lets me run some Windows games flawlessly.
League of Legends runs flawlessly through lutris.
Dota 2 runs natively with the Vulkan API better than Windows (120+ fps).

Only Overwatch doesn’t seems to work. Am I missing something? Am I doing something wrong? I installed all the necessary libraries.

Try dxvk 0.71

That’s what I used. I tried 0.71, 0.70 and 0.62

I have the same issue with a RX480 on Kubuntu 18.04 with dxvk 0.72.

edit: fixed it!
It seems there was a conflict between the Intel iGPU and my RX 480.
I added VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/radeon_icd.x86_64.json in the game environment variables and that fixed it.

4 Likes

OMG You are awesome! Thanks! I also have an integrated Intel GPU. You are the best!

1 Like

You’re very welcome :blush:

thank you so much. solved my issue and the game is running flawlessly

Hi,

know somebody how looks game environment variables for NVIDIA? 1050 GTX 4GB ??? I try it google it but :((((

Thanks

For NVIDIA you set the VK_ICD_FILENAMES environment variable to /usr/share/vulkan/icd.d/nvidia_icd.x86_64.json

4 Likes

Rather than add an environment variable, simply select the Vulkan ICD loader in system options that corresponds to your video card instead of leaving it on “auto”.

1 Like

Legend. This was exactly it, default was Auto.

If that doesn’t work. Please read this continued thread here: [solved, kind of] Overwatch General Error 0xE0010170