[Solved] Overwatch exits during gameplay

After a recent update in Overwatch, my gameplay will go from normal to black screen to desktop without any kind of error notification.

Logging seems to reveal no information either. Log file here. Crash occurs inbetween lines 11401 and 11402.

lutris --submit-issue JSON file here.

EDIT: Seems with the release of lutris-wine-6.10 things are stable again? I have switched to Win10 partition for OW because I can’t go through that banwave again. Too scary.

1 Like

I have also witnessed this behavior the past day or two with no errors in the log. Not quite sure what is going on yet.

Artix Linux
mesa 21.0.3-2

I’ve had similar issues myself. I don’t get a black screen, but I get a short freeze up for about 0.5 seconds and end up back at my desktop too. Started in the last patch a day or so ago.
PopOS 20.04 LTS
Ryzen 5 3600
MSI B450 Gaming Pro Carbon

I am also having the same issue after the latest the update. Tried deleting GLCache and reinstalling the game with no luck. Started happening after the latest update.
Arch Linux Kernel 5.11.16
Nvidia GTX 1650TI With the latest Nvidia drivers
Ryzen 5 4600H

I’ve been having this issue also for the last three or so days. RIP my SR.
Please do share any updates on this.

OS: Ubuntu 20.04.2 LTS
GPU: Nvidia GTX 980 Ti
nvidia-driver-460: 460.73.01-0ubuntu0.20.04.1 amd64
wine-staging: 6.7~focal-1 amd64
lutris: all
lutris runner wine version: lutris-6.0-x86_64 (also tried lutris-6.4-x86_64)
lutris runner dxvk version: v1.7.3L-03f11ba
Overwatch: - 81410

Each instance of the game initially runs perfectly fine. Then, with no warning whatsoever the game is just gone, as if it never was. No errors or logs or dialogs are provided.

The crash usually happens within 20-60 minutes of starting the game and is always just a matter of time.

The game seems particularly eager to crash in competitive, be it when spawn doors open up or halfway through the match mid-action. I’ve also had it crash in quick play and in arcade, and even in the main menu of all places.

I did find one thing, namely that the wine64-preloader process running Overwatch.exe actually segfaults.
This was apparent from /var/log/apport.log at the time of the crash:


Update: Good news! I changed lutris runner settings and haven’t had a crash in 6 hours so far, which includes 6 arcade games, 2 QP and 2 role comp games. I think this actually duct-tapes it!

Settings currently working:
lutris runner wine version: lutris-5.7-11-x86_64
lutris runner dxvk version: v1.7.1L

I suspect the issue only happens on the newer dxvk version and that wine is alright, but while this thing is working I’m not touching a thing.

I’ll update once it crashes or later tonight if all remains well.


This seems to ‘work’. It isn’t crashing, but it doesn’t get the same level of performance as it used to. But this IS something!

1 Like

I do seem to get the same performance, but only after shader caches have been built. And that only happens as you get exposed to various visuals.

I found that a quick way to build shader caches is to join custom games like “Tiny Room”, where everything is chaotic and over-the-top.

1 Like

I went into one of the 1000 damage next hero games for a few minutes, but I still get drops when spinning sometimes.

This is also working for me currently, however this is not a solution.


I’m sure there are several things that are improved in newer versions, hence this being far from ideal.

I’m having no issues with voice comms on this version that I’m aware of, however. I can talk to my team in comp.

Clearing Battle.net cache seems to have fixed the problem for me for the latest Lutris runner and latest DXVK but there was like 2kb game update so I don’t know which one fixed but I played around 3 hours and my game didn’t crash.
Cache clearing guide: https://eu.battle.net/support/en/article/34721

@Ceryn Huh, weird. My comms just don’t work in any WINE versions earlier than 5.22.

@Awsim I don’t see how Battle.net cache would affect Overwatch gameplay crashes but I have just done so and will report back if it works for me or not.

Yeah I as I said game got a small update that might have fixed it but anyway I got a decent play session without crashing so I suggest trying it out.

Update: Can confirm clearing my Battle.net cache did not fix the issue (for me). Crashed again in comp. Also did not get an update like you said you did.

I also got a crash today. Which is weird because it didn’t happen before and all of my play session were at least 2 hours.
I will try downgrading DXVK with the latest Lutris Wine will see how it goes.

Hello, made an account here because of this specific issue.

I also encounter random crashes during gameplay of any mode since last update. Both DXVK 1.7.3 w/ lutris-6.4 and DXVK 1.8.1 w/ system wine 6.7-tkg-esync-fsync act the same (although the latter also bugs out whenever I alt+tab and I have to alt+enter twice to make it register my mouse in gameplay again, since it thinks the window is unfocused).

I’ve noticed that the crash is always preceded by this specific error. I’m using PipeWire on Fedora 33 (5.11.16-201.fsync.fc33.x86_64) as my PulseAudio server instance. I don’t know if it’s a symptom of the crash or a potential cause, nevertheless here it is.

If the problem could get pinned down and fixed sometime soon, I’d be very grateful!

I’ve meanwhile switched Wine audio to ALSA and will see if it helps.

I am also using PipeWire can someone with pure PulseAudio or ALSA confirm that their game is crashing too? I don’t think it is audio server/driver related but worth to test it.
@Synthkrieg Can you tell me your debug output settings on Lutris or how did you get that log?

@Awsim It’s journald viewed through GNOME Logs. I’ve spent two more hours playing on ALSA without a crash, but that needs more testing since I’ve had slightly longer sessions that ended up crashing with Pulse. You can try yourself if you change the sound output to ALSA in Lutris game settings. Outside of Lutris it’s winetricks sound=alsa, always separate setting per Wine prefix.

My crashes were on pure PulseAudio/ALSA. I’m not using PipeWire. I’m not quite sure which of the two are used though, as my wine and game both are set to auto-select.

My installed versions, just for for reference, are:
pulseaudio: 1:13.99.1-1ubuntu3.10 amd64
alsa-base: 1.0.25+dfsg-0ubuntu5 all

In other news, I’m still happily using the versions mentioned above of wine and dxkv in my Lutris runner without crashing.
I’ve played some 12 more competitive games, idled for hours and more besides still without crashes or other issues.