Back to the main site

[Solved] Fallout 76 Issue(s) Discussion


#1

Just wanted to start a thread in hope to get some support on the issues I currently have with this game.

My setup is a 1080ti 4k with a secondary 1080p screen, I’m using the tkg–protonified-3.21-x86_64 runner atm, should I be using the FO4 one?

Issue 1
I have noticed that with background mouse enabled (needed) my movement look control will stop on the right panning as if its hitting the edge of the second monitor and stopping the game from detecting the mouse movement further.

Issue 2
For the life of me I can’t get sound to correctly work, only the intro movie plays sound, menu and ingame has no sound and I have XACT installed with 2_6 and 2_7 set to native. The only thing I can think of being the issue is that I have a Sound Blaster OMNI 5.1 USB?

So far from what I have read nobody else is having sound issues after installed xact, so this is quite puzzling. I have encountered this mouse panning issue before in many games and is related to dual monitor setup, I won’t be disabling my second monitor as it causes other issues, there are work arounds but its been 6-8months since I last used Linux/Lutris etc…

Issue 3
White or bad water textures, just set the graphics setting to LOW and it should be fixed.


#2

Issue 1 resolved,

What I did was set game to borderless window mode, and also set lutris to make a Windowed 3840x2160 virtual desktop mode. That appears to have done the trick.

Issue 2 is still unresolved, tried many things, can’t think of much else to try, only other thing is to use the FO4 runner or ALSA? its also possible the winetricks installed the 32 and 64bit dlls in the wrong place but I thought that bug was fixed LONG ago.


#3

Issue 2
Tried tkg-fo4-3.21 and tkg-3.21 (recommended one) and still no menu or ingame sound (only intro). :tired_face:

I have recreated the prefix quite a few times, certainly isn’t a prefix corruption from what I can tell.


#4

Issue 2: Installed ming binaries, compiled FAudio32/64

50 symlinks later and FAudio is working and all sound, (testing still required). Can’t believe that symlink spamming worked LOL.


#5

I’ve gotten into the game and fixed the mouse thanks to the fix you mentioned. Only problem now is the sound… All I get is the intro.


#6

Compile FAudio or find a binary for your distro and then wire in the dlls, you can do it easily by symlinks, and the required dlls are more then the sum parts of FAudio because faudio relies on further libraries you should have installed on your system somewhere.

There might be a Faudio install script already around but I did it manually. Don’t forget to change XAudio dll ref. 2_6 and 2_7 to native, builtin.


#7

Hello, i am on Lutris as well under Solus Budgie and everything works like it said it would right up untill I click Install and then i get this message -

Any help would be appreciated - I tried googling but theres no mention of this anywhere, and I am new to linux, fled here from windows after I saw windows was pulling that far left censorship stuff with the fake news app on windows mobile


#8

Yeah I don’t think the launcher works properly and I already had FO76 installed. The only thing I can suggest is install it via a VirtualBox windows VM and launch the game outside of that once updated, requires manually putting in login and password as the only drawback of that method.


#9

is that how you got the data O.o? surely there must be someway to correct this? I thought anything was doable in linux >.< by the way thankyou for responding so late


#10

Ummmm, VM’s run under Linux and are quite easy to use/install.

However I have a windows10 boot partition and that is how I got the data, there may be fixes on WineHQ database, I haven’t looked. Perhaps start a app report over there for Bethesda Launcher?


#11

ok ^^


#12

T_T

[

Test Results
](https://appdb.winehq.org/objectManager.php?sClass=version&iId=37428&sAllBugs#testdata)

Selected Test Results

What works

Installing the launcher

Log in

Viewing video games

What does not

Installing games: Launcher error: “Can’t get product info. Please check network connection”

Workarounds

What was not tested

  • Buying a game

Hardware tested

Graphics:

  • GPU: Nvidia
  • Driver: proprietary

Additional Comments

selected in Test Results table below


#13

Maybe run the debug terminal in lutris to see what the launcher says when this issue appears (upon clicking install button). Then put that in the bug report also. Might be useful.


#14

it spits this out when it errors Renamed cdpprod.dch

this is that file https://ufile.io/xi1mw says its a binary


#15

I had a thought…Since updating works… supposedly, could you copy your bin folder and upload it for me? if i drop it in maybe it will let me update or give the option to repair?


#16

Your not going to believe it but i l33td this shit like a true scrublord and somehow got it working XD


#17

Ok well don’t forget to tell people how and maybe leave howto instructions on WineHQ… don’t just walk off into the desert alone and not tell anyone like most people do :wink:


#18

no worries, i will make sure to link to the thing I just wrote here : D [ working fix ] [ Bethesda net launcher + Fallout 76 ] as of 1/24/19 7:07 AM


#19

Dang… I’ve gotta say I’m almost completely new to Linux so I have no idea how to do any of that. I did a little searching around but I can’t seem to find a binary for FAudio, sadly. And I wouldn’t even know the basics of putting it together myself. I found a post mentioning one but apparently they’re not ready to make one yet due to lack of WMA support.


#20

Well the latest proton beta ships with FAudio so you could use that in Lutris but I haven’t really experimented with howto.


Also it will be part of wine eventually. https://www.phoronix.com/scan.php?page=news_item&px=Wine-FAudio-Merge-Plans

On ARCH I think I used the FAudio 32/64 wrappers. Again I did it a very manual way where once it compiled the DLL’s I symlinked them in the windows DLL folders (wow64 and win32 directories)

Then launched a game in debug terminal mode to inspect if it was loading them correctly and discovered it couldn’t find other dependancies as it was looking exclusively in those folders so I just symlinked them in, was like 30 dependancy files.

A script could totally be made to do it for people but again I’m on ARCH and things don’t always cross over very well to Ubuntu stuff.

Your best bet is to wait until FAUDIO because a standard, atm its just experiemental, yes it works flawless for FO76 but that doesn’t mean they will jump on it for wine use just yet, those guys are slow to adopt!

Latest proton beta has it ready apparently… but you need to learn howto use proton via lutris and wire in FO76, last time I tried that it kept trying to run via steam or some nonsense which spat a error.

PS. I used these but had to do some manual stuff as you will discover in the comments section.

https://aur.archlinux.org/packages/faudio-wrappers-win64-git/
https://aur.archlinux.org/packages/faudio-wrappers-win32-git/