[Solved] Downloading of arial32.exe fails with return code 256, Battle.net

The following error occurs on installation of Blizzard Battle.net.
I tried it many times. No luck. Please help.

> [0] Downloading 'https://mirrors.kernel.org/gentoo/distfiles/arial32.exe' ...
> HTTP ERROR response 404 Not Found [https://mirrors.kernel.org/gentoo/distfiles/arial32.exe]
Downloading https://web.archive.org/web/2000/https://mirrors.kernel.org/gentoo/distfiles/arial32.exe to /home/sjuk/.var/app/net.lutris.Lutris/cache/winetricks/corefonts
Failed to connect: Timeout
Failed to connect: Timeout
Failed to connect: Timeout

lutris-issue-report.json (lutris --submit-issue)
lutris-debug-output.txt (lutris --debug)

There maybe something wrong with winetricks.
I also reported an issue at https://github.com/Winetricks/winetricks/issues/2132

The following topics don’t solve the issue, even if the symptom appears to be similar.

Just look through the forums here -I posted the solution to this already Bnet = battle.net

I guess you mean this one.

I tried to follow your workaround. But without success. Here is what I did.

$ /home/sjuk/.cache/winetricks/corefonts
$ rm arial*

arial.exe and arialb.exe were downloaded from https://sourceforge.net/projects/corefonts/files/the%20fonts/final/
and stored to /home/sjuk/.cache/winetricks/corefonts
Battle.net installation was retried.

Result: the error persists.

close lutris, then in terminal run lutris -d, retry the install and copy ALL the terminal output to something like pastebin and drop the link here

Here you are: https://paste.ubuntu.com/p/DpNWh25M5Z/

You missed the piece that said make sure you have wine ge 8.17 installed in lutris. On the left hand panel in lutris under runners, highlight wine and click on the folder icon beside it. Select the most recent wine ge (should still be 8.17) and install it. Retry installation

Same result with wine-ge-8-17: https://paste.ubuntu.com/p/7RJjP53FXF/

Actually this is a different result. Lets do this really simply - make sure the folder /home/sjuk/Games/battlenet does not exist, make sure you remove all files from /home/sjuk/.var/app/net.lutris.Lutris/cache/winetricks/corefonts , download the arial files (2 of them) from the corefonts source to the folder /home/sjuk/.var/app/net.lutris.Lutris/cache/winetricks/corefonts
Restart lutris with lutris -d and do the install again.

/home/sjuk/Games/battlenet does not exist

There were no files in /home/sjuk/.var/app/net.lutris.Lutris/cache/winetricks/corefonts

So get the fonts downloaded and try the install again

I copied the downloaded files (arial32.exe and arialb32.exe) that were downloaded this morning to the desired destination.
From /home/sjuk/.cache/winetricks/corefonts
to /home/sjuk/.var/app/net.lutris.Lutris/cache/winetricks/corefonts

And finally it worked, with wine version lutris-7.2-2. The trick was to use the right path.
Many thanks for your assistance :slight_smile:
For information only the debug log: https://paste.ubuntu.com/p/7zR5hmkXMy/

If you plan to use the 7.2-2 with an igpu, change the dxvk version to 2.0 and vkd3d to 2.6
Lutris will periodically update these, so if it fails to launch an installed game later, check these on the runner options tab (Show advanced needs to be enabled to see the version)

I just want to play StarCraft II. That works fine with the default settings with Intel GPU. But thanks for the hint. :slight_smile:

1 Like