Back to the main site

Issues starting Battle.net on Pop!_OS after update

Issue JSON:
https://paste.ubuntu.com/p/rFgQny66QC/

Lutris -d log:
https://paste.ubuntu.com/p/XsNC3zqzTp/

Game debug log:
https://paste.ubuntu.com/p/g5rJvCKgrn/

Description:
Battle.net and Classic World of Warcraft worked fine last night. Today, after updating, there are issues.

I start Battle.net from Lutris’s classic wow launcher. It logs in, starts to open the main launcher, then crashes. It looks like the issue is the following:
Unhandled exception: unimplemented function api-ms-win-crt-private-l1-1-0.d._o_getenv called in 32-bit code (0x7b453c5c).

Has anyone else run into this before? Is there a workaround?

Edit: found this bug report in wine, looks like 4.14 will fix it.

3 Likes

I just updated Battle.net a few minutes ago and now when i open it white screens. I’m running Ubuntu.

ArchLinux, the same issue

2 Likes

its possible to still start the game and it (at least WoW Classic) works just fine
you just have to guess where that button is on the white screen…

just try it :slight_smile:

I suspect update to Battle.net.11537… btw, I use Arch. :wink: I have tried multiple wine and DXVK versions, so it must be something new… No time to debug, I have managed to launch the game by muscle memory. :smiley:

EDIT: I have just updated OS because of this with same results.

you can change in the lutris settings Executable option on …/wow.exe

Running Manjaro, and got the same issue. Occurred after the battle net update.

Thanks man, this works. Since I reinstalled wow to try and get it to work, I’m now installing it with no progress bar, lol.

I’ve done a lot more looking into it. I switched my wine version to lutris-4.16 and it runs with the white screen that people have reported. The logs are showing errors with d3d and dxvk, I’ll throw them in another paste.

Actually, it just crashed again. Logs are here:
https://paste.ubuntu.com/p/9BP2X5CX78/

1 Like

Same issue here on Manjaro Arch. Problems after the latest Battle.net update.

Got this same issue on PoP_OS and tried to reinstall the game, so I also uninstalled the WoW game files with it. Since some are telling that starting the wow.exe directly also works, is there a way to obtain the files on another way?

Same problem on Xubuntu 18.04 with WINE 4.17

I though it was at my end so spent the last couple of hours making sure everything’s up to date…

Still, point Lutris at wow.exe and manually logging in has successfully loaded warcraft so the issue appears to be purely the battle.net launcher.
For reference I get:
Unhandled exception: unimplemented function api-ms-win-crt-private-l1-1-0.d._o_getenv called in 32-bit code

When launching the launcher normally

1 Like

Confirm for both Ubuntu 18.04 LTS and 19.04. Launcher just hangs after login and system says it is not responding and suggests to kill it. Trying to install Diablo 3. It worked perfectly today some hours ago.

1 Like

I reinstalled the entire blizzard app and now im able to get into the battle.net app but getting white screen after i log in, I’m able to click things but everything is invisable. I already uninstalled wow.exe so I can’t use the ‘point to the executable’ trick anymore.

1 Like

I went to my ‘drive_c’ \ Program Files (x86) \ Battle.net\

and i saw there was a new folder Battle.net.11537

The old folder ‘Battle.net.11512’ is still there tho…

so i deleted folder ‘Battle.net.11537’, and relaunched the game.

IT WORKED

(i did not expect this to work) :wink:

3 Likes

I Tried this, and surpisnly it worked. Def worth giving a try as a quick fix, tho guessing the script will need to be updated or something.

Yep nice one!

If it’s a fresh install the old folder (11512) isn’t present, but for those getting an old install working it’s a better work around that loading wow.exe.
Also after loading battle.net it downloads the updated version again so you have to delete 11537 before the next launch.

For those that lost (or don’t have) the last working version of the bnet launcher:

https://gofile.io/?c=15y3Yp

it’s a TGZ containing Battle.net.11378, unpack it inside C:\Program Files (x86)\Battle.net (or w/e you installed it)

SHA256: 195434c4f0dffad41ae905c1cc0b23ae5bd513aef23fa8cae3347adfc5a29df4 bnet-not-broken.tgz

4 Likes

I managed to track down a solution for this. You need to add the following two libraries to your wine configuration: api-ms-win-crt-private-l1-1-0 and ucrtbase.

How-to: Right-click the game and select “Wine configuration” then go to the Libraries tab and add the libraries from the drop-down.

Solution provided by WarfaceZ here

21 Likes

Yeah, that fixed it for me! Thanks for sharing what you found.

Thank you VERRY MUCH! Thats it… deleted the files. You are the man. I stopped playing, went over to a friend and nothing worked. I went crazy.