Back to the main site

Battlefield V Terrible FPS


#1

Hey all, I’m using Manjaro 18 - I have a GTX 1080ti and 8700k cpu

I’ve installed the lutris script for origin/battlefield V - Then downloaded battlefield V and ran it.

My framerate is super-choppy and I can’t seem to work out what the problem is…

I’ve enabled Esync

I’ve got the DXVK config file being loaded in the environment variables

I have NVIDIA 390.87 installed

Any clues in the right direction from here would be really amazing as Battlefield 5 is literally the only thing I have to return to Windows for now.

Also, I don’t know if this is a clue or is related but I have dxvk hug set to 1 - but I get no framerate data on my screen in-game.

Thanks in advance people!


#2

Hey, i am running the game without issues. Take a look here maybe that helps.

I am on a “real” archlinux with Kernel 4.20 and mesa 18.3.1.

I played with RX 580 and a RTX 2070 just fine.

I have a VEGA 64 in my Mail, i will report back how the FPS increased over the RX580 and RTX 2070.

btw. latest nvidia driver is the 410.93.


#3

Update the video driver


#4

Okay so I decided to purge all nvidia drivers etc. and start afresh from console. Turns out my newest driver is 415.25, so I have that now.

Then I re-installed origin via Lutris battlefield V installer.

NOW it’s much better - is it normal for it to start with lots of stutters then slowly improve? Is it caching something as I play?


#5

Shaders probably.


#6

Cheers! Any idea how i can make it run in 1440 p instead of either 1080 or 4k? There’s no 1440p option in-game


#7

No, I don’t have the game.


#8

You might want to try to switch through fullscreen/windowed/borderless mode in the graphic settings. As this game is played in a virtual WINE desktop, some games can’t get the resolution right. On another window/fullscreen mode, they do. (Source: I play this game on 1440p)

Also check twice if your virtual desktop also has your desired resolution :slight_smile:


#9

In Fullscreen i can choose every available resolution my display provides. I can go 1080p, 1440p or 4k.
I am playing this game on all low in 4k with about 80-120 fps. On 1440p with about 90-120fps and in 1080p with almost always over 100fps.

Asus Prime X470
R7 2700X
16 GB RAM
Vega 64


#10

Thanks Troll, I actually have a 4k monitor and playing at 4k would likely not be ideal for framerates since I play on windows at 1440p.


#11

Yeah see, I have a 4k too, but I can’t select anything on the wine monitor between 1080p and 4k…


#12

What if you try tkg-3.21 instead of the protonified version?


#13

Mh, thats odd, i did not have such problems, i will do some screenshots when i am back at home.


#14

That was good thinking! but no, switching didn’t help.

One interesting thing I’ve noticed that I’m guessing must be related is that if I go to system settings and try manually changing my screen resolution tehre, I’m not offered any resolution options between 1080p and 4k either…

So I’m guessing something is telling the system my monitor can on ly do those two resolutions?

NB Nvidia does offer me that screen resolution option - just not System Settings


#15

Can you post an xrandr output?


#16

Sure, I actually tried going the xrandr route after my last post because Iwent to do some research, but it won’t let me add the custom resolution to my DP-2.

So the xrandr output is: Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 621mm x 341mm
3840x2160 60.00*+ 30.00 29.97 23.98
1920x1080 60.00 59.94 50.00 29.97 23.98
1680x1050 59.95
1440x900 59.89
1280x1024 75.02 60.02
1280x960 60.00
1280x800 59.81
1280x768 59.87
1280x720 60.00 59.94 50.00
1152x864 75.00
1024x768 75.03 70.07 60.00
800x600 75.00 72.19 60.32 56.25
720x576 50.00
720x480 59.94
640x480 75.00 72.81 59.94 59.93
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)
1440p (0x251) 312.250MHz -HSync +VSync
h: width 2560 start 2752 end 3024 total 3488 skew 0 clock 89.52KHz
v: height 1440 start 1443 end 1448 total 1493 clock 59.96Hz

BUT when I try to add it to DP-2 with: xrandr --addmode DP-2 1440p

I get:

X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 43
Current serial number in output stream: 44


#17

Your addmode is not correct.

https://wiki.ubuntu.com/X/Config/Resolution#Adding%20undetected%20resolutions

see here for informations.

Btw, yesterdays Patch from 15 January 2019 made some adjustments to graphics, perfomance seems to be worse.


#18

What precisely is wrong with my addmode? As far as I can tell I’ve done it all correctly? I called the newly added mode 1440p (you can see it sittying there on my xrandr command) then I went to add it as per instructions best as I can tell?

If I’m getting something wrong, I really can’t seem to work it out from that page…


#19

Did you try creating a xorg.conf with nvidia settings?

It seems that nvidia and randr dont always work well together.

If your Modeline is correct than this should have worked.


#20

Open “Future frame rendering”。

In wine,Pre-rendering can improve CPU efficiency and make gpu fully loaded。

Battlefield series can temporarily open pre-render with “renderdevice.renderaheadlimit 3” command。