Back to the main site

WoW not working with new patch 8.15


#21

I saw on DXVK github issues that it is surely Nvidia drivers bug.
Is it possible to install vkd3d with Lutris?


#22

To my knowledge it is not featured there, meaning you have to install it manually and run it with lutris or just wine

edit: you might have to compile it with wine when I think of it…

vkd3d and dx12 even working for wow in wine is a big step forwards though, last time I tried this it didn’t start at all and that’s just like 6 months ago. It’s a working progress. some distros have vkd3d inc -dev packages, but I am sure they are all outdated

anyways here we go on this old laptop I have to setup anways


#23

same on ubuntu 18.10 :frowning:


#24

the DXVK dev posted a hack on github:


#25

Can confirm that reinstalling battle.net with the new script helps, but the game constantly and randomly crashes. Am I the only one with this problem?


#26

yes it works indeed!

just set the dxvk to manual and run

WINEPREFIX=~/Games/world-of-warcraft/ ./setup_dxvk.sh install

and you’re good to go again
it was actually on blizzard’s end it seems

edit: you might also have to https://github.com/lutris/lutris/wiki/How-to:-Esync


#27

I can confirm this works. (I did reinstall the prefix, my game folder is elsewhere so easy to do) the fix works. :))


#28

Can someone explain exactly what needs to be done for a Linux newbie… Thanks!


#29

Just do a fresh battle.net installation. Backup your WoW folder from your Lutris’ battle.net prefix (and don’t install WoW inside it next time, if you had - use symlinks or another way to not store the game inside Lutris’ prefix), remove it and reinstall. Then login back to your battle.net app, choose path to WoW and you are good to go. You may probably want to change DirectX settings in-game to Legacy DirectX 11.

Otherwise just follow nopies’ instructions: in Lutris’ battle.net configuration change DXVK to Manual and apply this to your prefix as suggested in the post.


#30

I tanked a 2 hour raid last night on 8.1.5 using tkg-4.2, DXVK 1.0, esync enabled. I didn’t change the graphics engine, it is still on DirectX 11.

I’m running in windowed mode if that makes a difference.


#31

I reinstalled using the new script they posted 8 hours ago or so. So far so good, I am getting good fps.

I tried to execute

WINEPREFIX=~/Games/world-of-warcraft/ ./setup_dxvk.sh install

But I got an error “Failed to resolve C:\windows\system32”

I think the new Lutris installer script address the issue though.


#32

hears a link to my youtube showing it works https://youtu.be/DQ9_NN9empQ


#33

Looks promising. A few ppl solve their 8.15 issue by applying this patch. Do you know how to apply this patch on lutrics???


#34

I ran into this issue as well and its a relatively easy fix.

  1. Download the patched dxvk here
  2. Open up ~/.local/share/lutris/runtime/dxvk/
  3. Create a new directory for this new dxvk release. You can name it anything. I chose wow-test, but you can pick anything.
  4. Extract the dxvk patched version downloaded above into this new directory your created in step 3. You want it to have the x32 folder, x64 folder and the setup shell script in there.
  5. Go into the game settings in lutris and change the dxvk version to manual, and type over the word “Manual” that shows up with the name you gave that directory. So in my case I typed in “wow-test”

You are done, and things should work perfectly again.

Just in case it helps here is my directory listing of what I created:

[andrew@schotty-tower-wired wow-test]$ pwd
/home/andrew/.local/share/lutris/runtime/dxvk/wow-test
[andrew@schotty-tower-wired wow-test]$ ls
setup_dxvk.sh  x32  x64
[andrew@schotty-tower-wired wow-test]$ 

#35

This
Very well written step by step guide, this is the approved workaround atm


#36

DXVK updated with a WoW fix

Should just work OOTB now.


#37

I reinstall Battle.Net with Lutris as Lutris dev uploaded a new script to help wine users to play WoW without crash. Don’t forget to move your WoW game folder on another place before to reinstall Battle.Net.
I played more than one hour, it’s stable and fast.
It’s impressive how the wine community and actors was reactive.
Lot of thanks to Philippe and Lutris dev.


#38

Thanks!!


#39

Okay, this is probably the stupidest question asked here, but: should we see any differences in the options we are given? Like in WoW, I have the options for DirectX 11 and DirectX 11 Legacy. Now that I have the patch in for 8.15, I switched WoW to the non-Legacy version - is that correct, or should there be a menu option for DirectX 12? Is DKVX reporting as 11 or 12?

See, I toldja, dumb!


#40

I personally had to do nothing besides download the tkg-4.3 runner. Lutris updated my default runner and dxvk accordingly.
So I just ticked the TKG-4.3 box and clicked “play”.
No more freezes. Great performance (for me).

Many thanks to the Lutris team.