Back to the main site

WoW not working with new patch 8.15


#1

I cannot get Lutris to work with the new patch of WoW. I can get into Battle.net, install the game, log in and see my character for a few seconds before the game freezes my computer entirely and I have to hard reboot.

I have tried both Fedora 29 and Ubuntu 18.10 (I have a dual boot system), and have tried reinstalling the game entirely, wiping the lutris configuration folder, swapping wine and dxvk versions but nothing seems to work, I just get a few secs of gameplay before it freezes again.


#2

Hi, I am experiencing a similar problem, but slightly different.

I can log into battle net I can see my characters, and configure settings such as graphics and sound, but when I try and enter the world, the game just freezes up. I didn’t need to reboot but I have to tab out and pkill wow, because when its in this state it super eats up my cpu resources for some reason and everything becomes mega slow. I also experimented with other runners and DKVX versions, as well as lowering game settings, but I havnt been able to resolve the issue. Is anyone else experiencing this?

Im on arch.

relevant system/driver info-> http://dpaste.com/23KNRAK


#3

Having the same issues here, tried to lower all settings, disable all addons, reinstall and nothing changed.

I’m using elementaryOS


#4

Ubuntu cosmic, nvidia 415.27

Exactly the same issue. It varies when the freeze occurs anything from a few sec to a couple of mins
on one occation it even froze my kb and I had to a hard restart. Before the patch the system has ran flawless


#5

ubuntu bionic, nvidia 415.27. freezing on launch (edit: by this I mean when entering the world. battle.net and character screen works just fine). Verified the framerates etc from before, disabled all addons. Also tried DX11 legacy option. So far no solution that I can find. is kicking self for not trying ptr before today


#6

Same issue here: Battlenet and character selection screen works fine, but once I log into the game, it freezes the whole system.

If you disable DXVK in the runner options and switch to DX11 Legacy in the game it kinda works, but with an awful framerate, obviously.

I really hope we can get this fixed


#7

Exactly the same problem. I just open the game to see if this is happening on my system and it does.

I’m running it on Debian . Got to go to work. I’ll catch up later. Hope we can resolve this.


#8

works perfectly for me but then again im on https://www.parrotsec.org/ =D good luck all


#9

by the way the old setup with esync and no DXVK still works ok.
(tkg4.2 + esync enabled, no dxvk, DX11 Legacy).

It is not great performance, but it is a temporary workaround that functions (with some graphics options lowered I am getting about 15-20fps on Boralus with 4K resolution).


#10

so then it is starting to sound like it is about the dx11-vk wrapper.


#11

The installer was updated earlier today, has anyone tried it yet?


#12

yep. Battle.net launches. WoW doesn’t launch, critical errors out.


#13

Same on Manjaro … Battlenet loads. I can login … A few seconds later the computer freezes and I have to reboot. Tried on my Mint Linux computer… Exactly the same problem.


#14

Update: After 3-4 hours of trying to reinstall and configure, it is still not working as of Wednesday, March 13.

As someone else posted above, disabling DXVK seems to work but FPS drops to 1-2 per sec.


#15

Same issue on Ubuntu 18.04, I can login on Battle.Net, the client launched normally but I can not launch Wow, it crashed quickly. Why there are so much problem with Blizzard software? They always make changes that are not or badly supported by Wine.


#16

look at the changelog, there are a lot of DirectX changes:

New Graphics APIs in 8.1.5

In 8.1.5, we are making some improvements to how World of Warcraft uses DirectX. In essence, our old DirectX 11 is now called DirectX 11 Legacy, and our new DirectX 11 is multi-threaded. More details on each DirectX version is below:

DirectX 11 Legacy

A single-threaded rendering backend. This is provided to be the most compatible with older hardware, operating systems, and drivers. This is also the least performant. This is very similar to the functionality of DirectX 11 in 8.0.1.

DirectX 11

A new multi-threaded rendering backend using DirectX 11. This should improve performance for older GPUs or operating systems that don’t support DirectX 12. This is new for 8.1.5.

DirectX 12

A multi-threaded rendering backend using DirectX 12 for hardware, drivers, and operating systems that support it. There are some performance improvements in 8.1.5, but it is mainly the same as the 8.1.0 release.


#17

if you switch to DX11 Legacy from the advanced tab of graphics, it helps with the framerate a little.


#18

Tried DX11 legacy mode here, exactly the same behavior


#19

I tried disabling DXVK and turning to DX11 Legacy. It seems to play without crashing now, but low fps (~15 fps or so).


#20

Using vkd3d with dx12 in wow was the only thing that made it playable for me so i could raid tonight, as suggested here. https://old.reddit.com/r/wine_gaming/comments/az5b85/vkd3d_world_of_warcraft/

Had to compile it myself with the patch that was mentioned and use a fresh wine prefix.

Not a perfect fix, but at least it’s something to consider until a dxvk fix is found.