Back to the main site

World of Warcraft 'streaming error'


#21

Hm, I’m again having this issue with the BFA release, and I have found no way of resolving it.


#22

I have verified the cache db fix works. If you can, run through the heart once on a Windows machine and then copy the Cache directory from Windows back to your Lutris install.


#23

Hi all,

I have the same problem, but it occurs when opening chests(but the content then goes to my mailbox) and when opening the profession window.

When I had the problem a few months ago, the game disconnected right on login onto one specific character, nut all others were ok.

I copied the Wow installment from my girlfriends PC which also runs Linux and it worked again.

So I assume there is no need for a Windows cache, but somewhere in the installment is an issue which causes that behavior…


#24

I also am having the streaming error crashes in BFA. I dont have anything else to contribute other than I have tried various settings to no avail.

Anybody got any BFA streaming error advise?


#25

My WoW client had been crashing with this error since it was installed - after the release of BFA - in certain circumstances including loading the PvP and Appearance panes. Since yesterdays patch the streaming error now occurs on every attempt to login as a character.

I have disabled all of my addons with no change.


#26

The solution is still above.


#27

Hi Dox,

Not sure if youre familiar but there has been a new WoW expansion. The old cache file doesnt seem to work…

-David


#28

Open an issue, ask for fresh copy of Windows cache?


#29

Done and done. Thanks


#30

You can try this, perhaps it works.


#31

Ok so thank you Dox,

Some combination of applying this fix (the reddit one above) + restoring the cache with that 2 month old file + using staging 3.14, has allowed me to login to my characters and I am getting 90+ FPS btw.

I wish I could reproduce the problem and figure out just exactly which fix was the reason it is now working…

Anyway,
Thanks
-David

EDIT:
Woke up today after installing steam yesterday and couldnt get past hitting play in WoW (it gave a black screen of sorts). However, I disabled streaming via the battle.net app as per the documentation on github and was then able to log in correctly. Hope this helps someone.


#32

Thanks! This worked for me on a fresh install of Ubuntu 18.04.


#33

Sorry to bump an old thread but this was the first to pop up on my search of the error.
The above links to the caches are for old expansions of WoW.
I managed to get my hands on a copy of the Cache folder from a BFA installation on my partners Mac and it works perfectly.
I have uploaded it to my github.

Hope this helps. I will try and keep it updated when newer patches are released.

Cheers


#34

So, clearing the cache fixes the streaming problem…Yet, I can’t use any addons?

Tell me why I want to run this on Linux then?


#35

I’m running with 100+ addons with no issues for multiple expansions on Linux only.

So, please don’t try to spread misinformation, kthx.


#36

Hey, just rebooted and all of the WoW files are gone. This has been a total waste of my time and effort. What a POS this whole Linux experience has been.

Keep on bucking the trend dudes. Later


#37

That’s very strange.
I made the leap to move from Windows to Linux as the only thing keeping me on Windows was WoW, since finding out about Lutris last week and installing Wow it has been running better than what I had on Windows. I am running all the same addons I was using previously.
The only issue I had was the streaming error which I posted the file above which fixed it.
I don’t know how addons wouldn’t be working unless they aren’t being installed to the correct location.

I have been using http://www.braier.net/wow-addon-updater/index.html to download and install as well as update my addons.
I haven’t tried using the Curse/Twitch Client as of yet via Wine but that may work but I’m not 100% on that since I have not tried it myself.

Thanks