Back to the main site

World of Warcraft 'streaming error'


#1

I had been playing WoW (installed with winetricks, not lutris) with minimal difficulties with any addons or performance for the last 6 weeks. After what I believe was a hotfix yesterday, I have been frequently disconnected in a 100% reproducable way with the following message: streaming error occured (WOW51900322). This occurs when either 1) loading several addons (which addons don’t really matter, the bigger the addons, the more likely to trigger the DC) or 2) attempting to transmog (even with no addons installed at all). I am using kubuntu 17.10.

Any other wow players having issues lately? I wouldn’t ask here unless I had seriously checked all other sources…


#2

Glad I am not the only one. Lack of any info on wow forums was seriously frightening. Didn’t try to transmog, but learned that add-ons that “get info” from the server are triggering the error. For example, when I enable HandyNotes (marks of chests and rares on the map), disconnect happens when I open the map/fly to any possible location, where add-on tries to get info about “quest” linked to gathering a chest on this location. Same with other such add-ons. Purely UI add-ons work as intended.

Edit: Some thread from the official forum I just found.


#3

That addons (and transmog guy) try to get information from server and that is what is messing up is just my guess. Lets not make it lore yet.


#4

Question: Anyone in the EU have these issues? Only people I have talked with are US based.


#5

I’m on EU and I’ve had these issues since thursday or friday.
Same symptoms as have already been reported.


#6

I’m on EU aswell. Tried different combinations of wine, DXVK and windows version, no result.

Edit: topic on EU official forums.
Edit 2: topic on WineHQ forums.


#7

Fyi, this does not happen to in the BfA beta. I have no addons there, but visiting a transmog vendor and flipping though all the pages worked fine.


#8

I don’t have the error now. I have asked people to test really a lot of things, but still haven’t found anything. I keep thinking it has to do with retrieving information from the server, but somehow failing to get it correct.

Like I said somewhere before, I vaguely remember having similar issues with it some months ago (I think with same error). I would log in and get d/ced right away, I just kept logging in till I was in. I think it was around the time my connection to the servers wasn’t working perfectly, with some fluctuating ping (some spikes, and a packetloss here and there). I didn’t do anything to fix it, it was over after a while. I still suspect it had something to do with the blizzard network itself, but I can’t prove it in any way.


#9

Next question: Do you have runtime enabled or disabled? (Try enabling / disabling the runtime in Configure > system settings for WoW).


#10

Enabled runtime (unchecked the setting), nothing has changed.


#11

Ok, didn’t think it would matter. I’m fully out of ideas again then.


#12

People are reporting that logging into your characters from a Windows installation and then copying your cache folder from Windows to Linux fixes the issue.


#13

Simple copying didn’t fix it for me, but deleting Cache folder in Wine installation first did.


#14

This error occurs on my client when:

  • always in the moment I log in on 1 char
  • from time to time on the others when I either open the Map (always) or inspect people (always) or just randomly (sometimes)

It’s getting to a point where it is unplayable :frowning: Really sad, I still miss the mage tower challenge with the feral druid and that char can’t login no matter where the game masters port me.
Even a complete reinstallation didn’t work.


#15

Hi yes I’m having this error after downloading the pre-patch for BFA. I delete my cache folder, reset my wtf,Interface folders the problem still persists. On some toons I got a good 5 minutes then boom streaming error. I’m on Ragnaros -EU


#16

What do you do when you don’t have a windows installation nor want to have one?? :thinking:


#17

I answered my own question. Yay for internets

Found this on blizz forum

Windows WoW cache

it fixed the streaming error issue for me. Hope this helps others too.:point_up::point_up_2:


#18

hello yes i am having this probrom too error 51900322 ,i see people using addons which i think blizzard are trying to break successfully it seems ,and now breaking it for ubuntu users and linux users alike


#19

Download the Windows WOW cache from the link and replace it. Don’t merge or anything like that overwrite it. and you’re good to go .


#20

I’m getting this issue now too after reinstalling WoW.

No addons.

Replacing the cache doesn’t help either. Me sad :frowning:

EDIT: Cache that fixed it for me: https://web.tresorit.com/l#mD9ZiPy9-NmivJiT7OIl1Q