World of Warcraft not Starting [Solved]

World of Warcraft stopped working for me today after a game update. It works fine on my laptop (Pop! OS), but that machine has integrated intel, and is really unplayable. My desktop runs a fully upgraded (as of 18:30 PDT on 29 April, 2020, because that matters) Arch with an RX580. The only line item from the log that is from the game is *** stack smashing detected ***: terminated The rest of the lutris -d output is from lutris itself and the battlenet app. Full output at link.

SOLVED: Updated Wine version to 5.7 (others reporting success with 5.6)
My functional install on my laptop had 5.5-2, so that version also works

I have the exact same issue, using Mint 19
have had this issue before too, and it came good without intervention a few days later.
Currently I went back to windows (have it installed on seperate ssd)
Funny thing which happened last time… it classic loads fine its just retail that doesnt.
I have attempted repair of wow install, bnet repair etc… to no avail.

Same issue here as well. WoW worked earlier in the day, but it just did an update and I receive the same stack smashing detected error.

Running Ubuntu 19.10 with an NVIDIA card.

Same here Retail will not start… Ubuntu 18.04 - Nvidia GeForce GTX 1080

PTR for retail works and Classic.

Same boat Retail WoW not working, Ubuntu 18.04, was working last night around 10:30PM Central Time before bed.

Same issue here on both my computers running arch. Desktop with nvidia gpu and laptop with amd gpu. Haven’t tried classic or ptr (no ssd space) but diablo runs perfectly.

Lutris Discord Server is not responding, if they ask for logs idk how since no logs are created.

I changed the Wine version from 4. something to 5.6 and now i can get into WoW.


This fixed it for me too!

I don’t have a version 5. My latest is the 4.20. How do I install the 5.6 version? I guess I should add that I have Lutris 0.5.6 up to date (I think), but I don’t see a 5.6 wine version in my runner options

@rescue_toaster just click here to access WIne version and upload a more recent one:

at the left panel, click on “Wine” then “manage versions”

1 Like

Latest version is 5.7 WINE but I picked 5.6, thought someone somewhere said 5.7 crashes Lutris? Still trying to find that.

Awesome. Thanks. I had my left bar turned off so didn’t see the manage versions button. I installed the 5.7 and was able to get in. I can let you know if I have any issues with 5.7.

I just tested with Lutris Wine 5.6 and 5.7, last DXVK 1.6L, it works! Thank you @Scald :wink:

Wine 5.6 works great for me as well. However, when typing a “v” into the chat, it automatically types an “ö” instead (German keyboard layout).

The skill I placed on v is triggered however. Also: My skill on hotkey ^ (left from 1) doesn’t work.

American here and the v in chat is still a v so maybe that is a regional thing/issue.

I had this issue when i installed wow by choosing app in lutris, but then i switched to the world of warcraft installer it works as it should. It was annoying to say the least

Now that I think about it, I had this problem earlier with GTA:O, when using the GE-Proton version. Every “v” has been converted into “ö” in chats.

This also applies to the app right now. I am sure it is a problem that has to do with WINE and the region / keyboard.

If I find smth., I’m going to post it here.

Could you do me a favor and try to use any keyboard layout that uses an “ö” (Swedish, German, Icelandic,…)?
Would like to narrow down the problem. :slight_smile:

Thanks for this! It works for me. Changed mine to 5.7 and been running a while without issues.