Back to the main site

World of Warcraft BFA Keyboard Keystroke Problem

Hi everybody.

I have two computers (one work, one home). Everything works fine at home (i even have the same keyboard). I’m running ubuntu 19.10 on my work computer (where the problem occurs). I have world of warcraft installed and the game starts up just fine and I can enter the game world and move around. The problem here is that sometimes (commonly). A keypress will not be recognized by the game client and I’ll have to press the key again to get it to work. I have an NVIDIA geforce titan x installed with 430 drivers installed that I installed by following the instructions of the vulkan wiki:

I searched around online and there was a thread in the official blizz forums:

Here they said nvidia shadowplay was causing this issue. As far as I know the nvidia driver installed on my ubuntu machine doesn’t even support shadowplay, and the nvidia x-server driver settings application doesn’t list anything related to shadowplay. So I don’t think it’s that.

How would I go about troubleshooting this issue? I’m guessing something else is intercepting the keyboard command, but how do I know who the culprit is? And of course, how do i fix it?

Keep in mind this keyboard and each keystroke is fully functional and has 0 issues outside of the world of warcraft game client.

Edit: I just discovered some additional information. I have a wireless mouse. The problem occurs only when i hold down a mouse button, move the mouse, and press a keyboard key. When these three things happen in unision, the keyboard keypress event is not properly handled by the game client (for whatever reason, either the event is not sent, or something else). Also, this happens with my nice mouse, but also with some random usb mouse i found around the office. So it seems like its not my mouse. (And this occurs when holding down any mouse button right or left).

Thanks
Rethek

I have this exact same problem with 19.10 too, if I downgrade to 19.04 using Timeshift the problem goes away. I’ve also tried a different distro (Fedora 31) and the problem exists there too.

Wondering if the latest version of gnome has something to do with it, gonna try kde, I’ll let you know what I find.

Whats funny is this is actually the case for me. I upgraded my work computer to 19.10. My home computer is using 19.04. So I think you’re right, there’s something in the 19.10 update that causes this problem. It’s literally a game breaking bug. I can’t play. Let me know if you find any kind of setting or adjustment that can be made. I’ll do the same.

Found another post here that describes the issue:

Ok interesting. I’m not sure I agree with the other thread you linked. What I’m experiencing is not a freezing of the game, but the games inability to properly process keyboard keystrokes when three different things are happening at the same time (hold mouse button, move mouse, press key).

In my case it does process the keystroke, but the game gets frozen for a tiny but perceptible fraction of time, which is really a game killer for anyone who enjoys a smooth gameplay.

I tried other desktop environments and this seems to really happen only on gnome. I have no idea what component from gnome is causing it, but there’s definitely something odd there.

Good Morning Both,

The issue I am having is exactly has jpfarias describes - definitely a game killer. I probably miss-understood your issue rethek.

I think we have the same issue.
I’m on Fedora 31 stock, but with an amd card

Game works fine, but if you try to move …say like hitting W and D to move in a diagonal one of the keys won’t register and will not work again unless you hit the key again. (It’s hard to explain it.)

So if you’re holding W and D to move in a diagonal path, but D doesn’t work and you switch to S and D the D key will not/work ever, until you let go and hit it again.

This happens on every single version of lutris higher than 4.16. On 4.16 the game will work, but
If you change to say 4.20, it will break again.

Interesting. What I’m experiencing always includes using my mouse at the same time. It certainly does sound like we’re experiencing related issues. It sounds like the game is not recieving keypress events in some cases. I haven’t tried downgrading lutris to 4.16, but I might try it. I just opened lutris, how do I know what version of lutris I’m using? To get an old release I just go to:

right?

In the lutris window, hover over “wine” on the runners menu to the right.

There is a little box next to it and you click that to download different wine runners.

Once you’ve picked one, you right click wow and click configure.

Go to runner options and there will be a Wine version drop down menu.

From there you can change your version you want WoW to run in.

I tried on 4.16 and 4.18. The Battle.net launcher doesn’t even open on 4.16. 4.20 said it didn’t support Esync, so it wouldn’t launch anything. Seems like 4.18 (nofshack) is the only one that launches the game, and it still has this mouse move + double keypress event problem.

I experienced the exact same problem after upgrading the wine runner from lutris-4.16 to lutris-4.20. Reverting back to lutris-4.16 fixed it for me. Doing so, watch out for leftover wine processes still running after exiting the game, otherwise the battle.net launcher might not start right after downgrading.

I fixed this issue by down-versioning my wine version to:

lutris-nofshack-4.15.x86_64

Not sure what the change was that broke it for me beyond this version, but this seems to work for now.

Thanks all

I’ve been using 4.16 to avoid this issue. Both 4.18 and 4.20 don’t work.
I’ve played around with it a little bit and narrowed it down to keystrokes not registering when I click a mouse button and move the mouse at the same time (i.e hold down right click and turn around with the mouse). If I only hold down the button or only move the mouse it works as usual.

4.21 is also broken. 4.16 and below work fine.