Back to the main site

Wow mouse btn on-hold, disturbs keyboard inputs

I have played wow on Linux for years now, but I have never experienced this issue before.

If I start auto-running + hold right mouse button down + press “any movement key”

Then often the “any movement key”-input is ignored. It only happens sometimes, like 1 out of 5 times.

It seems that the more keys I hold down at same time, increases the possibility, but it never happens if I don’t touch my mouse.

I have tried running the game in Win10, using the same folder - and there is no problem.

Help me someone :smiley:

1 Like

I found the solution. Just use the following script to enable Hardware cursor:

/script SetCVar(“rawMouseEnable”, 1);

Thanks a lot for that. I’ve been using Wine 4.16 to avoid this problem until now, now I can finally use a more recent version.

I’m having the same issue.
Where would I insert this command?

Enter it in your chat while you’re logged on to your character. It is persistent as long as your game exits cleanly (i.e. you close the game rather than it crashing)

1 Like

Cheers!

I have this issue. If I hold the right mouse button key presses sometimes don’t register, especially two keypresses at once. Except I only have the issue when I’m using dual monitors (Gnome Display Settings -> Join Displays).

If I disable my second monitor (Gnome Display Settings -> Single Display) all my keypresses register. I tried using /script SetCVar(“rawMouseEnable”, 1); but it doesn’t fix the problem.

Any ideas?

(Ubuntu 20.04, running the game with lutris-4.20-x86_64)

The script didn’t work for me either. But what did fix my issue was to go to

Interface Options -> Game Tab -> Mouse -> Enable Lock Cursor to Window

This setting fixed the keyboard input issue for me.

I’m on Pop_OS 19.10 (Ubuntu 19.10) and running wow classic on lutris-5.5-2-x86_64

Just tried:

  • “Enable lock cursor to window” on 4.20
  • Upgrading to 5.5-2 without lock cursor
  • 5.5-2 with “Enable lock cursor to window”

nothing works :frowning:

Another thing I noticed with the Enable Lock Cursor to Window was sometimes when I Alt-Tab to other windows, it won’t lock unless I click out and back in to WoW. Then I have to confirm it’s actually locked into the window when I try to move the mouse outside.

I’m pretty sure this has something to do with GNOME and WINE. I would try a different DE if nothing else is working.

For some reason this works: /console rawMouseEnable 1

Whoho! Netflix and WoW all night! :slight_smile:

2 Likes

i have exactly the same issue. When i have actived Dual Monitor , my keyboard stuck in wow classic, with only one monitor no problems.
When actived 2 Monitors i wrote this: /console rawMouseEnable 1 and now its working

(ubuntu 20.04, RTX 2080 Driver 440) working with lightdm

It is still an issue after I upgraded to the latest Ubuntu 20.04. However, If I switch to KDE, it works flawlessly with no extra game settings necessary, meaning it is definitely Gnome specific. That’s a shame too, since I really like Gnome, but I like my gaming better.

I can confirm I have the same issue and setup.

  1. Ubuntu 20.04 (didnt happen in 19.10)
  2. Dual monitors using a GTX 1060 6GB
  3. My keyboard exhibits the same issue

Installing KDE Plasma via “apt install kubuntu-desktop” completely eliminates the issue for me. I am going to test with some other gtk-based DM’s like Budgie to see if it happens on that too…

Although I am not a World of Warcraft player, I do experience this exact same issue in EverQuest 2. I reached this topic thanks to some Google searching :smile: (searched for: lutris everquest 2 mouse keyboard issue)

Whenever I am holding down a mouse button and the mouse is being actively moved, the keyboard does not respond. This makes strafing around in a circle impossible, unless the mouse is moved after the strafe key is activated, which doesn’t feel natural.

I have started up xev | grep -E "ButtonPress|KeyPress" and I can see that my key and button presses are being registered when the mouse is moving around in circles.

I have tried running the game in WINE 5.7, 5.6-2 and 5.0 with the same issue found in all.

However, I only started getting this issue since installing and using GNOME. I am a long time XFCE user that wanted to try out this environment, and I am kinda liking it, minus this one issue (oh, and tray icons, but that is for another day).

If I boot in to XFCE, the problem goes away, so that is my workaround for playing EverQuest 2 for now. But it’s fairly disruptive, as I obviously must quit all my open applications, and I do real work on this computer! I have tried some other games such as Dying Light and Left 4 Dead 2 and they do not exhibit this issue in either GNOME or XFCE.

Although I’ve narrowed it down to it being GNOME, that’s a fairly broad beast, and I’m not knowledgeable enough with either GNOME, Linux, DE’s, WM’s, etc. to know how to proceed further to fixing the issue.

Anybody else able to verify my findings? Where would you go from here?

Update: Using WINE 4.15 seems to be a solution (lutris-4.15-x86_64 in Lutris Runner options). Hopefully this helps.

Update 2 (1 week later): The problem still happens every now and then, but is not 100% reproducible at all times unlike on higher versions of WINE. It is worth noting that the issue never happens in XFCE regardless of WINE version used.

You fix this by turning on “Automatically capture the mouse in full-screen windows” in winecfg.

This is already enabled for me by default, so does not fix the issue.

Oh, well it worked for me. Sorry

I am having this issue with wow classic, I can replicate the issue consistently by jumping (middle mouse buttton) and strafing at the same time. The strange thins is that the character get stuck runing forward even tho i have not pressed the forward key at all.