Back to the main site

Winesteam doesn't work on LM20/LMDE4

Hi Linux Gaming Folks!

Before i open this topic i search long times on the web and in this forum, but can’t found a solution to my issue.

To install winesteam i use this topic how-i-got-the-winesteam-runner-to-work-properly-under-lutris, no any problem with the installation.

Having choice between 3 version of wine:

  • System 4.0.2/5.0.3 (LMDE4/LM20)
  • winehq staging 5.12
  • Lutris 5.7…

Depending on the choice of wine, winesteam launches but with a black background, either nothing launches at all…

I have the same problem with playonlinux and wine after performing tests.

My config are:

LMDE4
Ryzen 5 3600
16Gb Ram
RX570 8Gb

If someone from the community would have a solution I am interested :slight_smile:

Depending on your reasons for running Winesteam, you could try circumventing the issue by using Proton (Steam Play) in the native Steam client to run Windows games instead.

On the other hand, if the source of the problem is your videocard, that probably won’t work either… Maybe try to ensure OpenGL works first?

Hi, thanks for the reply.

Steam proton can’t launch Hitman Absolution and Sniper Challenge because of the CEG DRM policy.

I have the last open source amdgpu-pro drivers and dxvk too.

After a search i see on protondb that Hitman doesn’t run well, and have an black screen with L4D1 under proton.

Not being a big gamer and having only a few games, half of which do not work properly with proton / wine / Lutris, I prefer to stay on the Linux steam client while waiting for full compatibility.

Thanks for your help :wink: