Windows installers fail immediately

I have a weird problem. When I try to install a Windows game using Lutris, the Windows installer fails immediately. It doesn’t even open a window. Lutris’ installer continues, and I end up with a more or less empty game directory. This occurs with many or all Wine games. I used to be able to install these games, but the last few weeks or months I can’t.

However, the games I already have installed run fine. So obviously Wine and my graphics hardware work.

This problem persists even if I reinstall the operating system!

As an example, I tried installing Everquest 2, which used to work great a few months ago:
lutris --submit-issue: Ubuntu Pastebin
lutris -d: Ubuntu Pastebin

EDIT: I’ve enabled 32-bit binaries (sudo dpkg --add-architecture i386). I’ve installed 32-bit libraries and wine (sudo apt install nvidia-driver firmware-misc-nonfree nvidia-driver-libs:i386 wine).
I’ve made a clean OS install on another hard drive on the same computer, using the same settings and packages. The same Windows installers fail in the same way.
I’ve made an identical install on another computer (same OS, same settings, same packages, but newer motherboard and CPU), and the installers work there (at least the ones I’ve tried).

Could it have something to do with how different CPUs handle 32-bit code? Or even 16-bit code – I’ve heard that many old 32-bit games use 16-bit code in their installers?

1 Like

This game is way too new to have 16bit code. Have you tried using another version of wine, I had problems installing a game with current wine version (6.14-3), I ended up renaming a wine folder in runners to stop lutris downloading and using that version by default.

1 Like

Thanks for the tip, @ComodoDragon . The Everquest II installer works when I downgrade to lutris-6.1-3-x86_64.
(I edited the install script, and tried all Wine versions, from newest to older, until I found one that worked.)

So in summary, Lutris’ default Wine version works fine on this machine:
Motherboard: ASUS B85M-GAMER
CPU: Intel Core i5-4460
Graphics: Gainward Pegasus GeForce GTX 1650 Super
OS: Debian 10
Configuration: proprietary nVidia drivers and 32-bit nVidia libraries from Stable

… but I need to downgrade to lutris-6.1-3-x86_64 on this machine:
Motherboard: ASUS P5E
CPU: Intel Core 2 Quad Q9650
Graphics: ASUS GeForce GTX960
OS: Debian 10
Configuration: proprietary nVidia drivers and 32-bit nVidia libraries from Stable

Do you think I should fork the script and publish it?

Regressions happen with the development branch of wine, you could leave a note in the issue section on the game page.

1 Like

Interesting! I stumbled upon the same Problem as Islander. I’m new to both Linux and Lutris but the first thing I tried (after successfully installing Pop! OS on my old gaming rig) was installing Lutris 0.5.9 and GOG Galaxy which immediately failed. (return code: 13568)
lutris --submit-issue
lutris -d

The other windows game installers I tried failed with the same return code. Trying other Runner versions for the installation was difficult (see other thread) but doable with a workaround. At first I figured out that lutris-6.1-3 was the latest Runner that works on my machine both for installing and running windows games. Then I downloaded several lutris wine versions from Github and tested if they worked on my machine. As a result I figured out that something must have been introduced between lutris-6.10-2 and lutris-6.10-3 which breaks compatibility with my machine.

As a reference I installed the same OS and Lutris versions on my little Surface Go 2 (slow but more recent CPU). Here both installing and running worked slow but flawlessly, even with the default Wine Runner (lutris-fshack-6.14-4). And I updated my old rigs system wine version to 6.20-staging from WineHQ and could successfully run GOG Galaxy with it.

Interestingly both Islanders and my rig use the same CPU, a Core 2 Quad Q9650. So I suspect Lutris’ wine fork introduced something special in lutris-6.10-3 which WineHQ didn’t use but which causes a hardware incompatibility with a Core 2 Quad Q9650 or maybe older CPUs in general. I am no system coder, but could it be that modern CPU extensions like AVX are now used in Lutris’ wine forks?!

It would be great if other users with access to machines with older CPUs like a Core 2 Quad or Core 2 Duo could try to reproduce the issue and post their results.

1 Like

Ok, I did some further testing and enabled ‘show crash dialogs’ which revealed some more information.
It seems a CPU feature (RDTSCP) is used which isn’t present in Core 2 CPUs and early Athlon 64 CPUs.
It seems anyone can open issues on Github again so i opened one there.

I am having, I think, the exact same issue.

I am playing my game on a Quad Core 2 Q6600 machine and wine builds of Lutris newer than 6.1.3 do not work and always fail with “could not load kernel32.dll” error on ArchLinux and PopOs! 21.04. However the latest wine packages (never than 6.1.3) from the distribution works.

Also, I have another machine with an i7-8565U and wine builds from Lutris newer than 6.1.3 work.

Yesterday I managed to install EpicGamesLauncher by doing the following on the Q6600 machine:

  • Download the installer json.
  • Add version: 6.1.3 to 2 wine sections in the file I have downloaded.
  • Launch lutris from the terminal with lutris -i <name of the json file>
  • Follow the installation

There is a new Wine release from Lutris 6.21 which should fix the issue with Core 2 CPUs. That new version starts fine again on my Core 2 Quad Q9650. However the fixed version is still not used by default with installers.

1 Like