Select default wine version for installation

Hey guys,

currently I’m experience some issues with the wine version “lutris-6.0-rc1”. Expecially annoying is it that lutris want to install all new games with this version and if i deselect this one in my version manager, lutris start to download this version again and try to install the game with it which causes installation errors.
I don’t want to use “Lutris-6.0-rc1” for new installations. How can I configure another default?

Best Regards

Burger menu > Manage runners > scroll down to WINE > click on the settings icon (configure runner) > set your preferred default WINE/Proton version and click on save

Hallo Pix0wl,

thank you for your feedback. Unfortunately this is not working. Lutris displays me that “Lutris-5.7-11” is now default but when I want to install a game he tries to install Lutris-6 again. If I cancel the download lutris also cancel the installation.

Weird, that sounds like a bug to me. A bug which I cannot reproduce.
For me the configured Wine or Proton version is used, although in the drop-down menu lutris-6.0-rc1 is still tagged as default. FYI: I’m using Lutris v0.5.8, which seems still a little buggy. :slight_smile:

You could try to edit the Wine.yml at:
There the default version is defined among other Wine related parameters.

Maybe it also helps to delete the Wine version (lutris-6.0-rc1) directly in the directory:


Unfortunately this didn’t solve the Problem either. Only the Lutris-5.7-11 version is available in the folder “/home/[USERNAME]/.local/share/lutris/runners/wine/” and the .yml file also only contains the Lutris-5.7-11 version.

And i tried to install again a new game but Lutris still want to install Lutris-6

This behavior is really strange… hopefully you have any further good ideas.
Thank you for you help in advance!

Best regards

Well, I’m out of ideas.
I would recommend you to open an issue at the Github repo.
The chances to solve your problem there is much higher.


Also, experiencing this issue. Trying to install on an older version of wine due to regressions.

I would recommend you to open an issue at the Github repo.

Unfortunately, you can only submit a bug report if you are a contributer: An owner of this repository has limited the ability to open an issue to users that have contributed to this repository in the past.

Also have this exact issue on Debian 10 X64…

And for sure, Github also no available to me…

I figured out that if i click on Preferences, Lutris does crash on segfault, do you also have this ? @spawnofmayhem @TheBridge

The only way to use another wine version for install than the latest one if to specify it in the script installer.

For example, put at the end of the script installer:

  version: lutris-5.7-11-x86_64

But you are right, an option to choose the default wine version for installing script installer will be nice feature.

@legluondunet i’ve used your suggestion creating a draft install script following to testing it. It’s does work very well for INSTALLING app but when come to launch the app, there is what i see :

lutris -d
2020-12-21 11:24:32,264: Initializing lutris
2020-12-21 11:24:32,797: Runtime up-to-date. Initialization complete.
INFO 2020-12-21 11:24:32,807 [application.do_command_line:314]:Lutris
INFO 2020-12-21 11:24:32,807 [startup.check_driver:49]:Using NVIDIA drivers 450.80.02 for x86_64
INFO 2020-12-21 11:24:32,808 [startup.check_driver:53]:GPU: GeForce GTX 980 Ti
INFO 2020-12-21 11:24:32,808 [startup.check_driver:69]:GPU: 10DE:17C8 3842:4992 (nvidia drivers)
INFO 2020-12-21 11:24:37,785 [runner.use_runtime:280]:Runtime disabled by system configuration
DEBUG 2020-12-21 11:24:37,914 [displayconfig.get_current_resolution:621]:Retrieving current resolution
DEBUG 2020-12-21 11:24:37,914 [prefix.set_virtual_desktop:204]:Enabling wine virtual desktop with default resolution of 3840x2160
DEBUG 2020-12-21 11:24:37,943 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/system32/dxgi with DXVK version
DEBUG 2020-12-21 11:24:37,945 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/system32/d3d11 with DXVK version
DEBUG 2020-12-21 11:24:37,946 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/system32/d3d10core with DXVK version
DEBUG 2020-12-21 11:24:37,947 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/system32/d3d9 with DXVK version
DEBUG 2020-12-21 11:24:37,948 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/syswow64/dxgi with DXVK version
DEBUG 2020-12-21 11:24:37,949 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/syswow64/d3d11 with DXVK version
DEBUG 2020-12-21 11:24:37,950 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/syswow64/d3d10core with DXVK version
DEBUG 2020-12-21 11:24:37,951 [dxvk.enable_dxvk_dll:177]:Replacing /home/eric/Games/starcraft-ii/drive_c/windows/syswow64/d3d9 with DXVK version
INFO 2020-12-21 11:24:37,952 [runner.use_runtime:280]:Runtime disabled by system configuration
Erreur de segmentation

Hello eric1212.

No, luckly I can see the preferences without any issues.

Hello Legluondunet.

I have tried to add the version to the installer-script and it is now working fine. Thank you very much. Is there a possibility to provide this as a feature request to the developers?

the better solution will be to code the feature and submit a patch to Lutris dev team.

I probably have more than 1 issue. Your software did install but are you able to run it ?

Yes. My game is running properly.

I just wanted to say this is SO frustrating. I tried to do what everyone else told me to do. Add it to the script or manage the runners. None of that worked. WHAT DID was laughable. I actually renamed my latest version of wine to the one i wanted it to install with. THAT WORKED. Jeez! FIX THIS! Very frustrating when you are on a ps4 running linux oh nevermind!

Same here. When trying to install anything in Lutris 0.5.9 it always uses the lutris-fshack-6.14-4-x86_64 Runner, no matter what I choose in the manager. Editing the installscript to specify another Runner doesn’t seem to work either. Renaming the directory of the lutris-6.1-3 Runner (Which actually is the last Runner which works on my machine, but that’s another issue.) to lutris-fshack-6.14-4-x86_64 actually works to install something in Lutris on my machine. But this seems like a very bad workaround. It would be much more intuitive if Installers would actually use the Runner specified in the manager. I think this issue is worth to be fixed, but as I am no contributor (just another linux newbie) I can’t open an issue on github.

I’ve opened issue #3961 as I had the same issue. As for github, I only had to login, nothing else.