Unable to install Cyberpunk 2077

I’m attempting to install the GOG version of Cyberpunk 2077, and as per the “Please read before asking for help” guidelines (Please read before asking for help), I’m trying to get the logs, but running “Lutris -d” through a terminal gets me a version that doesn’t look meaningfully different from running it by itself- and critically, doesn’t have a sidebar with a “show logs” option; indeed, I can’t find an equivalent anywhere (though I’m certainly willing to accept that I’m just missing it). Installing a handful of older games gives me the option with those, but it doesn’t seem to be possible with titles that failed to install. So unless I’m missing something there, I have no logs to share.

Here’s my hardware:
OS: Pop!_OS 22.04 jammy
Arch: x86_64
Kernel: 6.5.4-76060504-generic
Desktop: pop:GNOME
Display Server: x11

Vendor: AuthenticAMD
Model: AMD Ryzen 5 5500
Physical cores: 6
Logical cores: 12

RAM: 31.1 GB
Swap: 20.0 GB

Vendor: AMD
OpenGL Renderer: GFX1102 (gfx1102, LLVM 15.0.7, DRM 3.54, 6.5.4-76060504-generic)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 23.1.3-1pop0~1689084530~22.04~0618746
OpenGL Core: 4.6 (Core Profile) Mesa 23.1.3-1pop0~1689084530~22.04~0618746
OpenGL ES: OpenGL ES 3.2 Mesa 23.1.3-1pop0~1689084530~22.04~0618746
Vulkan Version: 1.3.204
Vulkan Drivers: AMD Unknown (RADV GFX1102) (1.3.246)

The specific problem I’m having seems to be “RLIMIT_NICE” being less than 20:

; I’ve tried multiple times, changing the few simple options I understand, and that’s the one consistent factor (often the only problem). As I’m sure many of you can relate to, moving away from the operating system you’ve used since you were a toddler is a… challenging experience, but I DO know enough to realize that just screwing around with niceness Rlimits (whatever those are) would probably just make things worse- so I appeal to the experts.

Yeah Nah - that is not your issue

lutris -d launches lutris in debug mode with the output in terminal. Start your install, when it fails, grab the terminal text to pastebin or something and drop the link - those logs are for the most part not very helpful

Also, in lutris, click the three lines on the title bar->preferences->global options->enable Advanced and make sure that the vulkan ICD loader field is not set to unspecified

Okay, cool. I changed the Vulkan ICD loader field, as you instructed, and got a the same error message.

Here’s the pastebin of the terminal text: https://pastebin.com/mMJn2ceB

Your pastebin has gone AWOL - 404 error

Yes it has- stupid remote text hosting. Trying again…

Can you jump over to the lutris discord server from the link on the main lutris.net site?

Pastebin is useless

Unfortunately, no; Discord’s not an option for me. Is there another way?

try another service or file share service - pastebin is just giving 403 or 404 errirs

Okay, this one’s working for me even on other machines: https://pastes.io/qhbss2kpjj

Check that this location and file exists:


I think the file name is wrong

The name is correct; the location didn’t exist. I created it, copied the file, and am installing… same problem. Attempting installation using the installer file in the newly created folder… progress! It’s telling me part 25 of the file is corrupted, so I’ll need to redownload; I’ll try again in the morning, after it finishes.

In the meanwhile, thank you for the help you’ve provided me; I doubt I’d’ve figured this out on my own.

1 Like

Good luck

Okay, after redownloading the corrupted file, I tried again, and got the same result. Then I moved ALL the installation files to the .cache/lutris/installer/etc. directory, and got a new error:

Here’s the log: https://pastes.io/knl4cawvwx

I asked on discord for you, best response was try Heroic and see if it installs there.

Thanks- I’ll give it a shot.