Back to the main site

Torchlight II won't launch through Lutris

I’m having a weird issue where the GOG version of Torchlight II won’t launch, but only when I launch it through Lutris. Double-clicking the executable works just fine.

Just tested the installer. The executable path isn’t set correctly. It points to a directory and not the start.sh script.

Go into the game’s settings and under Game options set the Executable path to [root-of-game]/start.sh.

I’ve changed and submitted the script.

The script is now validated, thank you all 2.

No problem, nice to help the community.

Did the blade runner one too.

That still doesn’t work for me. I tried running all the different executables through Lutris:

  • /start.sh
  • /game/Torchlight2.bin.x86
  • /game/Torchlight2.bin.x86_64
  • /game/ModLauncher.bin.x86
  • /game/ModLauncher.bin.x86_64

All of them say this in the Lutris console when I launch them:

FMOD detects no hardware acceleration!
free(): invalid pointer
Game is considered exited.
Initial process has exited.
All children have exited.
Exit with returncode 134

Weird. And you placed the correct path as can be seen here?

Lutris is just a front-end. If you can run it from outside Lutris, you should be able to run it from Lutris.

You are running Lutris as your own user and not as root?

Yep. I’ve tried multiple executables and none of them work through Lutris.

Yeah

Got a little bit further with this one. I noticed that the sound wasn’t working while it did when running start.sh from the command line.

There are two bash scripts, both made by GOG: start.sh which uses gog_com.shlib. These two set the correct LD_LIBRARY_PATH variable to the correct libraries directory of the game.

Somehow there is a incompatibility between this script and how Lutris handles the launching of the Linux runner…

Got it to run with sound. I had to disable gamemode by unchecking the option in the Lutris System options screen for the game and making sure that gamemoderun was not in the Command prefix field.

Progress. I disabled Prefer system libraries and Enable Feral gamemode and now the launcher starts, and I can launch the game. One problem, all the character models have this weird flickering effect:

Does this happen too when you start the game from the terminal?

Do you mean when I run it outside of Lutris? No, it doesn’t.

Then the driver stack must be ok.

So why is Lutris causing this? Every option in my Lutris System settings are switched off…

Anything in the logs?

The logfile is really long, and I can’t really figure out if anything in it is relevant, but here it is:
https://paste.centos.org/view/9dddd185

We are very close on specs.

You:

 *  CPU ID: GenuineIntel: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
 *  SSE: yes
 *  SSE2: yes
 *  SSE3: yes
 *  MMX: yes
 *  MMXEXT: yes
 *  3DNOW: no
 *  3DNOWEXT: no
 *  CMOV: yes
 *  TSC: yes
 *  FPU: yes
 *  PRO: yes
 *  HT: no

 * AMD AMD Radeon RX 5700 XT (NAVI10, DRM 3.36.0, 5.6.6-arch1-1, LLVM 10.0.0)

 * Res=1920x1080

 * Esync=on

 * Distro=Arch

Me:

 *   CPU ID: GenuineIntel: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
 *   SSE: yes
 *   SSE2: yes
 *   SSE3: yes
 *   MMX: yes
 *   MMXEXT: yes
 *   3DNOW: no
 *   3DNOWEXT: no
 *   CMOV: yes
 *   TSC: yes
 *   FPU: yes
 *   PRO: yes
 *   HT: no

 * AMD Radeon RX Vega (VEGA10, DRM 3.36.0, 5.6.7-300.fc32.x86_64, LLVM 10.0.0)

 * Res=2560x1440

 * Esync=off

 * Distro: Fedora 32

Maybe Esync is the first one to try. For instance, is esync also on when the game is started from terminal?

Edit:
Not ESync but VSync…

Can ESYNC be enabled for native games?

Oh sorry, I think I’ve misread ESync. It’s VSync. And that is an option in the games options screen. I’ve toggled it but it doesn’t make a difference on my laptop. That’s an Intel graphics chip. I have to test it on my desktop.

It appears that “Hardware Skinning” is the issue. Enabling everything but that setting removes the flickering. The problem is, I want that setting because it apparently drastically improves performance.

I have that option too and its on… :thinking:

Did you have the flickering issue too?