Back to the main site

Titanfall 2 does not install on origin

Hello! My error is: trying to install a titanfall 2 and nearly “Playable” progress give error 327682:11, what is on https://github.com/lutris/lutris/wiki/Game:-Origin similar as a “.NET fails to download”, but titanfall 2 not use .NET libraries at all
Try do this(same error):
1.All on https://github.com/lutris/lutris/wiki/Game:-Origin
2.Different kernels: 5.2, 5.3, 5.4
3.Changing wine from 4.16 to 4.18(also lutris version)
lutris -d: https://paste.ubuntu.com/p/jV8X9yNKmG/
System: https://paste.ubuntu.com/p/5TDyNpKnwh/
Now check how installing apex

I got it downloading completely after I changed the wine version to lutris nofshack 4.19, then I switched back to lutris 4.16 when the game was installed

Thanks for help, but I update origin too and not sure that your method is working

Did you run the update script in the origin directory? Right click on Titanfall 2 and click on “browse files” when inside, run “./updateorigin.sh” inside a terminal.

I used that script, but raised error “install update or stay in offline mode”

@mishkaGame I had the same issue installing Titanfall 2. One percent before “Playable” the installation would fail with error 327682:11. There’s a lot of posts about Apex Legends giving similar errors, so it might be a Respawn issue with the way they handle their DirectX install.

The Lutris Origin troubleshooting page has some good suggestions, the “DirectX fails to install when finalizing a download” seems to be the issue, because the game is getting installed (i.e. finalized) at the “Playable” point instead of the end.

What worked for me was to wait for the installation to hit one percent prior to the Playable percentage (so if playable was 47%, do this at 46%), and delete all the *.cab files from
/drive_c/Program Files (x86)/Origin Games/Game Name/__Installer/directx/redist

It took a couple tries to get the timing right - if you’re too early the cabs are still staged. I’m still not sure why this worked, it is incredibly awkward and fiddly.