Strange problem with my French keyboard

Hello,
I recently got a problem with my French keyboard, I can’t understand why since for a long time all worked fiine.
I play WoW with lutris under linux (Debian 6.5.13-1), currently with wine-ge-8-25 but my problem first appeared with previous versions.

The actions in the action bar corresponding to french characters ( action 2 : é, action 7 : è, action 9 : ç) do not work anymore (no effect). However within WoW messages or menus these characters are correctly taken into account. Except that it is not possible to specify them as action shortcuts in the option menu.

Same thing for all versions of WoW (Dragonflight, Classic…). I previously sent a message on Blizzard forums, without any answer.

My current workaround : toggle azerty/qwerty during the session when necessary. Not very pleasant.

Any explanation would be appreciated !

Thanks in advance for your help.

Ronchon65

je crois que c’est un bug de wine, je l’ai vu mentionné y a quelques temps et ca relève visiblement du cas par cas en fonction des jeux.
cela dit t’as une option dans la config du jeu sur lutris pour basculer sur un QWERTY uniquement sur le dit jeu donc ca évite les transitions intrusives.
je connais pas d’autre solution, malheureusement dans le gaming et surtout dans l’info beaucoup trop de devs s’en battent les couilles des dispositions autres que le QWERTY…

image

J’ai eu un problème similaire jusqu’à il y à peu (il c’est resorbé tout seul, aucune idée de pourquoi), je pouvais pas utilisé ma touche é sur la plus part des jeux qui utilisait wine (ff14, path of exile). ce qui étais le plus étrange c’est que cette dernière fonctionnais dans le chat. Ton cas est peut être similaire?

Merci pour la réponse. Le problème de cette option de config, c’est que c’est fait pour toute la session. Pour entrer ensuite des messages ou des choix dans le jeu, ça devient malcommode si on a pas le clavier qwerty dans les doigts. Je l’ai eu, mais il y a longtemps…

Le bug wine est probable, cela dit. Je peux aussi tout de même paramétrer les raccourcis avec des caractères “neutres”. Ça perturbe les réflexes, mais bon.

Merci pour la réponse. Ça ressemble, mais j’aimerais quand-même trouver l’explication :slight_smile: Ou alors un “workaround” moins pénible que le mien.

es-ce que le moteur supporte les configs comme sur source ? par exemple +exec custom.cfg ?
y aurait peut être moyen de contourner l problème via un script qui s’éxécute en jeu quand tu presse une touche ?
je sèche un peu autrement

Je vais regarder, mais je n’en ai pas l’impression.

Ehy, I’m on Arch and some hours ago updated Lutris and other programs. I encountered the same exact problem with the Swiss French keyboard after the update. Basically it happens only for the keybinds.
Did you perhaps find a solution? I tried various steps but I’m unable to solve the problem

I think it’s useful to add, it’s not a french keyboard only problem, since even characters such as äöü are not detected, I guess every non-ASCII character is gone

Bonsoir, je j’ai le même soucis, PC neuf, Ubuntu 23.10, lutris 0.16 et wine-ge-8-25_x86_64.
les touches é(2), è(5), ç(9) et à(0) ne fonctionnent plus pour le binding/raccourcis. C’est la loose, difficile pour moi de jouer sans.

Dans le chat cela fonctionne correctement. ca sent le passage par 2 couches logicielles différentes entre chat et jeu.

Sur mon précédent pc (avec le même clavier) en Ubuntu 22.04 et lutris 0.12 et wine-ge-8-15_x86_64 aucun problème de ce genre.

Si qq a une solution je suis preneur. Pour le moment je bascule en clavier ‘en’ sur wow (mais je perd la touche ² que j’utilise aussi bcp dans le jeu, donc ca reste un compromis un peu pourri)

Edit : J’ai installé la version wine-ge-8-15_x86_64 (qui nécessite WINE_SIMULATE_WRITECOPY=1 pour fonctionner), et j’ai le même problème alors qu’avec la même version wine je n’ai pas de soucis sur mon autre PC => ca n’est peut être pas que wine le problème ? Je tenterai lutris 0.12, et un maximum config identique (options système et wine sous lutris) voir si j’arrive a discriminer d’où cela provient.

Similar issue for myself as well on a Swedish keyboard, but I’m not running WoW through Lutris, I’ve been trying to run Overwatch through Steam. The root cause might be related?

In my case, the problems apperar because I’m left handed and I use PLÖÄ instead of WASD, so that Ö and Ä don’t work. It’s weird, because the game will let me bind the keys, but then won’t recognize them if I actually try to use them in-game. It’s as if Overwatch uses a different API to recognize the keys in the bind screen compared to in actual gameplay, and Wine handles these two API’s differently somehow.

I’ve not tried changing to a US keyboard layout just yet, but I’m pretty sure it will work, and if Lutris has an option to auto-switch to US keyboard on launch, that seems very convenient, I might give it a try.

As for @dagoonk, I suspect the reason you’re losing your ² key is that the “en” keyboard layout is a US one which uses the 104-key ANSI layout. Maybe try using a UK keyboard layout instead will let you use this key instead, because the UK keyboard is 105 key ISO? Of course it’s not an actual solution but it might help you use all the keys on the keyboard for this game in the meantime.

Thanks for your answer. You are right, the problem appears for all non-ASCII characters, but only for action bindings. Chats are not affected, nor textual menus.
I have no solution for now, except toggling to a english keyboard when playing WoW (and back to french keyboard for chatting). Quite boring.

Merci pour votre retour, je me sens moins seul :slight_smile: À noter, comme je le disais dans mon premier message, que les caractères non-ASCII ne passent pas non plus dans les paramétrages du menu option, ce qui est bien frustrant.
Vous avez apparemment fait plus de tests que moi, le dernier que vous mentionnez est particulièrement intrigant, c’est aussi la même version du système sur vos deux PC ?
Je suis également preneur d’une solution !

@pv2b You are correct, ‘²’ key works with UK version (but still not in French version). Thanks now I can dispel quickly !

@ronchon65 J’ai une ubuntu 22.04 sur l’ancien PC, avec lutris 0.12 et wine-ge-8-15_x86_64 et tout est OK. Le nouveau est sur ubuntu 23.10, et avec lutris 0.16 et wine-ge-8-15_x86_64 (ou la version courante 8.25) et j’ai le problème.
Je peux tenter la lutris 0.12 pour voir, mais je doute que cela vienne de là (au final il ne fait que lancer la meme ligne de commande wine, avec la meme version de wine). Du coup j’avoue que je suis sec.

Pour le moment, j’ai du coup configuré gnome avec 2 claviers (fr et en/gb). J’ai activé l’option “Basculer les sources de saisie individuellement pour chaque fenêtre” (gnome/Paramêtres/Clavier) et avec la combinaison de touches windows+space je bascule dans wow entre les 2 claviers, selon que je suis dans le chat ou que je joue. Et quand je joue, le seul raccourci que je n’ai plus est shift+², donc j’arrive à survivre avec cela. Mais bon c’est quand meme frustrant comme problème…

D’un autre côté, je ne vois pas comment ça pourrait venir du système, sinon par un biais extrêmement tordu. Mais peut-être: vous êtes sous Ubuntu, je suis sous Debian, il y a beaucoup de choses communes.

Pour ma part j’ai deux écrans sur mon PC, je joue sur l’un et sur l’autre j’ai mis des lanceurs pour basculer mon clavier entre fr et en (et éventuellement tout tuer quand ça plante). Il faut juste désactiver la capture de la souris :slight_smile:

Bonsoir, de mon côté aussi j’ai récemment eu des soucis d’agencement clavier (fr) dans certains jeux lancés via lutris.
Note : j’utilise la version flatpak de lutris, et j’ai l’impression que l’activation de gamescope empêche l’application du réglage “paramètres régionaux”.
De mon côté, j’ai contourné le pb en laissant paramètres régionaux à “Système (par défaut)” et en préfixant le lancement de lutris avec cette variable d’environnement :
XKB_DEFAULT_LAYOUT=fr /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=lutris --file-forwarding net.lutris.Lutris
Ainsi le bon agencement fr-azerty est utilisé (y compris les caractères spéciaux &é"…).

Bonjour, merci pour votre retour.

J’ai tenté XKB_DEFAULT_LAYOUT=fr en lançant lutris.

Dans mon cas le tout premier appui dans le jeu sur une des touches coupables fonctionne (touche 2 par exemple), mais pas les appuis suivants. Sans la variable d’environnement, même le 1er appui ne fonctionne pas…

Je ne sais pas encore quoi faire de cette information, mais ca me semble intéressant à noter.

Bonsoir,
J’ai essayé, c’est sans effet pour ce qui me concerne, que ce soit sur le premier appui ou sur les suivants…