Back to the main site

Steam Fatal Error while updating it

Hi, I’m new on Linux so I’m quite unexperienced.
When I try to run a game with wine steam I get the following error:

Steam - Fatal Error
Steam needs to be online to update. Please confirm your network connection and try again.

I can confirm that I habve network connection and I tried with different versions of Wine

So I need help

System Specs:
16 GB RAM DDR4
Intel Core i7 7700
GTX 1060 6gb

I have the same issue. Running lutris -d gives me this output:

“Aborting HTTP request because we received a response with a content-length over 64M and we are not streaming[2019-06-26 18:25:03] Error: Download of package (resources_all) failed after 0 bytes (200).”

@deliverance37 I have a suggestion to fix your problem, Update Steam on a Windows machine, copy the Steam files, past update Steam files into your Wine Steam bottle. I have read a few people have fixed the same issues by doing that.

This worked, thanks a lot.

@Shadowbane New to the community here. Which files/directory from a Windows Steam install do you mean and what directory would I copy them to in my Lutris directory structure? I’m excited to get my “Wine Steam” instance working to play a few Windows games that have been sitting my Steam library.

@hermayneMUNSTER I would first try and find a better way than I suggested to update steam. The reason being it probably is a very tedious process involving checking and replacing individual files. There is someone in a different post who came up with a better way of updating Steam if I come across the post I will link it here. I can’t create a way to fix Steam error’s on Linux because of the only graphics card I have isn’t supported by that latest version of Lutris. I suppose if I could find a version of Lutris and Vulcan that supported Nvidia’s 390 drivers then I could make a guide.

I came across this guide that tells you step by step how to install Windows Steam using Lutris called Install Windows Steam on Linux using Lutris. I don’t know if the guide will help because I can’t use Lutris because I can’t find a version of Lutris that is compatible with my graphics card. The only advice I can give you is never run a command as root always use sudo. I also came across another guide that may be of use called How To Use Lutris To Play Windows Games On Linux (Quick Start Guide).

I came across the post I was talking about earlier here is the link Wine steam can’t update due to download error

@Shadowbane Thank you for your reply!

Understood about the tedious process. I’ll take a look at the Wine steam can’t update due to download error guide and then go from there researching the other guides. I greatly appreciate the assistance! Thanks!

I’ll report back what I come across, thanks again!

@Shadowbane Here are my results!

I used the instructions @acourtney87 had listed in the Wine steam can’t update due to download error thread:

  1. Download the Windows version of steam
  2. Install Steam via command line with Wine
    wine start ~/Desktop/SteamSetup.exe
  3. Start Steam via command line with Wine, if installed to default location, let it update then exit
    wine start ~/.wine/drive_c/Program Files (x86)/Steam
  4. Launch Lutris and click on the cog icon next to Runners to go into the configuration section
  5. Open the settings for the Wine Steam runner
  6. The very first option in the Runners tab should be “Custom Steam Location.” Browse to the location of your Windows Steam install in your default Wine prefix and select it (should be “~/.wine/drive_c/Program Files (x86)/Steam” if Steam was installed to the default location)
  7. Go back to Lutris and search for the Steam game you wish to install and follow all the prompts from Lutris (A couple games won’t show progress, just let it run and do its thing)
  8. Everything should work from here on
  9. Trying to Start Halo: Spartan Assault but it does hang. Looking into that to see what the logs say.

Well, HermayneMunster I see you are making some progress if you still are having problems with installing some games I would suggest reading Please read before asking for help and follow the steps it suggests there.

Thanks for the solution!!