Back to the main site

Starfall Online

I am trying to run this game under lutris, but it have some problem.
First problem was with runtime for wine runner.
To solve it i build tks-protonofied-faudio from git on my system.
It solve problems with runtime, but game crash at start.
Lutris -d log is near 71Mb so i can upload it to pastebin.com or paste.ubuntu.com
game internel log here

I have try some latest ge-* wine runners from lutris and best result with ge-protonified-nofshack-4.9-x86_64.
Game start but with black screen.
If switch to another window and back, game window come with some garbage.
I wait for 2-3 minutes before stop via lutris.
lutris -d log here
And game internal loghere

Game is alfa version but under win it work.
For compare here game log from win (i only start it and exit).

The error at the end of the log is exactly the same as right here (a negative HResult at WindowsMovieStreamer.cpp:588) so you’re kinda back to where you started.

The error happens within UnrealEngine source (which is closed to non-subscribers), so I can’t take a look at what could be the error source, so my best guess is it might be caused by a codec (which could be fixed by installing codecs into the prefix via Winetricks). The only thing I can say for sure is that I couldn’t find any mention of that particular error anywhere else on the Internet. Perhaps you can get some info by contacting developers of the game?

I write on game forum, hope developers will answer soon.

Developers give some info on error, according to file and line error caused by
IMFMediaSession::SetTopology()
Is there a way to turn on details wine log only for media foundation replacement?

If you know what you’re looking for you can grep for it, but it’s probably better to search for it within the full log to see the context. As for selective logging, that sounds kind of too complicate to implement.

Regarding MediaFoundation library, it’s present in Winetricks (under the name mf), so you can actually try to install it first (if you’re lucky that will suffice). Although it’s not always enough apparently; since it’s an open issue in Winetricks, it seems that it can only be circumvented by hand currently.

grep will help in full log.
But i hope that mf have separated debug channel.
Thanks for links, i will try it.

With manual installing mf by this instruction, i get new problems.
When attempt to regist msmpeg2vdec.dll (and msmpeg2adec.dll) by command wine64 regsvr32 msmpeg2vdec.dll, if exact by this command
LANG=en_US.utf8 WINEARCH=win64 WINEPREFIX=/home/nemos/Games/starfall_online ~/.local/share/lutris/runners/wine/ge-protonified-nofshack-4.9-x86_64/bin/wine64 regsvr32 msmpeg2vdec.dll

regsvr32: Failed to load DLL 'msmpeg2vdec.dll'

full output here

regist by command wine regsvr32 msmpeg2vdec.dll work fine.
msmpeg2vdec.dll i take from win7 x64 from path Windows/SysWOW64/

Have you tried just placing the file into system32 folder of the wineprefix? Or into the game folder, for that matter? That certainly seems to be the purpose, anyway.

Yes i try, no effect.
I also wait for some new wine runners (ge-*-4.10 and lutris-experimental-4.10) and test them.
They don’t even go for black screen. Assume they don’t have some patches that was in tkg builds.
Some gamers was able to run this game in virtualbox, i will try this as temporal solution.
Hope in future i will be able to run it under wine or native client will be released under linux.

If the game gains popularity and/or becomes more stable as it moves towards proper release, it’ll probably get a WineHQ page, and someone might write there how to make it work. Until then, forum of the game or whatever they have is likely the only place where you can find any tips on how to make it work when it doesn’t.

…I guess I have it easy, not buying early releases and not caring much about newest games out there.

I’ve done it.
Option with virtualbox was wrong. Virtual box give only directx 9, game engine need directx 10.
I return to lutris with wine (ge-protonified-4.10). I analyze it’s logs and problem was in sound libraries again.
I enable option disable lutris runtime and all works now.
There some lags, but most likely because i run it from hdd not ssd. I will check it later.
For testing i use fresh created wine prefix, without any hacks from winetricks or any manual hacks.
I play for 30 minutes for testing.

You should try to make a Lutris installer for it then, so that when others want to play it they don’t have to go through the same problems :slight_smile:

I will make it soon :slight_smile: