Back to the main site

Star Trek Starfleet Command III

Thank you for the input. I believe it is some kind of scaling issue. One difference I noticed between the 1024x768 resolution on the vanilla and modded version is that the vanilla version displays from the top of the screen to the bottom while the modded version is slightly squashed. This explains the mouse offset. Just a matter of playing around with it to get it displaying properly.

Are we talking about the same gog version ? Because it does not work for me out of the box.

Yes, dont use the updated gog file and use the launch version.

Tested it on my laptop this time.

Only things I had to do is set the executable path and the path to the WINE prefix. As for some reason these weren’t set.

Specific to my system: I set System / Enable NVIDIA Prime Render offload to true as I have a laptop with an AMD 5800H APU (Desktop) and a NVIDIA 3050 GPU. This option sets the __NV_PRIME_RENDER_OFFLOAD=1 and __GLX_VENDOR_LIBRARY_NAME=nvidia environment variables to instruct the system to use the NVIDIA GPU.

Installing…

Installed…

Running…

The mouse is still offset to the left. Hovering the cursor left of the buttons lets me click them.

lutiris script or just installed in wine

Lutris script installed via Lutris.

i only install games in wine myself i have my own Gog, Steam, epic, Uplay folder. i do everything Manuel for 2 reasons 1. learning (the best way of learning is by doing it yourself) 2. Control (i control the environment and know how it set up)

i have the game on gog so i can give a crack at it.

They released a update yesterday, going to try it one more time. I still get the same errors as i got before, Unable to save model cache issue still present + i don’t even see the mouse at all. I wonder what i am doing wrong.

  1. Installed the gog installer using wine
  2. After installation i open Lutris and select select the sfc3.exe
  3. These are my settings

After i press oke i get another error

Edit 2: I get the same errors when i add this game as custom game in steam using proton. When i fire up the game using steam proton it skips the videos, skips the menu and it enters the lan lobby, when i hit back the game crashes. This is the only game i did not get to work under linux and it gives headache. If there is no solution i trash this game for good.

Got somewhat further. I got the Cache error again and found that installing the d3dxof winetrick still works. I’ll make a change to the GOG installer to include it.

The mouse issue persisted until I rebooted my system and ran the game again. Then the mouse suddenly was centered.

All Lutris settings are default except for my NVIDIA setting which is specific to my system.

I also left the dxcfg.exe / dxcfg.ini settings default.

I noticed there are two versions of this game on Lutris. I’m focussing on the one with the slug star-trek-starfleet-command-iii.

This one didn’t have a dedicated GOG installer. I’ve added it as a installer which installs the GOG version as it is. Thus without any 3rd party stuff.

The game is running quite nicely over here!

Can you share that file ?

No sharing necessary.

  • Click on the little arrow button next to the WINE icon to show the WINE related options.
  • Then choose Winetricks.
  • Then the Winetricks widget will show. Choose default WINE prefix.
  • Then choose install Windows DLL or component
  • Scroll down until you find d3dxof, check it and click OK.

After it installs keep clicking cancel until the tool exits.

1 Like

I will try tommorow, thanks.

Good luck sir!

1 Like

Has anyone been able to get this to run at 2560x1440?

I installed the 3.3 mod last night with the CD version using the Win10 install script from @tfk. Unfortunately, the game screen was cutoff at different points, depending on which resolution I tried. I must be missing something, since I can’t even get the mod to work at 1024x768. Does it work with the GOG version?

I’m now on my laptop which works at 1080p. Can’t go higher for the moment. The GOG version uses a patch 1.1 and an AMD patch. Those patches can be found on the web. GOG just bundled them to make it work for Windows 10 users and we Linuxers are riding along on this bandwagon.

This thread started once when the GOG version wasn’t available yet. And we used the version from myabandonware.com and patched it with a patch which was probably listed there.

If you want to mimic the GOG version I would recommend using the same patches as they are using.

This is what GOG installs:

The RDNA fix does not show cursor at all on my side. Any fix for this ??? the prefix works as you said thanks.

I installed only this and it seems to include this fix. I’m still investigating why the offset cursor was fixed after a reboot. It is visible though.

Funny thing is that I saw this missing cursor issue when testing other old games.

image

For this game I found this post which is interesting. Someone running it in a virtual machine. There is a cursors.txt file this user renamed which switched the cursor to a stock variant. Maybe it is rendered by the game engine and renaming this file bypasses this rendering?

I am looking for almost 2 hours “again” to fix this game…i spend to many time onto this one again. GoG release is crap, launch version worked but i had the error as said yesterday. Then gog released the amd patch which broke my game and the rna fixed it again but removed the cursor…i am tired of this game already. Even if i would get it fixed i already hate it duo all these problems in linux.

The above solution i also tried and did not work…i even tried to download a crack to see if it would be a exe problem which it is not.

I am a nvidia user by the way

Yep, resurrecting old games is a totally different ballgame altogether. For me its a game in itself. But I can see that its a bit frustrating for users who just want to play.

We Linuxers are not alone in this. Take a look at this. Most of those posts are from Windows users.

https://www.gog.com/forum/star_trek_starfleet_command_iii/page1#1642144784

Another comment section with a few frustrated users:

More current games are much more straight forward because they all use common and mostly current DirectX apis. With these games we have to deal with very old versions of DirectX, 3Dfx, etc.

On my laptop I’m a NVidia user too. I run this game on my 3050. I only ran the default installer BTW. No manually installed patches. I did do a clean install of the game with each test though. Why the mouse cursor chose to work all of a sudden is still a bit of a mystery.

Got it finally to work. I renamed the .wine folder so lutris could recreate a new one. I downloaded the d3dxof using winetricks. I changed the runner in Lutris to use it’s own (system 6.0.2), this fixes the mouse 10 cm away from target. I ran the game and my mouse problem is gone.

Yay! So its the WINE version used which is responsible for the offset cursor…

This is my config:

Its using the default lutris-fshack-6.21-x86_64 version of WINE. Maybe my custom setting under System (Enable NVidia Prime Render offload) steers WINE in another direction?

So to summarize, installing the d3dxof winetrick (now done via the installer script) and choosing a different WINE version in case the mouse cursor is offset should make this game work…