Star trek starfleet command 2 orion pirates

Hi guys, I can play SFCOP , but everytime crashes… i can play on mission and the other crashes… someone can help me??

log output:

Running /home/gustavo/.local/share/lutris/runners/wine/lutris-5.6-2-x86_64/bin/wine /home/gustavo/.wine/drive_c/Program Files (x86)/Taldren Software Inc/Starfleet Command Orion Pirates/SFCOP.exe
Initial process has started with pid 8161
Game is considered started.
Initial process has exited.
wine: Unhandled page fault on read access to C4F80504 at address C4F80504 (thread 003e), starting debugger…
Unhandled exception: page fault on read access to 0xc4f80504 in 32-bit code (0xc4f80504).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:c4f80504 ESP:0032fdc8 EBP:0032fe40 EFLAGS:00010212( R- – I -A- - )
EAX:04abfff6 EBX:06ef6e01 ECX:04ab0038 EDX:06ef6cb8
ESI:06ef6cb8 EDI:06ef6d70
Stack dump:
0x0032fdc8: 00713fc0 06ef6cb8 0071c919 06ef6cb8
0x0032fdd8: 06ef6d70 06ef6cb8 06ef6e24 06ef6d14
0x0032fde8: 06ef6cb8 0032fe04 00791225 00000005
0x0032fdf8: 0071b60a 06ef6cb8 06ef6cb8 0032fe34
0x0032fe08: 007910b8 ffffffff 005d3c12 06ef6cb8
0x0032fe18: 005efef1 00000001 06ef6cb8 05a1c9ec
=>0 0xc4f80504 (0x0032fe40)
1 0x005efe4c EntryPoint+0xffffffff() in starfleetop (0x0032fe78)
2 0x005ef81f EntryPoint+0xffffffff() in starfleetop (0x0032ff20)
3 0x7b4521d9 in kernel32 (+0x321d8) (0x0032ff48)
4 0x7b452674 in kernel32 (+0x32673) (0x0032ffd8)
5 0x7b4521ea in kernel32 (+0x321e9) (0x0032ffec)
0xc4f80504: – no code accessible –
Module Address Debug info Name (42 modules)
PE 400000- c86000 Export starfleetop
PE 1910000- 1981000 Deferred met_1scout.scr
PE 10000000-10007000 Deferred osspecific98
PE 21100000-2115d000 Deferred mss32
PE 69240000-69381000 Deferred dxvk_config
PE 7a840000-7a849000 Deferred opengl32
PE 7b020000-7b03c000 Deferred kernelbase
PE 7b420000-7b5f1000 Export kernel32
PE 7bc30000-7bc47000 Deferred ntdll
PE 7c980000-7c986000 Deferred uxtheme
PE 7cf30000-7cf35000 Deferred winex11
PE 7cfe0000-7d00d000 Deferred dbghelp
PE 7d060000-7d06c000 Deferred dinput
PE 7d0c0000-7d0c5000 Deferred dsound
PE 7d150000-7d15a000 Deferred wined3d
PE 7d2b0000-7d2b5000 Deferred ddraw
PE 7d320000-7d327000 Deferred iphlpapi
PE 7d350000-7d357000 Deferred ws2_32
PE 7d390000-7d410000 Deferred winmm
PE 7d460000-7d46e000 Deferred winspool
PE 7d4b0000-7d4b6000 Deferred imm32
PE 7d4f0000-7d4f7000 Deferred wsock32
PE 7d510000-7d514000 Deferred usp10
PE 7d570000-7d5c6000 Deferred comctl32
PE 7d6b0000-7d6ba000 Deferred aclui
PE 7d700000-7d72d000 Deferred ole32
PE 7d840000-7d846000 Deferred shcore
PE 7d870000-7d882000 Deferred shlwapi
PE 7d8f0000-7e1ec000 Deferred shell32
PE 7e300000-7e3ad000 Deferred comdlg32
PE 7e420000-7e42e000 Deferred gdi32
PE 7e570000-7e57d000 Deferred rpcrt4
PE 7e600000-7e60d000 Deferred advapi32
PE 7e6a0000-7e6c8000 Deferred ucrtbase
PE 7e790000-7e795000 Deferred version
PE 7e7b0000-7e7c9000 Deferred setupapi
PE 7e850000-7e944000 Deferred user32
PE 7ea60000-7ea63000 Deferred wow64cpu
PE f3500000-f350e000 Deferred oleaut32
PE f4d40000-f4d44000 Deferred winepulse
PE f4d80000-f4d85000 Deferred mmdevapi
PE f4dc0000-f4dd5000 Deferred msvcrt
process tid prio (all id:s are in hex)
0000000e services.exe
00000027 0
0000001a 0
00000013 0
00000010 0
0000000f 0
00000011 plugplay.exe
00000017 0
00000016 0
00000012 0
00000018 winedevice.exe
0000001e 0
0000001d 0
0000001c 0
0000001b 0
00000019 0
00000025 winedevice.exe
0000002a 0
00000029 0
00000028 0
00000026 0
0000002b explorer.exe
0000002f 0
0000002e 0
0000002d 0
0000002c 0
0000003d (D) C:\Program Files (x86)\Taldren Software Inc\Starfleet Command Orion Pirates\StarfleetOP.exe
[“C:\Program Files (x86)\Taldren Software Inc.\Starfleet Command Orion Pirates\StarfleetOP.exe”]
00000057 0
0000004d 15
0000004c 0
0000004b 0
00000044 0
00000040 15
0000003e 0 <==
System information:
Wine build: wine-5.6.1.r0.g4c160ec8 ( TkG Staging Esync Fsync Vkd3d DXVK-Compatible )
Platform: i386 (WOW64)
Version: Windows 7
Host system: Linux
Host version: 5.4.0-26-generic
Game is considered exited.
All monitored processes have exited.
Exit with returncode 0

1 Like

I recently participated in getting Starfleet Command III to work. It could be the same engine so maybe the same settings work?

I’m running this one as a Windows 10 prefix BTW.

Interesting, SFCOP+ works just fine in wine for me, using the patches from hot n spicy

And a vid of it running on my laptop

Hey everyone

I’ve been diving into Star Trek Starfleet Command 2: Orion Pirates, and I must say, it’s been a rollercoaster of emotions and challenges. I’ve managed to get the game up and running, but it keeps crashing intermittently during missions, which is a real bummer. I’ve been checking the logs, and it seems to be encountering some page fault issues.

I’ve also noticed some similarities between my experience with Starfleet Command III and this game. Maybe they share the same engine, so the settings that worked for SFCIII could potentially be helpful here. I’ve set up a Windows 10 prefix, which seemed to improve things a bit, but the crashes persist. I seem to be an experienced programmer, but I can’t figure out what is going wrong. I specialized mostly in cross-platform development (I even have experience in Andersen), that’s probably why the puzzles in my head don’t fit together.

On another note, it’s interesting to hear that SFCOP+ runs smoothly for some with patches from hot n spicy. Maybe that’s something worth looking into…

So, Sharkguto, regarding your crashing issue, have you tried experimenting with different compatibility settings or perhaps exploring patches similar to the ones used for SFCOP+? It could be that a specific configuration is needed to stabilize the game. Hang in there, and let’s keep our fingers crossed for a solution.