[SOLVED with much help!] An Elite Dangerous Install Tutorial That Genuinely Works!

Installed the Padoka PPA.

Got “Same version is already installed” when I attempted to install Vulkan through that.

https://www.reddit.com/r/linux_gaming/ has a lot of AMD users who may be able to help you. I’m sure one of them has the same video card as you and has Elite Dangerous working. Have you thought about asking for help on there? Maybe they can help you.

Before posting you can grab a list of all your system bits that may be useful in assisting them by doing,

inxi -SPARM -GDCN -v1 -xGRCS


cd ~
inxi -SPARM -GDCN -v1 -xGRCS >> mysystem.txt

to save it as a text file in your Home folder.

Thanks for the suggestion.

Been through the Reddit. All the ED related stuff over there is ancient and there’s only a few posts about it anyway. The most recent being from 9 mos ago. Everything else goes back years. The couple of videos posted are on Youtube and I’ve watched every ED/Linux related one going.

I’m not a Reddit member. Will look into it but judging from the extremely sparse ED related stuff already there I’m not holding out much hope.

Can I just ask, are you running on a laptop or desktop? Does your system have “Optimus” graphics? Also, do any of your other games work through Steam Proton at full speed? Does your system use “UEFI” or “Legacy Boot” BIOS (Other OS) on startup?

HP 6200 Pro Desktop. Core i7 with 16gigs of RAM, Radeon 7750 with 2gig dedicated RAM. UEFI is turned off. It’s in legacy mode for dual booting.

Ah ok. Yeah that is weird that it’s not working with that.
I’ve seen some gamers trying to use discrete cards in laptops, but are unable to utilize them, because they are in UEFI mode and the OS can’t see the device. The only way around that is to boot in “Legacy” (Other OS) mode or create a MOK (Machine Owner Key) for UEFI.

This obviously isn’t the problem in your case.

And your other demanding AAA titles work in Proton yes?

I don’t really have any other “demanding AAA titles”. I’m not a real heavy gamer.

Half Life 2 runs perfectly fine but it’s been ported to Linux so that one doesn’t count. I also have Space Engineers that I really like but I haven’t played that in over a year, nor have I tried it in Linux.

I’d suggest installing some other games, (maybe free Windows titles) not Linux native ones. This will give you a chance to see if Proton is able to run them. Just to ensure that it isn’t a problem with Elite and more with your Proton and/or gfx environment.

Free game to try in include “Rift” a free MMO. “Warframe”, “Path of Exile”. I’m sure you could find others in Steam search.

Once you find one, check the compatibility for it on https://www.protondb.com/
Install and run it and if you still can’t run games with Proton, at least it will give you a clue on what the issue may be.

Also, have you tried to run Elite on an earlier release of Proton? Maybe 4.2-9 or 3.16-9?

Have you updated winetricks and wine 4.13 (staging) to the newer versions as detailed in my guide doc?

Just installed Thief Gold (Windows only). It appears to run fine.

Nope, I take that back. I can enter all the options and settings menus without any problems but I get a CTD when I attempt to actually start the game. But there is a fix for this I’ve read about in the past. The game must be run in 32 bit mode and in a single CPU core. It requires a special patch to do that on 64 bit multi-core machines. But it’s a Windows patch so I don’t even know if it would work through Wine in Linux.

Installing faudio gets me up to the development branch of WINE but am still missing something to get staging installed LOL. Will check the mint 19.2 tutorial later for a clue on what I am missing… Xubuntu 18.04 here

Geez, did a system update after getting up to development and some more wine stuff was installed, THEN I was able to get up to staging…still dont know what was missing :smiley:

1 Like

What kernel are you running? I’ve heard that AMD cards benefit from later kernel releases.

uname -a

You could try using the Mint kernel updater, but I haven’t tested it in Mint as I’m on my daily driver today with about 10 projects open. If you can’t find it in there, you could try using “UKUU” (Ubuntu Kernel Update Utility). However, do note that Ubuntu kernels are compiled specifically for Ubuntu, whereas the mainline kernels have a bunch of stuff left in which may affect things like wifi/bluetooth and stuff. You may also get a few random errors messages on boot, but your system may still boot.

You could also try installing,

sudo apt install vulkan-utils



if you get anything printed in the output that says “failed”, check with,

lspci -k | grep -EA3 ‘VGA|3D|Display’

See if you can see your gfxcard in there. If not, look at this link. This guy said his gfx were using the “Radeon” driver and not the AMDGPU.

Dude! I followed the instructions at your “This guy” link to change the graphics driver AND IT WORKS!

I just got wood!

But it’s windowed. Not full screen. Have to look into that.

Glad to help buddy. Finally aye! Jeez that was a slog. I’ll make a note later at the bottom of my Google Doc to help other AMD Radeon users. I’m happy you got it going. :smiley:

A million thanks man. You have far more patience than I do.

I was just about this close to giving up and resolving myself to having to keep Windblows around just for one friggin’ game. Now if I can get the windowed mode thing licked I’ll be a happy camper.

I look forward to your updated Google Doc so I can snag a copy of it for future reference.

No problem man. If I hit a problem, I’m just the kind of person who won’t quit until I find a solution. Even if the problem isn’t directly affecting me. Once I add the new information to the doc, if you could be so kind as to verify the steps and highlight anything I may have missed?.

Much appreciated. *fistbump

Will do. If I find any errors you’ll be first to know. Err well, make that second to know. :rofl:

Many thanks again.

Nice one. New info now added to my website, as it’s easier to maintain.

1 Like

Nice guide, thanks. Closely mirrors my trials with installing ED, so I can verify it’s pretty solid.

Aside from that, anyone managed to get EDH working on an AMD GPU?
I have a similar stop as Steam install script, but a comment indicates someone has it working on Arch (I’m running Ubuntu) but it does does not mention fixes, driver versions etc, and I can’t find any post here supporting it.
Would be good to know if any additional steps are required.

I fixed my issue with Elite Dangerous Horizons with the same driver change.

It seems to be caused by some issue with the AMD supplied vulkan-amdgpu-pro driver (amdgpu-pro-19.30 - both 838629 and 855429 versions) - on a new AMD RX 5700

Only happens in Elite Dangerous Horizons, the regular version runs without issues. The system crashes/freezes at “preparing planet generation system” after shader generation completes.

Cycle of pain: -

  • installed AMD supplied driver

  • install updated winetricks

  • install lutris steam ED:H

  • run the regular game launcher once. Quit.

  • winetricks to make sure win7 dxvk dotnet40

  • winetricks to make sure dotnet472 (twice, failed the first time)

  • run ED:H. Freezes the system with high CPU/GPU at “preparing planet generation system”

  • switch to padoka PPA instead of oibaf (also updates llvm to 8), with proper purge

  • run ED:H. Freezes the system with high CPU/GPU at “preparing planet generation system”

  • install latest dxvk from doitsujin

  • run ED:H. Freezes the system with high CPU/GPU at “preparing planet generation system”

  • tweaking of dxvk options tried to tell it I was an Nvidia card

  • run ED:H. Freezes the system with high CPU/GPU at “preparing planet generation system”

  • forcibly copy TerrainComputeShadersNvidia.csa to TerrainComputeShaders.csa

  • run ED:H. Freezes the system with high CPU/GPU at “preparing planet generation system”

…in the end, it was the AMD pro driver :frowning:
remove AMD driver
$ sudo apt remove vulkan-amdgpu-pro vulkan-amdgpu-pro:i386
install regular Ubuntu Open source
$ sudo apt install amdvlk

  • run ED:H. “Preparing planet generation system” takes a while, but eventually completes

and the crowd goes wild :slight_smile: