Back to the main site

[SOLVED with much help!] An Elite Dangerous Install Tutorial That Genuinely Works!

The script on the Lutris page for it is borked. I’ve tried following several so-called “tutorials” on Youtube, all to no avail. I’ve now got so many different versions of Steam and Wine on my system it doesn’t know whether to crap or go blind. And still no joy.

I’ve downloaded and installed the complete Elite Dangerous (Linux version of Steam with Proton enabled) and at a 4 hour download I will not be sitting through that again. I tried pointing everything to where that resides on my system. Lutris sees it and even creates icons. It goes through the rigmarole of downloading fonts and VB libraries and DLLs and whatnot, but it still won’t run. The launcher won’t even start.

This is the ONLY thing keeping me from finally ditching Windblows for good and I have no idea where to turn next.

as of July 4 2019 it has supposedly gotten very easy to run in Steam. Might try again myself. Thing is, I am not sure it would even run in Windows on my hardware

Last time I tried I ended up borking Wine on my entire system ended up reinstalling the entire OS

I’ve been through that one too I think. It looks awfully familiar. If I remember right I kept getting messages about trying to install older stuff and it prevents be from doing so. I’m running Mint 19.1 MATE.

I might go through it again tomorrow. I’ve got the system so packed with all manner of crap now from all these failed install attempts I’m probably going to have to do a complete OS re-install and that’s going to suck largely because this is a dual-boot system.

This method worked for me using “Ubuntu MATE 18.04 LTS”. Although given your past experience - I’d suggest grabbing a coffee first before you do it this way.

Video guide HERE
Linux Mint MATE 19.2 fresh install + NVIDIA / AMD Radeon 7xxx guide here.

This guide assumes you have the following correctly installed on your Linux distro.

Graphics Drivers

Vulkan

Edit: Wine 4.13 (staging) is not able to install until you add a key to obtain “FAudio” as described here by dimesio .

WINE

winetricks (Ubuntu)

sudo apt install winetricks

to install a newer winetricks see the end of my Google Doc here.

Lutris

Steam

Installing “dotnet45” and “vcrun2017” via Lutris to fix “Elite: Dangerous” for use in native Linux Steam “Proton 4.2-9 or above”.

  1. Open Lutris in the terminal (this is important so you can see the output of winetricks). Open a terminal and type “lutris” (without the quotes :P)
  2. In Lutris, press the “Add Game” icon top left.
  3. In the “Game Info” tab, add a name into the “Name” field eg, “Let’s Fix ED”. Then in “Runner” dropdown pick “Wine (Runs Windows Games)”
  4. On the “Game Options” tab enter the path for your Elite Dangerous “compatdata” folder into the “Wine prefix” field, eg, mine is in: /media/supa/Steam/SteamLibrary/steamapps/compatdata/359320/pfx/
  5. In the “Runner” tab - choose a Wine version. The one I used was “lutris-experimental-4.10-x86_64”. Leave DXVK off, we don’t need that as all we are doing is installing “dotnet” and “vcrun”.
  6. In the “System option” tab - set “Disable Lutris Runtime” to ON and “Prefer system libraries” to OFF.
  7. Press “Save” on the window (bottom right).
  8. Select the new “Let’s Fix ED” icon you just created in Lutris and press “Winetricks” on the right of the Lutris window.
  9. Once the Winetricks window opens - choose “Select the default wineprefix” and press OK.
  10. In the Winetricks window select “Install a Windows DLL or component” and press OK.
  11. In the list, select “dotnet45” and “vcrun2017”, then press OK. Your terminal will go mental while “dotnet” and “vcrun” installs, so go grab a coffee or something - this will take a while.
  12. Next select “Run winecfg” and press OK. When the window pops up, set the “Windows Version” on the “Applications tab” to “Window 7” and press Apply, then Ok.
  13. After your Winetricks window returns. Press “Cancel”, then “Cancel” again.

You now should be able to launch “Elite: Dangerous” from your Linux Steam using “Proton 4.2-9”. You may see a few little grey Windows error boxes popup when the launcher sets things up after pressing play for the first time. Ignore these and press OK. Elite will then install its Windows blobs on top of what we added. If all goes well the launcher screen should appear. From here you can enter email and password to login to you Elite account. If not, restart Steam and press play again.

In-game: set the Graphics mode to “Borderless” and turn “Vsync” off in Options > Graphics. I also had to set my controls to “Keyboard and Mouse” too.

Problems installing?

If you’re having issues installing dotnet and vcrun using the method above - it may be that your Elite Dangerous WINE prefix already has “vcrun” or “dotnet” installed, but with errors. I’ve had this issue too when first installing. I fixed it by removing the pfx folder and any files inside the “compatdata/359320/” folder. Then I created a new empty pfx folder and ran my steps above again. This worked for me.

Edit: I amended the steps to set the Windows version to Windows 7 in Winecfg to last, as installing “vcrun” and “dotnet” can sometimes revert that back to WinXP. Also while doing the Lutris patch, ensure Steam is closed and make sure that the Elite Dangerous 359320 compatdata folder is completely empty. Apart from an empty pfx folder. Then follow the guide above.

Hope this helps.

1 Like

Tried this method and got nowhere. For starters my compatdata folder is 100% empty. Next, I am unable to install the dotnet45. I get an error saying it conflicts with dotnet40 that’s already installed, then WInetricks does a CTD. It is not listed in the list of installed components of wineconfig and a system search reveals nothing even in hidden folders so I have no idea where it is or how to uninstall it. If you know how to uninstall it can you please tell me.

There is nowhere to call WInetricks from within Lutris that I can see. I have to either start it from a terminal or from the start menu icon.

I have this system so thoroughly hosed now I’m afraid I’m going to have to wipe it and start all over from scratch again. And it’s a dual-boot system with WIndows so you know it’s going to suck cheese. It may be days before I’m able to try this again as I’ll be busy reinstalling everything I use that’s “more important” than games.

I need a little more information first. What Linux distro are you running?

The “compatdata” folder will be empty if you have never installed any Windows games. It is normally located in “/path to your/SteamLibrary/steamapps/compatdata”.
After installing & running “Elite Dangerous” in Linux Steam (not Lutris), you will see a folder named “359320” in compatdata. That is Elite Dangerous.

Have you correctly installed WINE for your distro as detailed in the Lutris WIKI?

Regarding your “hosed system” make a backup of your Home folder to another drive using either “APTIK” (Ubuntu) or “Grsync”.

sudo apt install grsync

This will ensure that when you reinstall Linux you can selectively copy back over all your settings to your new Home folder.

I am running Mint 19.1 MATE. I completely removed WINE and reinstalled it. The ‘359320’ is now there. I went back through the configuration process and reinstalled and reconfigured everything as per your tutorial. Except there is no way to call Winetricks from within Lutris. It must be done through terminal or menu icon. Still no joy. It will not launch through Lutris or the Steam client.

One thing I forgot to mention earlier, in the “Runners” tab in Lutris I have no flavor of WINE called “lutris-experimental-4.10-x86_64”. It is the most recent version of Lutris.

When you select the “Let’s Fix ED” WINE bottle that you created in the guide. You will see on the right hand side of Lutris, a button that says “WInetricks”. That’s what you press to run Winetricks inside that WINE bottle.

Edit: To install new WINE versions in Lutris.

  1. Click on the top left Lutris icon in the titlebar.
  2. Select “Manage Runners”.
  3. Go down to “WIne” in the list and click the “manage versions” icon.
  4. Select what Wine versions you want to install and they will be set as an option the next time you go into Lutris > Configure > Runner options.

I added a video guide to make it easier for you to understand how to do it.

Hope this helps.

1 Like

Followed your video guide to the letter. Still no luck. Everything goes fine until I get to installing dotnet and the vc runtimes then WInetricks crashes to desktop with this message and never re-appears:


dotnet40 install completed, but installed file /home/housemint/.local/share/Steam/steamapps/compatdata/359320/pfx/dosdevices/c:/windows/Microsoft.NET/Framework/v4.0.30319/ngen.exe not found

This option is not available. Please see --help for all possible usages.
Waiting on children
All children gone
Exit with returncode 1

I give up.

I understand your frustration. “Elite Dangerous” was a pain to install for me too.

When you type into terminal

wine --version

what does it say?

Have you tried “protontricks”?

protontricks 359320 dotnet40 vcrun2015 win7

Wine is version 4.0.1

Yes I’ve tried the Protontricks thing.

Mine is wine-4.12.1 (Staging)
Installed as per the instructions on https://github.com/lutris/lutris/wiki/Wine

I’m running Ubuntu MATE 18.04 LTS. But the WINE install page says this should work on “Linux Mint 19.1” too, however I doubt it on Linux Mint 19.2. This is one of the reasons I moved away from Mint over to Ubuntu MATE, because of the latest WINE issues.

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository ‘deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main’
sudo apt update

I also added,

sudo apt install --install-recommends winehq-staging wine-staging wine-staging-i386

and

sudo apt install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

Give that a shot redo the tutorial and see how it goes. If you have an older wine installed I’d recommend uninstalling it first.

I’m over it. Looks like I’m stuck keeping a ginormous Windblows installation around just for one friggin’ game. I’ve got the Linux side of this dual-boot so hosed with crap right now I’m about to run out of HDD space with all the crap I’m installing. I’m surprised it even still boots.

Went through all that and got this error. And it’s a new one on me. Can’t complete because it wants to install packages that haven’t been created yet. WTF?


housemint@housemint ~ $ sudo apt install --install-recommends winehq-staging
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
winehq-staging : Depends: wine-staging (= 4.13~bionic)
E: Unable to correct problems, you have held broken packages.

Honestly buddy, if you are not using Linux Mint for any specific reason other than the way it looks - I’d just grab Ubuntu MATE 18.04 LTS and run wit that. I’ve had none of the issues you’ve had with WINE using the Lutris install guide.

Make a backup of your home folder somewhere and install Ubuntu MATE 18.04 LTS.
A lot of Window users head right to Mint as it “feels” like a Windows UI. I honestly love Ubuntu MATE and its been rock solid for me for ages. I even came back to this from MX Linux just a few weeks ago as that has its own set of issues.

Mint has been my daily driver for well over 10 years now. I do everything on it. And I do mean everything.

As time has gone by I’ve seen less and less of a need for a Windblows machine because more is available in Linux. And right now it looks like I’m down to only needing to keep it around for Elite Dangerous and nothing else.

Then stick with it if it works.

I fired up “Linux Mint 19.2” in a VM and encountered the same issues you’ve been having. It could be one of two things. Either wine-staging candidate isn’t in the repos or the fact that they have recently pushed out wine 4.13 and it has borked the wine-4.12.1 (Staging) one.

I guess it just wasn’t meant to be in Mint 19. I was beginning to think it was some quirky distro-specific thing myself.

I do sincerely appreciate your time though.

I’d just give it a week or so then try again with the tutorial. Maybe then the updated wine-staging will be in the repos. It is the summer so many people take holidays, so that may explain the slowness of the updates.

I’m going to install protontricks in this VM in a second and see if I can get dotnet40 and vcrun to install into the Elite pfx. If I get a result on Mint 19.2 I’ll post it below.

OK man. Thanks.