[SOLVED with much help!] An Elite Dangerous Install Tutorial That Genuinely Works!

Sorry man, I’ve tried every possible combination of prototricks and dotnet and vcrun and even threw my own fix in for good measure via Lutris. Been at it for hours on Mint 19.2 in a VM. It just won’t load up like on Ubuntu MATE 18.04.

If I do manage to get it going in future tests on Mint - I’ll be sure to report back here.

I tried :confused:


Many thanks for your video tutorial, it worked for me.
I’m using Debian 10 with latest wine 4.12.1 staging.

1 Like

To install WINE development branch in Ubuntu base, you need to install libfaudio0 32 and 64 bit versions…I was getting same depends error until I figured that out…there are instructions on winehq Ubuntu site…at top of page

1 Like

Glad to hear it. :smiley:

I think for those who are having problems - it may be that they are not currently running wine 4.12.1 (staging) or a correctly configured wine environment, or are missing some dependencies.
I too run wine 4.12.1 (staging) and it works for me.
Sadly, I think wine 4.12.1 (staging) is inaccessible now from the Ubuntu repos.

apt policy wine-staging does report “Candidate: 4.13~bionic”, however it is missing an libfaudio0, libfaudio0:i386 and a few others.

Maybe there will be an update to the 4.13 repo soon.

Great stuff. Thanks for this Jeff.

1 Like

I have some good news for you. “Elite Dangerous” does work on “Linux Mint MATE 19.2”. I have detailed my experience here for you to follow. :slight_smile:

Linux Mint 19.2 Elite Dangerous Install Guide

I was determined not to let Linux Mint defeat me on this one.

1 Like

Damn dude! In the nick of time. I was within moments of wiping my system to load Ubuntu 18.04!

I’ll look into it after dinner.

1 Like

Things to check, in the terminal

uname -a

To check your kernel version. Mine after installing “Linux Mint MATE 19.2” is at “4.15.0-55-generic”. The NVIDIA 430 installed fine with this. Check your NVIDIA driver version too. In terminal,


It may be a combination of the new NVIDIA 430 drivers along with the correctly installed Wine-staging as per my Google Docs guide.
The more things you get exactly the same as in my guide the better luck you will have.
Good luck buddy. Hope this works, if not - I’m going to check myself into a mental hospital! :stuck_out_tongue_winking_eye:

Don’t have Nvidia card. Mine’s a 2gb ATI Radeon HD 7700. Have most recent drivers as far as I am aware.

So long as your drivers are up to date, you should be ok. I’d check this page to see about installing the latest for AMD along with enabling Vulkan.

Still no joy. Upgraded to Mint 19.2. Completely removed Wine and started from scratch.

Went through all this again. I did notice in the terminal that there were HUNDREDS of errors noted as it was installing the runtimes and dotnet stuff. The ED Launcher DOES come up but when I press the PLAY button nothing else happens. It just hangs right there. Nothing locks up and I still have full control over the computer, it’s just that nothing else ever happens.

But when I close the launcher window and go to shut down Steam it tells me ED is running. I don’ t get it. There’s nothing on the screen but my desktop.

Did you enable the Vulkan libs?

Also, it does say that “Since Ubuntu 18.04 ships with LLVM 6.0, which is not supported by DXVK, you must add the stable Padoka PPA and upgrade your system for DXVK to function properly.”

I did notice on the Linux Mint ppa: that they were referring to bionic during installs. Did you try add the Padoka PPA? Do a Timeshift backup before you do this, since I don’t run on AMD I can’t verify that this will work, but it’s worth a shot given what you’ve been through.

sudo add-apt-repository ppa:paulo-miguel-dias/pkppa
sudo apt update && sudo apt upgrade
sudo apt install libgl1-mesa-glx:i386 libgl1-mesa-dri:i386

After that - reboot.

Crap! That was the one step I forgot! let me get it done and see what happens.

You’re killing me dude lol!

Guess what. Vulkan is already installed.

In the games launch options try this,

PROTON_NO_ESYNC=1 %command%

I’ve noticed other AMD users having more issues than NVIDIA users with this title.
If you’re still having no luck. Keep an eye on https://github.com/ValveSoftware/Proton/issues/150

I give up. Sticking another HDD in this system and doing a fresh install of Mint 19.2. Of course that also means waiting on another 4 hour download of ED. Then starting from scratch. If that doesn’t work then it’s got to be some quirky hardware issue and I’ll have to give up and just keep Windblows around for this one friggin game.

Sorry bud - I tried, I really did. :confused: I just don’t have any AMD stuff at hand to experiment with.
It’s weird that it just works with Ubuntu MATE and Linux Mint at my end on NVIDIA. I did exactly what I wrote in my guides on both systems.

I hope you eventually find a solution. If you do, be sure to share it here in this thread.
Maybe a AMD user with a similar configuration as yours will come to your rescue. :adult:

No problem man. I do really appreciate the time you spent on this. Once I get the fresh install up and running, if it works I’ll definitely post the results here. I’m hoping that all this installing of tons of crap may have lunched something and is the cause of all my problems. I’ve been a faithful user of ATI video cards for many many years and never had a problem with them in the past, but as they say “there’s a first time for everything”.

No joy. Fresh clean from scratch install.

Same thing. ED launcher starts but does nothing after clicking on PLAY. Just hangs.

But now I get “Vulkan is not available or your system isn’t Vulkan capable” when I run Lutris from terminal. Never had that before. Vulkan IS installed.

I’m done with it.