Back to the main site

[SOLVED] Lutris doesn't open after update


#1

This morning, I ran sudo pacman -Syu as usual, which among other things updated also Lutris. After the update was done, Lutris just wouldn’t open. There were no error messages during installation, it all seemed normal.

I tried uninstalling sudo pacman -Rs lutris, and reinstalling all dependencies listed in the Arch Repository and then Lutris itself. It does appear as one of the installed programs in my system, and right after I click the icon to open it, a window opens and shuts down a split-second after.

Would you please help me solve this? I’m considering reformatting the OS, even though it feels like an overreaction.

Thank you.


#2

Well, you’re not alone. I have exactly the same issue.
Reformatting will not help i guess.When i try to open Lutris i get:

Traceback (most recent call last):
  File "/usr/bin/lutris", line 31, in <module>
    from lutris.gui.application import Application
  File "/usr/lib/python3.7/site-packages/lutris/gui/application.py", line 30, in <module>
    gi.require_version("GnomeDesktop", "3.0")
  File "/usr/lib/python3.7/site-packages/gi/__init__.py", line 129, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace GnomeDesktop not available

Tested on Arch:

$ uname -a
Linux arch 4.20.6-arch1-1-ARCH #1 SMP PREEMPT Thu Jan 31 08:22:01 UTC 2019 x86_64 GNU/Linux

#3

This is good news (maybe =P). it probably means there’s a bug somewhere, and we should just wait for it to be patched =) Even though I would rather put my hands into help solving the issue… but I know nothing about programming =/

If I try to execute Lutris from the console I get the exact same error messages you get

We’re both on the same state of release of Arch, as well. I get the same results for uname -a

Do you think this might be something related to Arch, instead of Lutris? I must say, if I remember correctly, after I ran sudo pacman -Syu this morning, I don’t think there was any Arch related updates, but there was definitely a Lutris update. This is why I though of posting this issue here, and not in the Arch forum.


#4

I’ve just tested it on my Laptop with the Gnome Desktop.
There the Error changes into this:

Traceback (most recent call last):
  File "/usr/bin/lutris", line 31, in <module>
    from lutris.gui.application import Application
  File "/usr/lib/python3.7/site-packages/lutris/gui/application.py", line 34, in <module>
    from lutris.game import Game
  File "/usr/lib/python3.7/site-packages/lutris/game.py", line 14, in <module>
    from lutris.runners import import_runner, InvalidRunner, wine
  File "/usr/lib/python3.7/site-packages/lutris/runners/wine.py", line 10, in <module>
    from lutris.gui.dialogs import FileDialog
  File "/usr/lib/python3.7/site-packages/lutris/gui/dialogs/__init__.py", line 6, in <module>
    from lutris.gui.widgets.utils import open_uri
  File "/usr/lib/python3.7/site-packages/lutris/gui/widgets/utils.py", line 4, in <module>
    from PIL import Image
ModuleNotFoundError: No module named 'PIL'

#5

So definitely a bug on Lutris? =P Man… shouldn’t have updated it today! xD is there a way to downgrade it?


#6

I don’t know if there is a way through pacman as i’ve never tried it.

But if you can’t wait for an official fix from upstream you might try to go around pacman temporarily and use a source version:

https://lutris.net/downloads/


#7

Yes, you can downgrade via pacman:

sudo pacman -U ‘/var/cache/pacman/pkg/lutris-0.4.23-1-any.pkg.tar.xz’

worked for me


#8

Ah! Nice! Running into the same problem since this morning. Will revert.

Thank you!


#9

Works for me aswell, thank you very much! :smiley:


#10

andib, I try running the command line you posted, but I get the message:

error: ‘‘/var/cache/pacman/pkg/lutris-0.4.23-1-any.pkg.tar.xz’’: could not find or read package

But when I browse the /var/cache/pacman/pkg, I see the lutris-0.4.23-1-any.pkg.tar.xz file in it. What would you say could be the problem? It’s in there, somehow pacman can’t access it.

Thank you.


#11

Had an error on the first try too.

Just try it like this:

sudo pacman -U /var/cache/pacman/pkg/lutris-0.4.23-1-any.pkg.tar.xz

instead of

sudo pacman -U ‘/var/cache/pacman/pkg/lutris-0.4.23-1-any.pkg.tar.xz’

#12

hmm… i just typed

sudo pacman -U

and then dragged the file from the filemanager into the terminal. Perhaps it works this way for you.


#13

Wow, it worked! =D thank you guys so much!


#14

For the ModuleNotFoundError: No module named 'GnomeDesktop’ and ‘PIL’ on Arch Linux try run sudo pacman -S gnome-desktop python-pillow


#15

Python Pillow made it work on my Gnome Laptop.

But i guess the Gnome Desktop should not be a dependency for Lutris, so i’ll just stay on a downgraded Version on my Xfce Desktop, until there is another solution.

Thank you very much!


#16

Yay! Installing sudo pacman -S python-pillow made it work for me. I am using Xfce 4 just like you and the newest version now works for me. Thank you for mentioning it @OsamaBinlada.


#17

gir1.2-gnomedesktop-3 is a dependency on Lutris Debian package, gnome-desktop on arch is the same package (its a lib for Gnome modules), i guess…


#18

Enjoy Lutris 0.5.0 hehe


#19

Well, i didn’t expect that.

Installed it now and got everything working, thanks for your research and help! :slight_smile:


#20

Let me see if I understand this right, I need to install gnome-desktop as a dependency of Lutris even if my desktop environment is actually KDE?

Edit:
Wow, this is even better! In fact, installing gnome-desktop dependency then lutris-0.5.0-1 works just fine! =D I thought somehow the gnome-desktop would try and install itself in place of my current KDE installation. =P the more you know, I guess… one thing though, I had to manually remove the old Lutris shortcut and then re-add it again, so it wouldn’t give me any error messages when opening from the shortcut.