[Solved] Games/Launchers wont launch with DXVK Enabled -> vulkan-1.dll.vkGetInstanceProcAddrr

Currently my two tested clients are Origin and the Blizzard Launcher.
Origin Crashes at start, throws no error. The blizzard launcher prints “wine: Call from 0x7bc77779 to unimplemented function vulkan-1.dll.vkGetInstanceProcAddr, aborting” in the terminal and crashes.
Both start without problems if i deactivate DXVK.

Lutris Debug Log: https://pastebin.com/b9GnSBJj
Video showing the issue: https://youtu.be/XAyX4JpBMkQ

Xubuntu 18.04
Nvidia GTX 1060 6GB with 415.27 Driver

Vulkan/DXVK Games over Steamplay run without any problem

My system did reject the libvulkan1:i386 package somewhere along the way. I leave this here for people who may run in the same issue.


Thanks for leaving the solution in. I remember having a broken libvulkan installation as well, once. It was due to the fact that libvulkan1 was in version, say, 2.1 while libvulkan1:i386 was in 2.0 because my repository couldn’t finish the build job.

So I did like sudo apt install libvulkan1=2.0 libvulkan1:i386=2.0 (of course version numbers are not the actual ones)

1 Like

Thanks for editing the main post with the solution. :slight_smile:

Thank you all for this thread!

In my case I solved my WoW Error by using this command:

sudo apt install libvulkan1:i386 mesa-vulkan-drivers:i386

I am not using lutris. 386 drivers were missing. And by not adding a version to the command it installed the newest version for me.

1 Like

Thank you ! I installed the missing library via sudo apt install libvulkan1:i386 and everything is fine now !