[Solved] Game not launching

Hi, I’m trying to use Lutris to install and run Final Fantasy XI on a Steam Deck, following the steps from a guide that I’ll post in the next comment (since I can only have 2 links in the post, apparently).

When I try to launch the installer by pressing Play, the button changes to say “Launching” but then it just stays like that forever, without launching anything.

Output from lutris -d: Ubuntu Pastebin

lutris-issue-report.json: https://paste.ubuntu.com/p/9J9npsqSYj/


This is the guide I’ve been following: Installing wine and lutris

Your log looks strange. Are you trying to launch the steam game from lutris?

Nope, this is me trying to launch the installer downloaded from here: FINAL FANTASY XI Official Web Site

My coment comes from the python error, that one says something about the contentstatid which is related to steam. Also there is a suggestion in the error to install python-magic.

Did you tried using the installer script?

I didn’t even know that the installer scripts existed. Thanks! I’m giving it a try now.

Used the installer script (and installed python-magic), here’s the new log: Ubuntu Pastebin

It is still very strange, look:

File “/usr/lib/python3.10/site-packages/lutris/util/steam/config.py”, line 161, in read_library_folders
KeyError: ‘contentstatsid’

Something is telling the launcher to use the utility for steam.

Can you please screenshot the configurations that you have?

Hey I’m a dumb dumb there is another thread in this forum that explains how to fix this issue regarding the steam part look:

1 Like

Oh awesome! I’ll take a look.

Edit: Well, it’s working so far!


Glad to hear, funnily enough I saw the other thread earlier and read it but it never clicked that this was your problem. Oh well, such is life.