Back to the main site

[Solved] Epic Games Launcher - Form unfillable


#1

Hey there all,
After a few trials and error, I’ve successfully managed to install the replacer for Battlenet and games like Starcraft 2, Diablo 3 and such.

Now I’m trying to get the Epic Game Launcher to work. It did installed successfully, and I manage to launch the program, but the login form is totally invisible and I only get a green square on the screen. If I click on it, I got to get the two fields to login, but I can’t fill them in.

Do someone know if there is a workaround or a parameter to change to make it work ?

Thanks !

PS : Specs is now Manjaro latest version.


#2

You could try removing -opengl from the argument field under the Games Options tab. It’ll make the Epic Launcher window flicker though.


#3

Thank you for your reply. Unfortunately, this didn’t did much.

Thank you though for the suggestion, it is much appreciated


#4

Are you using the Mesa drivers? Are they up to date?


#5

Mesa drivers… good question. I have a fresh standard Manjaro installed. I suppose this has something to do with the video drivers ? I’m using nvidia drivers but not sure whether this is Mesa or not. I’ll investigate this as soon as I can. Updated, my system is indeed up to date. I just don’t know about the Mesa one. I check this ASAP


#6

Okay, after researching, I found that the Mesa drivers were the nouveau driver. I installed it and removed the nvidia one, which blocks now my system upon boot. Damn… :frowning: not sure at all how to fix it now… i’ll but this is not in the scope of this forum. :frowning:


#7

Be sure to blacklist nouveau when installing the nvidia driver


#8

Don’t ask me what I did, nor how I did it, I’m not very sure myself… All I know is that the nouveau driver was not working and was making the game to crash instantly.

But I reinstalled the latest nvidia drivers, and now it works finely. I’ve been able to log in successfully, and am trying to download Fortnite on it. But Epic Games Launcher works now like a charm !

Thank you for your suggestions, once again :slight_smile:


#9

Only problem left now is that there is no sound in the game. I’ve found a workaround on winehq but i’ve No idea how I should make it work. But i’m Sure i’ll Find out.


#10

Wasn’t the installer fixed for this issue?

Someone removed the DIrectX installation from the script and it caused sound issues, when it was noticed, we put it back.


#11

There are a lot of DirectX installations going on, but I’m without sound on this one. Sound works perfectly for Starcraft II, which I also use in Lutris. I therefore suppose it has something to do with the installation. If you want, I can try it again, deleting the installation and making sure it is clean, and then reinstalling from scratch from within Lutris.

Basically, what I did to install it was the following :

  • Go to the games (in the web browser)
  • Find Epic Games Launcher
  • (clicking on install from the browser doesn’t launch Lutris, but instead shows me an error within the browser). So instead, I do Add to my library.
  • I start up Lutris, and after synchronizing, Epic Games Launcher can be installed.
  • I press on play, and let Lutris do its business until I get an option to start the game.
  • I close the installation, press on play, and get to the login screen
  • Logging in in the launcher, and installing Fortnite from the within.
  • After installation, I launch the game, and try to play (no sound).

(Testing it right now, I will keep you updated as soon as I get the new update of 2.8Gb done)

Update : It seems the new update broke it. Latest updated installed BattlEye, which is the first service that is starting. It opens in a window and tells me it tries to start BattleEye. But it doesn’t go further. I suppose BattlEye doesn’t like Wine ? Impossible to go further in the game now. Just a window telling “Starting BattlEye service…”


#12

And for your information, BattlEye is confirmed in this version of the game, and also confirmed that BattlEye is not Linux compatible.

I suppose Game Over for Fortnite.

Thank you for the support though, it was great support.

(/me scraps Fortnite off my library, and go find another game to play on his Linux machine)


#13

damn shame… Fortnite was working so well until the update


#14

So it looks like Fortnite is still playable w/o BattleEye:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=35574


#15

In the October version, it seems this is not working. By doing this work around, it tells that the server received an invalid request and shuts down the game.


#16

Strange. I was able to play Fortnite last night using the workaround. Will try again and report back.


#17

Well, the problem that I have is that I don’t find at all this .exe they are talking about. I’ve been searching through the files, but only find one .exe in the folder. I can’t seem to find any kind of folder whose name would be “Fortnite”, but instead everything I find is in the Launcher.

I’m doing things wrong, most probably, but can’t find where I fail. Care to share where the exe is to be found ? If it’s in the same folder as the epicgamelauncher.exe, I definitely don’t have it. That directory has one exe, and packed with DLL of all kinds.


#18

The fortnite executable they are referring to is in the “Program Files” directory. Its a 64-bit executable in the folder Fortnite.


#19

Indeed ! That works (without sound for me so far, but hey… At least the game is playable :stuck_out_tongue: Thank you !


#20

Is fortnite still playable? I tried the installation but the launcher goes white trying to install prerequisites? If I cancel from there are try again it just crashes out and I noticed it doesn’t actually install the game files?