Back to the main site

[solved] Cannot install game from battle.net client


#1

Hello,

I’m trying to install OW through these installations (tried both): https://lutris.net/games/battlenet/

I followed the guide about the blizzard app (see the link above)

However, I’m stuck when I try to install a game, I’ve got an infinite loading when installing it; see

Launching lutris -d doesn’t give much information except a bunch of debug messages.

I also reproduced the same issue with the overwatch installer from lutris catalog.


#2

First generic question, which you problem have sorted is: do you have winehq-staging + --install-recommends installed in your system? It gets rid of a lot of dependencies.

Second, there were other users experiencing this problem.
See if this is similar to your problem

From my experience, sometimes games get stuck on downloading (not your screen). For example, they go to 65% and then stop downloading. When I close and open it up back again, it’s completely functional and ready to go.

Another thing you can try is installing the game using a wine staging version (staging-3.13, for example) and then switch back to an esync version (probably lol-3.13 because of positive feedback of its functions)


#3

I found that changing the Executable in Lutris from ‘Battle.net Launcher.exe’ to ‘Battle.net.exe’ made it work instantly.
If it doesn’t work first time, just try running it again.
However, I did install the game using scripts from the Overwatch page, which is recommended on the Battle.net page.


#4

I am having the same issue, on my system I have installed the latest stable version of Wine. Battle.net works fine but doesn’t install its just stuck on the same screen


#5

I managed to install overwatch but it looks like a fluke. Cannot get it working again. I tried changing wine version, reinstalling with the overwatch script, changing the path of battlenet exe and much more.

Looks like you’ve got to get lucky to be able to install a game.


#6

Try deleting C:/ProgramDate/Battle.net


#7

There seems to be some issue with Blizzard App and somehow messing up its configuration. What Wuffman says should work in most cases.

Nobody has made a bug report yet, but there was another update of Blizzard App today, hopefully it will be fixed with that.


#8

I confirm that deleting C:\ProgramData\Battle.net fix the issue. Beware though, it makes the blizzard launcher loose the link to already installed games (i.e: launcher app will consider no games are installed, reinstalling them seems to work quite well)

Thanks @Wuffman


#9

You can just “locate” them again.


#10

Sory for the Necro but this is still happening and deleting the ProgramData folders did not work for me, anyone else got any suggestions? Void Linux, but it was happening on Arch for me too.


#11

I have had the exact same issue, just did delete the Battle.net folder and was ready to install.
Are You sure, you have the same issue after deleting this folder?


#12

I confirm that deleting C:\ProgramData\Battle.net fix the issue.
For me also, using Xubuntu.