Back to the main site

[Solved] Battle.Net Opens with Login Prompt, then Crashes


#1

I’m trying to work out what’s causing Battle.Net to crash. I’ve tried both the WoW and Battle.Net installers and they both do the same thing at the same step. Battle.Net opens and lets me start typing in the username/password boxes, but then crashes. If I open it and do nothing, it crashes. Thus I can never login to install any games.

I managed to get this working by copying my existing WoW install over to the Wine container Lutris setup. That DOES work but since I can’t get into Battle.net itself, I’m relying on the in-game download stuff. Some things load slow but it’s workable. Battle.Net runs in Crossover (though there I can’t get DX11 working) so thinking it’s something with my config? I followed the two pre-install docs (the link to the wine-staging info on the Battle.Net page goes to a not found).


#2

Is it crashing during the installer phase or after the Lutris installer finishes? The former “crash” is intentional for the installer to finish.


#3

Exact same problem here :confused:


#4

I believe it’s after. Battle.Net pops up during the initial install then exists and then the installer says it’s finished. If I try to open Battle.Net again it crashes in basically the same way. Since I’m a newb to the forum I wasn’t able to provide links to the topic but I saw a similar forum post here that mentioned it might be the 2FA authenticator that’s causing issues (see Battle.Net launcher crashes) though the original poster for that has yet to confirm (they were having an issue installing Wine staging).

I’m not sure if it’s because I’ve already installed WoW but after I managed to get DXVK 0.54 working with WoW itself, I thought I’d re-try the BattleNet.exe and low and behold it seems to be working! I’m using pba-firerat-3.11-x86_64 and DXVK 0.54 (0.62 didn’t work). Before, I tried staging-3.11 and staging-3.12 without DXVK and Battle.net would crash but WoW itself worked. Hard to tell at this point if the two are related so I may try a clean install with the known good settings I’m using for my WoW install to see if I can reproduce the original issue.


#5

I reported this last week. No one seems to really care.


#6

For me, the issue was missing 32bit libs that Bnet needed, where I had only the 64bit ones. My #1 troubleshooting issue with a fresh OS install and prefixes that don’t behave correctly (or at all) is to use a locally installed wine, and from a terminal manually run “WINEPREFIX=/path/to/prefix/ wine /path/to/game.exe” to see what wine spams out and go from there.

As for DXVK, I had the same problem, and it spawned from my drivers being not quite bleeding edge enough. DXVK .61 needed NVIDIA 396.24.2, I have 396.24.0. 0.54 DXVK works fine enough for now. When my repo is updated I will try whatever the latest DXVK is.

As for the BNet games, staging is fine as well as pba. I have my prefix I built and Dox’s (think thats the default one to install via lutris website). Both are equally good, mine is on staging, Dox uses PBA.

HTH a bit.


#7

Like cxf said: Its not a crash. During the installation we basically “kill” Blizzard App when the login window is opened (the install of Blizzard App is then complete). This is done so the Lutris installer can finish the final steps. Once it is done, you can launch and log in.

If you try to open Blizzard App while the wineserver is shutting down, it will also look like it is crashing, but that is not the case, it is again just shutting down since the wineserver is shutting down.


#8

Hmm that would imply it crashes intentionally everytime I try to open it from the Lutris game list as well? If Lutris is doing that, I think that’d be unintentional? I basically can’t ever open Battle.net to download any game?

That said, I suspect an issue was the WINE version and/or some DXVK settings over Lutris killing the client after the initial install pass. I say that because it didn’t work with the stock install but in my quest to get DXVK working with WoW (when I manually copied my folder over, bypassing the Battle.net issue), I noticed Battle.Net now works. So at some point, the changes I made caused it to work somehow.


#9

As aforementioned, in my case that was entirely missing 32bit libs. BNet itself is 32bit, whereas OW, WoW, D3 have 64bit executables. DXVK works perfectly with any recentish version of wine or wine staging and Bnet. Ensure that you have both the 32 and 64 bit vulkan drivers and display drivers and any support library that both WoW and BNet need.


#10

I thought about that too but why would it start and crash? I actually managed to test that because at first I didn’t have some of the 32-bit support packages on Mint but I did install those and try a clean install and still managed to get the same results. I don’t think the issue is thus just the 32-bit libs. I actually think it’s gotta be a default config setting I changed, I just haven’t had a chance to find that yet.


#11

If you have no 32 bit drivers, it crashed when it needs to display 32 bit stuff. :wink:


#12

Hah well that’s a really good point. I clean install should show that now that I do have the 32-bit stuff working so I’ll try that soon as I’m able.