Battle.Net launcher crashes

I installed the default WoW Lutris game. Did everything as asked, installed dependencies and followed the guides but my Battle.Net application will just keep crashing.

I had a latest version of actual WoW installation ready, so after Battle.Net install I just copied it to the wine prefix created by Lutris and launching that via Lutris works fine. Wow runs and plays really well altough only with the Wine 3.6 version the the script uses. System Wine 3.9 will just give me a blank screen.

I launched the game via lutris CLI options and enabled debug mode but the logs did not seem very intresting. Seems like the actual wine logs are missing. If so could someone guide me so I could fetch them?

Here are the logs:

> ➜  ~ lutris -d lutris:world-of-warcraft
> INFO     2018-05-26 22:34:24,354 [lutriswindow]:Connected to as Veske
> DEBUG    2018-05-26 22:34:24,356 [api]:Fetching game library
> DEBUG    2018-05-26 22:34:24,427 [steam]:Watching Steam folder /home/kaspar/.local/share/Steam/steamapps
> DEBUG    2018-05-26 22:34:24,427 [steam]:Watching Steam folder /mnt/media/SteamLibrary/steamapps
> Gtk-Message: 22:34:24.477: GtkDialog mapped without a transient parent. This is discouraged.
> INFO     2018-05-26 22:34:26,308 [runner]:Runtime disabled by system configuration
> INFO     2018-05-26 22:34:26,698 [runner]:Runtime disabled by system configuration
> DEBUG    2018-05-26 22:34:26,698 [game]:Launching World of Warcraft: {'env': {'__GL_SHADER_DISK_CACHE': '1', '__GL_SHADER_DISK_CACHE_PATH': '/mnt/media/Wine_Prefixes/world-of-warcraft', '__GL_THREADED_OPTIMIZATIONS': '1', 'mesa_glthread': 'true', 'DRI_PRIME': '0', 'WINEDEBUG': '-all', 'WINEARCH': 'win64', 'WINE': '/usr/bin/wine', 'WINEPREFIX': '/mnt/media/Wine_Prefixes/world-of-warcraft'}, 'command': ['/usr/bin/wine', '/mnt/media/Wine_Prefixes/world-of-warcraft/drive_c/Program Files (x86)/World of Warcraft/World of Warcraft Launcher.exe']}
> DEBUG    2018-05-26 22:34:26,699 [thread]:Command env: SDL_VIDEO_FULLSCREEN_DISPLAY="off" __GL_SHADER_DISK_CACHE="1" __GL_SHADER_DISK_CACHE_PATH="/mnt/media/Wine_Prefixes/world-of-warcraft" __GL_THREADED_OPTIMIZATIONS="1" mesa_glthread="true" DRI_PRIME="0" WINEDEBUG="-all" WINEARCH="win64" WINE="/usr/bin/wine" WINEPREFIX="/mnt/media/Wine_Prefixes/world-of-warcraft" 
> DEBUG    2018-05-26 22:34:26,699 [thread]:Running command: "/usr/bin/wine" "/mnt/media/Wine_Prefixes/world-of-warcraft/drive_c/Program Files (x86)/World of Warcraft/World of Warcraft Launcher.exe"
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable SDL_VIDEO_FULLSCREEN_DISPLAY to off
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable __GL_SHADER_DISK_CACHE to 1
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable __GL_SHADER_DISK_CACHE_PATH to /mnt/media/Wine_Prefixes/world-of-warcraft
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable __GL_THREADED_OPTIMIZATIONS to 1
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable mesa_glthread to true
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable DRI_PRIME to 0
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable WINEDEBUG to -all
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable WINEARCH to win64
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable WINE to /usr/bin/wine
> DEBUG    2018-05-26 22:34:26,700 [thread]:Storing environment variable WINEPREFIX to /mnt/media/Wine_Prefixes/world-of-warcraft
> wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
> ATTENTION: default value of option mesa_glthread overridden by environment.
> <html><head><title>Object moved</title></head><body>
> DEBUG    2018-05-26 22:34:28,935 [thread]:Start process monitoring
> DEBUG    2018-05-26 22:34:28,935 [thread]:Processes monitored: World of Warcra (31803:Z)
> DEBUG    2018-05-26 22:34:28,936 [thread]:Processes excluded: wineserver (31806:S)
> DEBUG    2018-05-26 22:34:28,936 [thread]:Waiting for processes to exit
> DEBUG    2018-05-26 22:34:28,936 [thread]:Removing stdout monitor
> DEBUG    2018-05-26 22:34:28,936 [thread]:Thread is no longer running
> DEBUG    2018-05-26 22:34:28,936 [thread]:Restoring environment
> DEBUG    2018-05-26 22:34:30,702 [game]:Game thread stopped
> DEBUG    2018-05-26 22:34:30,702 [game]:Game thread still running, stopping it (state: running)
> DEBUG    2018-05-26 22:34:30,702 [game]:World of Warcraft stopped at Sat, 26 May 2018 22:34:30
> INFO     2018-05-26 22:34:30,702 [runner]:Runtime disabled by system configuration
> DEBUG    2018-05-26 22:34:30,925 [wine]:Killing all wine processes: ['/usr/bin/wineserver', '-k']
> DEBUG    2018-05-26 22:34:30,926 [wine]:	Wine prefix: /mnt/media/Wine_Prefixes/world-of-warcraft
> DEBUG    2018-05-26 22:34:30,926 [wine]:	Wine arch: win64
> DEBUG    2018-05-26 22:34:30,926 [wine]:	Initial pids: {'31806'}
> DEBUG    2018-05-26 22:34:30,979 [wine]:Waiting for wine processes to terminate
> DEBUG    2018-05-26 22:34:30,979 [thread]:Restoring environment
> DEBUG 2018-05-26 22:34:30,979 [thread]:Killing all remaining processes

Here is my system information:

➜  ~ phoronix-test-suite system-info

Phoronix Test Suite v7.6.0
System Information

  PROCESSOR:          Intel Core i5-4570 @ 3.60GHz
    Core Count:       4
    Extensions:       SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE
    Cache Size:       6144 KB
    Microcode:        0x24
    Scaling Driver:   intel_pstate powersave

  GRAPHICS:           MSI AMD Radeon RX 470/480/570/580 8192MB
    Display Driver:   modesetting 1.19.1
    Monitor:          BenQ xl2411t
    Screen:           1920x1080

    Memory:           16384MB
    Chipset:          Intel 4th Gen Core DRAM
    Network:          Realtek RTL8111/8168/8411

  DISK:               128GB Samsung SSD 840 + 1000GB Seagate ST1000DM010-2DM1 + 1000GB Seagate ST1000DM003-1CH1
    File-System:      btrfs
    Mount Options:    relatime rw space_cache ssd subvol=/ subvolid=5
    Disk Scheduler:   CFQ

  OPERATING SYSTEM:   Arch rolling
    Kernel:           4.16.11-1-ARCH (x86_64)
    Desktop:          GNOME Shell 3.28.2
    Display Server:   X Server amdgpu.dc=0
    Compiler:         GCC 8.1.0

➜  ~ pacman -Q wine
wine 3.9-1
➜  ~ pacman -Q lutris
lutris 0.4.18-1

Would appreciate some help with this. I can play Wow right now but once some patch hits, I will not be able to update my client :confused:

The crash seems to happen right after the loading animation under the login window’s credential form is finished. Sometimes rarely it does not crash, in that case the Auth app approval is bugged. Never receives the approval from mobile app and imagaes are not loaded.

Try making your systemwine “wine-staging”, and make sure you have installed corefonts. (And make sure you have 32 bit video drivers installed)

The wine-staging can not be fetched from mirror right now but for the rest, yes, done already. I also tried wine-staging-nine and with that the Bnet app crashed also. It did not crash when I made my own manual plain wine prefix.

How would one install the 32 bit Nvidia drivers on Ubuntu 18.04? I try to sudo apt install nvidia-drivers-396:i386 and it wants to remove the 64 bit drivers. I have the graphics-drivers ppa already set, and 396.54 64bit is installed.

Problem I’m running into is constantly crashing after logging in. Or if it’s not crashing, it’s locked up or just a solid white or black screen. About one in 5 times I can get it to run by running the directly from the prefix, but I’ve never been able to get it to run by double clicking or right click > run on the launcher in Lutris. I used the Overwatch installer from Sept. 29th.

I’m suspecting it’s probably the 32bit drivers issue, but I can’t seem to have both installed, or at least I haven’t been able to find a way to make it happen.

Overwatch runs perfectly fine if I point it directly to the Overwatch.exe instead of or Launcher.exe (which was the default after running the install script). It just means I have to login manually any time I launch the game. A bit of an annoyance.

Update: Just tried the DX11 to OpenGL installer for and it launches and runs just fine. However, DXVK is not enabled, if I enable it it gets crashy. Both launchers are 64bit prefixes, same Wine esync staging pba 3.16. I also tried mirroring all the environment variables from the prefix to the Overwatch prefix, most of them were already set, just had to add a few regarding PBA and one GL_Threaded_Optimizations and a mesa_glthread. Still crashy on the Overwatch prefix. I even tried disabling DXVK and it’s still crashy. I deleted the ProgramData cache files for in the Overwatch prefix and it works up to the point that it starts to load the client, then crashes.

So I try running Lutris from the command line to see what’s going on, and neither prefix works. Both get the error:
x11drv: Can't store handle for display fd
-> Red 1.000, Green 1.000, Blue 1.000
<- Red 1.000, Green 1.000, Blue 1.000

They don’t even bring up the login window. Launch Lutris from the menu and the prefix is working just fine. Overwatch prefix is still crashy of course if I try to run from it instead of just running the game directly.

For now until I can get this figured out, I’ve reverted the Overwatch launcher back to what it was set as originally, and re-pointed it at Overwatch.exe. I’ve symlinked the Overwatch install folder to the prefix so I can at least use that to apply any patches/updates.