Runner PCSX2

Hello Community,

I tried to run an .iso of War of the Monsters (PS2 game) with the runner PCSX2.

I get this error:
Error: Missing shared library.

/home/cronyk/.local/share/lutris/runners/pcsx2/PCSX2: error while loading shared libraries: cannot open shared object file: No such file or directory

I can assume that it’s because I haven’t configurated PCSX2 with the BIOS from the PS2, but I have no idear how to do it in Lutris because the configure Menu has no tab for it.

Of cause I googled and found a guide (in my native language) but I have no idear where to start with the Lutris Installation of the runner.
Can anyone help?

It seems that there’s a missing lib in your system, I’ll try to update the Lutris runtime to ship it so don’t be surprised if PCSX2 starts working without any intervention next time you try it :wink:

It will require a BIOS to run games, you can copy it to ~/.local/share/lutris/runners/pcsx2/bios

I created “bios” in .local/share/lutris/runners/pcsx2
Then I used
sudo apt-get install libaio1
to install the libary.

The problem stays, I think something went wrong with libary installation.

PCSX2 is a 32bit runner only, can you try with ?

sudo apt-get install libaio1:i386

Well, this seems to solve the lib problem, thank you :slight_smile:
But now it seems like nothing happenes when I start the game.
When starting with terminal I get “Illegal instruction”. Google brought me to this:
The solution don’t really helps in this case…

Maybe I did something wrong with the BIOS files.

Here is the Path and Folder:
cronyk@Magnus:~/.local/share/lutris/runners/pcsx2/bios$ ls
PS2 Bios 30004R V6 Pal.bin scph39001.MEC
PS2 Bios 30004R V6 Pal.MEC scph39001.NVM
PS2 Bios 30004R V6 Pal.NVM SCPH-70004_BIOS_V12_PAL_200.BIN
rom1.bin SCPH-70004_BIOS_V12_PAL_200.EROM
scph10000.bin SCPH-70004_BIOS_V12_PAL_200.NVM
scph10000.NVM SCPH-70004_BIOS_V12_PAL_200.ROM1
scph39001.bin SCPH-70004_BIOS_V12_PAL_200.ROM2

Is everything alright?

I also found this:

This is my plugins folder:
cronyk@Magnus:~/.local/share/lutris/runners/pcsx2/plugins$ ls

Update: In every configuration guide for PCSX2 you have to open the Program first. So I tried to do it manually:

cronyk@Magnus:~/.local/share/lutris/runners/pcsx2$ ./PCSX2
./PCSX2: error while loading shared libraries: cannot open shared object file: No such file or directory

So I tried to install:

cronyk@Magnus:~/.local/share/lutris/runners/pcsx2$ sudo apt-get install libwxbase3.0-0
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Paket libwxbase3.0-0 ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.
Doch die folgenden Pakete ersetzen es:
libwxbase3.0-0v5:i386 libwxbase3.0-0v5

E: Für Paket »libwxbase3.0-0« existiert kein Installationskandidat.
cronyk@Magnus:~/.local/share/lutris/runners/pcsx2$ sudo apt-get install libwxbase3.0-0v5:i386 libwxbase3.0-0v5
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
»libwxbase3.0-0v5« ist bereits die neuste Version (3.0.2+dfsg-1.3).
libwxbase3.0-0v5 wurde als manuell installiert festgelegt.
Die folgenden NEUEN Pakete werden installiert:
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 975 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 3.184 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Holen:1 xenial/universe i386 libwxbase3.0-0v5 i386 3.0.2+dfsg-1.3 [975 kB]
Es wurden 975 kB in 1 s geholt (713 kB/s).
Vormals nicht ausgewähltes Paket libwxbase3.0-0v5:i386 wird gewählt.
(Lese Datenbank … 248203 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von …/libwxbase3.0-0v5_3.0.2+dfsg-1.3_i386.deb …
Entpacken von libwxbase3.0-0v5:i386 (3.0.2+dfsg-1.3) …
Trigger für libc-bin (2.23-0ubuntu3) werden verarbeitet …
libwxbase3.0-0v5:i386 (3.0.2+dfsg-1.3) wird eingerichtet …
Trigger für libc-bin (2.23-0ubuntu3) werden verarbeitet …

No effect

I could install the missing libary, now I get:

cronyk@Magnus:~/.local/share/lutris/runners/pcsx2$ ./PCSX2
Ungültiger Maschinenbefehl

Its german for invalid maschine command

The problem is placed somewhere in Lutris, because when I simply install PCSX2 from PPAs it works. But this also installs some libarys. Could this be the point?

This is definitively a library issue. The version we ship runs fine on Ubuntu 16.04 but I haven’t tried other setups.
Have you tried disabling the runtime in the options to see if that does anything?

How to disable runtime in the options?
And I AM running 16.04. And Ubuntu, No Mint or other lookalikes, Ubuntu itself.

in the sidebar, if you have any PS2 games in Lutris, you should have a PCSX2 icon, you can right click on it, click configure and then disable the runtime in the System tab.

If you are running Ubuntu then this is probably due to a library I have installed on my system and you haven’t. If we can find out which one, I’ll add it to the runtime.

Ok, and how could we? xD Is there a list?

I found it. Disabeling Lutris runtime did’nt change anything.

There’s a whole bunch of libraries needed by pcsxr that aren’t in the runtime:

runners/pcsxr/bin/pcsxr depends on these libraries not in the runtime (excluding common system libs):

The first four can be ignored since GTK is a Lutris dependency. The rest, we should add to the runtime. Strange though, I thought we already had most of them.

@Xodetaetl this is PCSX2 we’re trying to debug ^^ PCSXR will be trashed in 0.4.1 and replaced by a libretro core.


By the way @strider, if you don’t have that script to check binaries against the runtime to find missing libs, you need it! And you need to use it to check every runner you add or update and every linux game installer you add or review.

So for PCSX2, it says only is missing. Somehow got past the detection.

I have this script to check for missing libs:
I’d have to adapt it to optionally check against the runtime.

The WX Widgets dependency is probably inside one of the plugins, the .so files need to be checked as well.

This is the script I use. It’s a Valve script from their runtime, modified to exclude common system libraries… and GTK libs. So that’s why libwx was ignored. But that’s an issue because it’s 32-bit GTK, which isn’t a common lib on our 64-bit systems… And which we can’t put in the runtime…

I’m afraid there won’t be an easy solution to solve PCSX2’s dependencies.

Edit: the script in question relies on this one, both must be put in a “scripts/” folder at the same level as the runtime/steam/ folder.

Well, PCSX2 as Lutris runner don’t work on my maschine, but the PCSX2 Runner (when installed seperately from the homepage) works. So I have all the dependencies, or am I making a mistake while thinking? (I should lern english phrases :D)

Hm, if you have disable the Lutris runtime, it should indeed work as well as the standalone version. Though the build is not the same.
You can try replacing the Lutris build with the standalone. You’ll find the former in ~/.local/share/lutris/runners/pcsx2.

If you are running the 0.4.0 pre-release (which you should because we’re looking for beta-testers ;)) then you can set a custom executable for most runner. That way you can point the PCSX2 runner to /usr/bin/pcsx2 and it will work.