Red Dead 2 freezing/stuttering issue

Thanks to @mucan I recently got Red Dead Redemption 2 running with Proton 5.13, but I am having an issue with freezing that’s really getting in the way of enjoying the game.

Even though my framerate is generally very good (about 60fps), every second or so, the game temporarily locks up/freezes very briefly for a fraction of a second. This results in a juddery feel to it. I’m not sure why this happens but there is one other game where I’ve had the same issue and that was Assassin’s Creed Odyssey.

  • I’ve tried deleting the files starting with ‘sga’ in the folder where the game’s system.xml file is and verifying the game with the R* launhcer. While this does help the game to crash less, it does nothing to help this specific problem.

  • I’ve enabled Async Compute in the game’s system.xml file which seemed like it might’ve helped (not solved) the issue a little bit for a short while, but I’m not sure it really did as the problem seems as bad as ever at the moment.

  • I’ve tried using the AMD VLK driver instead of Mesa but that doesn’t help.

  • I’ve tried running the game in DX12 just to see if it works and reduces the stuttering I get with Vulkan but I can’t even get it to launch like that.

Any ideas?

My setup:
Ryzen 2700X
AMD RX5700
16GB DDR4 (3400Mhz)

Kernel 5.9.11-3-MANJARO
Mesa 20.2.3

I’m running all components at no higher than stock speed and my system is normally very stable. Most games work really well but Red Dead 2 isn’t quite one of them.


Bumping because I’ve re-written the post.

I had the stuttering/freezing fixed briefly. I updated my GPU driver from stable to mesa-git (Devel 21) and the freezing issue went away, but next time I played it, it was back :frowning: At some point during this, Proton had updated from 5.13-3 to 5.13-4.

Maybe another update to Proton or Mesa will solve it. I guess I’ll just have to wait and see. But if anyone has any other suggestions…


Edit: I tried Proton 5.13-3 again and it still stutters.