Can someone update the Red Dead Redemption 2 R* installer?

It looks like Steam users are having success with the game which is cool. I can’t get the Rockstar Games Launcher version to work though. It hasn’t been updated in months. Can someone who knows how please update the installer?


you can use the normal installer or the Rockstar Games Launcher installer and then switch the wine version to proton 5.13 (if you change the version after downloading RDR2 make sure the directx thing is installed otherwise the game won’t start if you download rdr2 with proton 5.13 it will automatically install) then when trying to start the game you need to enter this into a terminal:
“PID=$(pgrep RDR2.exe); kill -s SIGSTOP $PID; kill -s SIGCONT $PID”
without the quotes “”
and the game should start…

i think no one updates the installer because it needs Proton 5.13 and i don’t know if you can automate the terminal command

Edit: when trying to start the game you need to press the start button and then wait a little bit if you want to make sure just wait until the button says stop game and then enter the command into a terminal and then the game should start if it does not you can try to enter the command again


Thanks for the help. I selected Proton 5.13 and verified the game files which prompted the DirectX install I must’ve been missing before and then got the game to launch :slight_smile: Finally…

Now the problem I have is that Lutris won’t let me enable ESYNC or FSYNC when using Proton. Proton can use these functions can’t it?


i know that lutris throws an error about esync/fsync but i don’t know if they don’t still work… RDR2’s performance is good for me anyway so i don’t care about that but your mileage may vary

if it run’s fine just leave it be i’m still fairly new to linux with only a few years of experience and so often i’ve broken things just trying to fix something that wasn’t broken and even if i did fix something then the performance increase was always negligible

It’s just weird because it doesn’t do that with the custom GE Proton builds so I figure there must be some issue there. Anyway, it’s just cool to see the game launching after quite a wait to get it working. I haven’t tested it to see the performance yet but I will soon. Thanks for the help :slight_smile:

if you have an amd graphics card performance should be even better than the windows version also with the special proton build RDR2 has been playable for months

Yeh I do have an AMD GPU so hopefully it’ll be good. Though I could never get the game working with those custom WINE builds from the Codeweavers guy. But, I guess it was for the same reasons - that DirectX installation failure I was unaware of.

after getting the game working a few times and a few times not i just discovered that directx installation thing 1 or 2 days before your post here so luckily i included that since it seems that might have been your main problem from the beginning

Hi @mucan
I’ve just installed RDR2 but only read this post about switching to Proton 5.13 after the installation.
After i switched from the lutris wine version to Proton the Rockstar Social Club launcher doesn’t start anymore.
What do you mean by installing the DirectX thing?
Any help appreciated :slight_smile:

yeah i had trouble sometimes switching to proton too. try deleting the steamuser folder in users in your rockstar prefix or switching back and forth between proton and the normal lutris wine version helps sometimes.

as soon as the launcher works with proton go to the settings and verify the data/files integrity of the game and the launcher will do the rest and then the game should start after you hit the play button and type the PID command into a terminal like i described earlier

Hmm no luck for me then.
I deleted the steamuser folder and switched between lutris wine and proton for a few times, but that didn’t help.
Is it possible to reinstall the Rockstar Social Club Launcher without re-downloading the whole 120 freaking GB game again?

Okay I got it to run.
Over the Wine Control Panel I was able to uninstall the Rockstar Games Launcher.
Then I copied the new launcher-xxx.exe into the wine prefix and installed it again by using the Wine Control Panel. Worked just fine and detected the existing game files afterwards.

The only problem i have now, is that i can’t run the game in fullscreen mode and the max screen resolution is capped to FullHD.
I guess the FullHD bug is known, but playing fullscreen would be nice.
I am using wayland as display protocol, is that the reason why it doesn’t’ work?

@MajorMayer I’ve been able to play it in 1440p in either windowed, fullscreen windowed or full screen. I use Manjaro and am on Kernel 5.9.11-3-MANJARO and Mesa 20.2.3 if that’s of any use…

The game seems to run pretty well so far as far as FPS is concerned. Although, I haven’t gotten very far as the game keeps crashing about every 30 minutes, forcing me to keep replaying missions from the start. I don’t know why this is happening…

I see people mention things on ProtonDB ( like

WINEDLLOVERRIDES=“dxgi=n,b” taskset -c 8-15,40-47 %command%

but I don’t know what that does so I haven’t tried it.

1 Like

i don’t know the taskset command but the dxgi override helped with some systems when the game was crashing but as far as i know the dxgi workaround isn’t needed with newer versions of mesa

I’ve actually got the game running pretty good now without crashing too often but there is one issue that’s ruining it. That is the constant freezing every 1-2 seconds. I turned on AsyncCompute in the config files and started running mesa-devel drivers which seemed to get rid of it, but now it’s back again.

I made a thread about it here: Red Dead 2 freezing/stuttering issue