Red Alert 2 via Electronic Arts App does not launch


I was trying to install & run Red Alert 2 which I had on origin. I tried by just adding the game using lutris → origin connection. That installed origin, but origin just showed me a notification to migrate to “EA App” that I could not dismiss. So I thought, ok, maybe origin is EOL or so… (I do not pay much attention to origin, TBH)… is that right? Or did I do something wrong there already?

Anyway, updating to EA App from origin did not work, so I just installed the EA App “game” using lustris. That worked okish and EA App starts and is now logged in. I installed the game → all fine till now.

But when I try to launch Red Alert 2 I get a strange message from EA App that the game needs “administrator rights” and if I am sure to run it. Saying “ok”, I get some progress bar and after that an error message that “something on our side” has failed and I should try again later. I suspect EA App tries to solve issues with Windows Account thingie (EAC), but I guess that is not necessary on wine…

I tried to run lutris from the terminal, but could not find much usuful information there. I tried to just run the game exe usind “run exe in prefix” lutris option but that produced the error “missing ssleay32.ddl”… what is that?

Anyway, would be glad for any hints. Anybody experienced similar issues?


1 Like