Problem with RX 6800

Hi, after I changed card from Nvidia GTX 1070 to AMD RX 6800 I have light bug in GTA 5, sometimes it’s black and also ground is sometimes black. This is the only problem, game runs very nice and smooth, also, this is the only game with any problem. I use Lutris (game from social club) to play. I tried different wine versions (I need to use lutris-5.7-11, because in lutris-6 game stutter when any key is pressed, known bug from what i searched), dxvk versions, game settings, mesa and also compiled myself mesa-git. My system is Arch Linux, but I also tried on clean installed Manjaro, so the problem is not about any things that might be left from Nvidia (like dxvk cache). I’m running out of ideas, can someone hint me what the problem might be? Or if this is a new bug, because it’s quite new GPU, then should I report it in wine or somewhere else?
screenshot and logs here

I got the same issue with an 6800xt. On ProtonDB someone reported, that this can be fixed by using LLVM instead of ACO as shader compiler (in case you use MESA)

to enable LLVM there is an environment variable:
You want to check if this really runs with LLVM, though - for me this environment variable somehow does not get passed correctly to the driver. To do this, add an additional variable DXVK_HUD=devinfo,driver,api
to get some debug information. there should be mentioned “ACO” or “LLVM” somewhere. If its running with LLVM the bug should be gone.

I already opened a thread or the variable not getting passed to the driver correctly: Can't get RADV_DEBUG environment variable get passed to games

Do I need to install something additional? When I pass RADV_DEBUG=llvm %command% as Command prefix the game doesn’t even start, without any informations. Just 3 seconds of nothing and then lutris apears again. Using Environmend variables doesn’t work like in your post, game just starts with ACO compiler.

No, putting it into environment variables should be the correct way to do it. I get the same behaviour using the Command prefix.

I think this is a Lutris bug. Using Lutris I can’t get other games running with LLVM either. In Steam/Proton RADV_DEBUG is working fine. But I don’t want to buy another copy of GTA on steam just because of this.

I made a pull request on git to fix this bug. Locally, with the patched code I can run GTA V with llvm and the rendering issues are gone.

You’ll have to wait for the next lutris release though, or switch to the git/dev version until then.

1 Like

Thank you very much! After switching to lutris-git game runs with llvm, and without any graphical glitches. Maybe a little less FPS than ACO, but very smooth anyway.