Back to the main site

Overwatch: mouse laggy and jerky on game but fine on menus

The mouse works flawlessly on menus, but when gaming it does not go smoothly where i point.
Here’s a video clip showing the problem:

Overwatch with Lutris sluggish mouse ingame

The game was installed using everything official from the ubuntu ppa.

There was some discussion about this issue or something very similar on Discord. I don’t think we have found a solution for this yet.

Are you able to currently reproduce the issue or only happens to some users?

I haven’t played Overwatch in a while and it didn’t have the issue when I did. I think it might be related to a recent game update.

I noticed that laggy mouse suddenly lately. I don’t have it anymore now. I think that it had to do with me setting “reduce buffering”. I disabled that again. I don’t think this setting translates correctly to Linux.

Personally I think Nvidia’s “FullCompositionPipeline” actually does something similar, namely syncing the buildup of frames to the refresh rate of your screen. It is a 1 time shift of your framebuilding, that doesn’t introduce input lag. (Note: this isn’t vsync, that holds on to buffers till the screen refresh starts, introducing lag.)

Now, if your problem is something else: Remember that Overwatch uses raw input from your mouse, but since you are on Linux, this actually can be influenced by your settings outside of the game. I found this out when I first started playing OW on linux ages ago. I have a roccat mouse where I could set a lot of stuff in the open source driver. And also had DE (gnome 3) settings messing up my mouse, then it turned out, I had some sort of mouse acceleration from X. Read up about it here: https://wiki.archlinux.org/index.php/Mouse_acceleration

Oh and if your mouse is moving by itself, then your screen resolution is set incorrectly.

The screen resolution is correct (1920x1080), and the issue when moving the mouse also happens when using the touchpad. I set mouse acceleration to the minimum but still the same, seems unrelated.

I’ve tried with FullCompositionPipeline on and off and Reduce buffering on and off also and is the same.

Maybe there was some update to the Blizzard software? In Hearthstone something similar happens:

@parigan Try rolling back to staging 2.18

Wine 2.18 is not available as a package for ubuntu 17.10 artful aardvark. Only versions:
2.0.3
2.19.0
2.20.0
2.21.0

You’re using Lutris aren’t you? Download it via the runners window.

Yes I’ve tried with Lutris, the video on the first post is work Lutris.
Then I tried without lutris to see the differences but no luck.

After you start Overwatch, open a terminal and type this: killall Battle.net.exe Agent.exe

Oh, and 2.18 is better then 2.21, thats IMO, but also some other people have said the same, so using that is just good in either case.

Ok, and what about Wine 3.0-rc2 or git?

Nothing new for Overwatch, or any Blizzard games. Just stay on 2.18.

Did you try the killall thingie?

I can’t install Overwatch:

I thought you had it installed. Well, once you got it installed (again?), try it.

Still the same with wine-staging-2.18-x86_64. I’ve tried changing Mouse Warp Override to Enable but it’s even worse.

killall Battle.net.exe Agent.exe

In a terminal after you press Play in Blizzard App.