Back to the main site

Origin wont start on Manjaro 18

Hi, I have installed lutris and wine-staging on my system, I tried to install The Sims 4 with DXVK gold script, but origin wont start. I tried this: origin-not-launching-on-manjaro (these are names of topics on lutris forums, because of stupid restricions on this forum) but that isn’t helpful at all, also I tried this: Origin won't open after fresh setup I installed both 32bit/64bit amd vulkan drivers, but somethink is little weird when I try vulkaninfo:
ERROR: [Loader Message] Code 0 : /usr/lib32/libvulkan_intel.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib32/amdvlk32.so: wrong ELF class: ELFCLASS32
ERROR: [Loader Message] Code 0 : /usr/lib32/libvulkan_radeon.so: wrong ELF class: ELFCLASS32
but I dont this, that this should affect launching origin. Please help
error:
Running /home/pavla/.local/share/lutris/runners/wine/tkg-4.0-x86_64/bin/wine /home/pavla/Games/the-sims-4/drive_c/Program Files (x86)/Origin/Origin.exe
wine: Unhandled page fault on execute access to 0x00a1de00 at address 0xa1de00 (thread 003a), starting debugger…
Unhandled exception: page fault on execute access to 0x00a1de00 in 32-bit code (0x00a1de00).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:00a1de00 ESP:00a1d1e4 EBP:00a1d228 EFLAGS:00010246( R- – I Z- -P- )
EAX:00a1de00 EBX:00a1d400 ECX:00a1d240 EDX:00000001
ESI:00a1d240 EDI:00716c28
Stack dump:
0x00a1d1e4: 00401990 6bc28d0b 7e677ee0 004429d0
0x00a1d1f4: 7e74b498 00a1d220 00a1d47c 7e677ee0
0x00a1d204: 00716c28 00a1d2a4 00404e4b 6bc28d03
0x00a1d214: 00a1d298 6bc28d0b 00a1d298 0043e5a0
0x00a1d224: ffffffff 00a1d2a4 004051c2 6bc28d87
0x00a1d234: 00a1de00 00716c28 00443ef8 00000000
Backtrace:
=>0 0x00a1de00 (0x00a1d228)
1 0x004051c2 EntryPoint+0xffffffff() in origin (0x00a1d2a4)
2 0x004064a4 EntryPoint+0xffffffff() in origin (0x00a1dd0c)
3 0x00406b2c EntryPoint+0xffffffff() in origin (0x00a1dd78)
4 0x004263e7 EntryPoint+0xffffffff() in origin (0x00a1fc38)
5 0x0041d449 EntryPoint+0xffffffff() in origin (0x00a1fedc)
6 0x7bcb0094 (0x00a1feec)
7 0x7bcb3960 (0x00a1ffdc)
8 0x7bcb0086 (0x00a1ffec)
0x00a1de00: xorl %eax,0x0(%eax)
Modules:
Module Address Debug info Name (45 modules)
PE 400000- 700000 Export origin
PE 7b420000-7b5e6000 Deferred kernel32
PE 7bc40000-7bc57000 Deferred ntdll
PE 7c0c0000-7c0cc000 Deferred mpr
PE 7c0f0000-7c111000 Deferred wininet
PE 7c160000-7c173000 Deferred urlmon
PE 7c790000-7c7b4000 Deferred msxml3
PE 7c870000-7c87e000 Deferred msxml
PE 7c8d0000-7c8d6000 Deferred uxtheme
PE 7d100000-7d106000 Deferred winex11
PE 7d1a0000-7d28e000 Deferred msvcr120
PE 7d270000-7d2ab000 Deferred concrt140
PE 7d290000-7d294000 Deferred api-ms-win-crt-locale-l1-1-0
PE 7d2b0000-7d2b4000 Deferred api-ms-win-crt-filesystem-l1-1-0
PE 7d2c0000-7d2c4000 Deferred api-ms-win-crt-time-l1-1-0
PE 7d2d0000-7d2d7000 Deferred api-ms-win-crt-math-l1-1-0
PE 7d2f0000-7d2f6000 Deferred api-ms-win-crt-stdio-l1-1-0
PE 7d300000-7d305000 Deferred api-ms-win-crt-convert-l1-1-0
PE 7d310000-7d314000 Deferred api-ms-win-crt-heap-l1-1-0
PE 7d330000-7d336000 Deferred api-ms-win-crt-string-l1-1-0
PE 7d340000-7d345000 Deferred api-ms-win-crt-runtime-l1-1-0
PE 7d350000-7d365000 Deferred vcruntime140
PE 7d370000-7d375000 Deferred bcrypt
PE 7d390000-7d3d5000 Deferred crypt32
PE 7d460000-7d467000 Deferred wintrust
PE 7d4a0000-7d4a6000 Deferred imm32
PE 7d4c0000-7d4c4000 Deferred usp10
PE 7d500000-7d554000 Deferred comctl32
PE 7d640000-7d64a000 Deferred aclui
PE 7d660000-7d666000 Deferred shcore
PE 7d680000-7d692000 Deferred shlwapi
PE 7d700000-7dff6000 Deferred shell32
PE 7e0f0000-7e119000 Deferred ucrtbase
PE 7e210000-7e27d000 Deferred msvcp140
PE 7e300000-7e307000 Deferred ws2_32
PE 7e330000-7e33d000 Deferred rpcrt4
PE 7e3d0000-7e3fd000 Deferred ole32
PE 7e520000-7e52e000 Deferred oleaut32
PE 7e640000-7e646000 Deferred jsproxy
PE 7e660000-7e667000 Deferred winhttp
PE 7e6c0000-7e6c5000 Deferred version
PE 7e6e0000-7e7d3000 Deferred user32
PE 7e8f0000-7e8fd000 Deferred advapi32
PE 7e960000-7e96e000 Deferred gdi32
PE 7ef00000-7ef03000 Deferred wow64cpu
Threads:
process tid prio (all id:s are in hex)
00000008 (D) C:\Program Files (x86)\Origin\Origin.exe
[“C:\Program Files (x86)\Origin\Origin.exe”]
0000003a 0 <==
00000009 0
0000000e services.exe
0000002e 0
0000002b 0
00000026 0
0000001e 0
00000018 0
00000015 0
00000014 0
00000013 0
00000010 0
0000000f 0
00000011 winedevice.exe
00000019 0
00000017 0
00000016 0
00000012 0
0000001a OriginWebHelperService.exe
[“C:\Program Files (x86)\Origin\OriginWebHelperService.exe”]
00000039 0
00000038 0
00000032 0
00000030 0
00000025 0
00000024 0
00000021 0
00000020 0
0000001f 0
0000001d 2
0000001c 2
0000001b 0
00000022 plugplay.exe
00000028 0
00000027 0
00000023 0
00000029 winedevice.exe
0000002f 0
0000002d 0
0000002c 0
0000002a 0
00000033 explorer.exe
00000037 0
00000036 0
00000035 0
00000034 0
System information:
Wine build: wine-4.0 ( Staging Esync )
Platform: i386 (WOW64)
Version: Windows 7
Host system: Linux
Host version: 4.19.56-1-MANJARO
Waiting on children
All children gone
Exit with returncode 5
System:
Host: pavla-pc Kernel: 4.19.56-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 9.1.0 Desktop: Cinnamon 4.2.0 Distro: Manjaro Linux
Machine:
Type: Desktop System: LENOVO product: 90B60075CK v: Lenovo H50-50
serial:
Mobo: LENOVO model: SHARKBAY v: 31900058 STD serial: UEFI: LENOVO
v: IEKT31AUS date: 03/09/2015
CPU:
Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP
arch: Haswell rev: 3 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 25555
Speed: 1054 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 998 2: 998
3: 998 4: 998
Graphics:
Device-1: AMD Lexa PRO [Radeon RX 550/550X] vendor: Micro-Star MSI
driver: amdgpu v: kernel bus ID: 01:00.0
Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: modesetting
resolution: 1920x1080~60Hz
OpenGL: renderer: Radeon 550 Series (POLARIS12 DRM 3.27.0
4.19.56-1-MANJARO LLVM 8.0.0)
v: 4.5 Mesa 19.1.1 direct render: Yes
Audio:
Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1
Device-3: Logitech Webcam B500 type: USB driver: snd-usb-audio,uvcvideo
bus ID: 2-2:3
Sound Server: ALSA v: k4.19.56-1-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8168 v: 8.047.01-NAPI port: d000 bus ID: 03:00.0
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 1.14 TiB used: 44.51 GiB (3.8%)
ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08M2NA0
size: 931.51 GiB
ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
Partition:
ID-1: / size: 76.30 GiB used: 8.52 GiB (11.2%) fs: ext4 dev: /dev/sdb3
ID-2: /home size: 121.56 GiB used: 35.99 GiB (29.6%) fs: ext4
dev: /dev/sda6
Sensors:
System Temperatures: cpu: 32.0 C mobo: N/A gpu: amdgpu temp: 29 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1363
Info:
Processes: 219 Uptime: 51m Memory: 11.68 GiB used: 3.31 GiB (28.4%)
Init: systemd Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 inxi: 3.0.34

Problem starting Origin on Manjaro Solved my problem

1 Like