Back to the main site

Making fallout 76 work (yes it does)

I worked hard and got faloout76 to run in linux.
Here are my notes:

install lutris

go to lutris.net and create an account.
login
search for fallout 76 and click on it
click on ‘add to library’ on the right side of the page
install lutris software from the website
run and login

lutris must be 0.5.2 or higher; .0.5.1 has some sort of serious issue with bethesda.net
nvidia driver must be 418.56 or higher
In ubuntu or mint you must add the graphics ppa to get access to nvidia 418.56

right click bethesda icon and select configure
DXVK version should already be set to 1.2.1 which is fine
wine should be 4.0 or higher. if not change it from the drop down.
bethesda launcher needs at least wine 4.0.

Use lutris to install the bethesda.net launcher…and then run it

when the bethesda launcher comes up…
click to download fallout76
If it fails…or just suddenly stops…
In /home/{userloginname}/Games/bethesda-launcher/drive_c/Program Files (x86)/Bethesda.net Launcher/
delete any cdpprod.xxx files and try again. it will start downloading the game.

BUG Fixes:
In /home/[userloginname]/Games/bethesda-launcher/drive_c/users/{userloginname}/My Documents/My Games/Fallout 76

Create Fallout76Custom.ini

add bBackgroundMouse = 1 ; fixes severe mouse issue
change or add bEnableEnlighten= 0 ; fixes nasty blood red glow over everything

Edit Fallout76Prefs.ini

change iPresentInterval=0 ; turns off vsync which causes massive lag

Other BUGS:
Every so often the game quits to the desktop.
I have no answer for this yet.

p.s. the helper script included with the installer was not helpful. i think something changed and it quit working.

@bash64

Fallout76Custom.ini for mouse issue does not solve the problem with multi monitor use

what problem do you experience with multiple monitors?
i posted a fix for that on the steam forum .
it involved the game always using the wrong monitor.
i can repost here if you need it.

if the mouse is running over to other monitors you can do two things:

  1. use winecfg and tell wine to grab the mouse when in full screen
  2. tell lutris to use a virtual desktop for the game
  3. turn off all but one monitor
1 Like

reposted from steam forum:

Steam and proton monitor fix:

I found out something important to those with multiple monitors that use steam for linux to run their windows games.

For most the game will run on the wrong monitor with no way to fix the issue.

Here is my fix…

I have 3 monitors so I use menu->preferences->display (linux mint 19.1) to setup the monitor I want the game to run on on top and the other monitors below it as such in the below picture. This can be done using any distro. Your tool will vary.

The game always runs on the monitor that is on top. I no longer have to disable all but one monitor.

Why does it work?
If you have multiple monitors they are treated as one big monitor. When I had them defined as side by side I probably had a width of 5760x1080p. In this new top->down manner they are 1920x3240. What seems important to WINE is the width, not the height. WINE no longer crashes, fails to run, runs the game on the wrong monitor,etc… I no longer have to disable all but one monitor.

Any bugs?
Proton seems to have an issue with alt-tabing out of a game. At least Fallout 4 has this issue.

Usefulness?
I open my browser to the twitch stream I want to watch while I am gaming on the bottom monitor and the System Monitor on the middle monitor and Fallout 4 runs on the top monitor REGARDLESS of its real physical position.

Enjoy.

if any of this helped you please say so so others can benefit.
if anyone has ideas about the random crashing to the desktop please let us know.
it really is the only bug i encounter in the game. i have all the others fixed.

i cant test until i get home tonight, but good write up.
My original solution to play was to unplug the monitor but thats not a fix to the problem.

ill checkout the wine and lutris method.

@bash64 i didnt know those options existed at first glance. settings lutris to vm mode worked for me

what is vm mode?

virtual desktop worked…

but now it crashes when i encounter more than one enemy lol… i cant win…
its not my graphics, considering im running a vega64 and on medium graphics on a 1080p @ 144fps

yeah. due to desktop crashing i have gone back to qemu with gpu passthru. its odd. i can go 3+ hours with no crash, but then it will start crashing every 5 seconds.
i will say that when i went back to running it in windows it desktop crashed also, just not as often.
this game has problems even without linux.
it has constant server disconnects and heavy lag regardless of OS.

I thought I would post this here as well, to see if it will help more people trying to play Fallout 76 on Linux. I posted this here: Fallout 76 will not install.

I did the following set up to install and run FO 76:

  1. Run Fallout 76 in Lutris.
  2. Run helper.sh script (I dragged and dropped it into terminal and pressed enter)
  3. Right click on Fallout 76 icon in Lutris and select “Run EXE inside wine prefix”
  4. Navigate to the Bethesda launcher folder and select “BethesdaNetUpdater.exe”
  5. Wait 5 seconds
  6. Manually delete “cdpprod.dch” in the Bethesda folder
  7. Select “Install” in the Bethesda launcher for Fallout 76 and it should work!

The issue you mentioned though, about having a mouse/border issue, I found some support somewhere else on this forum (I’m sorry that’s not more helpful, but I can’t find it anymore).

That said, when I opened my configuration for Fallout 76 in Lutris, and selected "Runner options > “Windowed (virtual desktop)” toggled it to on and “Virtual desktop resolution” set to 1920 x 1080, I was able to get rid of the mouse issue I was experiencing:

Every time I would turn right the mouse would lock up and I couldn’t turn all the way around. I have an Nvidia card, and thought that it was to do with the pref.ini mentioned in the Lutris page for the game. I followed the instructions there and, with these settings, I was able to turn all the way around in game without the mouse sticking.

I found a youtuber (here https://www.youtube.com/watch?v=smF4z6Fafpw) who was getting ~60 FPS with his setup. He recommended using the following settings in Lutris:

wine-tkg-4.0, DXVK 0.96, and E-sync (I have tried everything but E-sync) and the game is doing much much better.

It no longer crashes for me when I encounter several enemies or when blood particle effects are rendered. I did notice a crash while trying to take a picture in Picture Mode. Maybe E-sync will fix this?

1 Like