Back to the main site

Lutris wine steam black screen

Hello!

I decided to register here because i’ve been using Lutris for some time and it is great. Hovewer recently i found one problem and i can’t solve it. After launching Lutris Wine Steam after logging i see only black screen, nothing exept of “Steam application bars”. When i launch Lutris Steam everything works, but Lutris Wine Steam gives me blac screen. I tried to change Wine version but the same thing is still heppening. I found similar topic, read it but in my case Wine 3.21 did not solve black screen problem. Could somebody help me and point toward solution? I use Arch Linux 64 bit.

Hi,

I had the same problem. Enabling DXVK, D9VK and Esync helped me with this. Hope, it helps you too.

Greets

Unfortunately, that is not the case. I’m running Lutris and Lutris Wine Steam on laptop with Intel Pentium B960 and i cant choose DXVK and D9VK options because they are related to Vulkan. As soon as i turn it on and click save they are being turned off. It is not related to my problem because Lutris Steam works correctly, but Lutris Wine Steam does not with this black screen issue. I think that this problem is related to this message:

“wine: cannot find L"C:\Program Files (x86)\Steam\bin\cef\cef.win7x64\steamwebhelper.exe”"

This message has been dealt with before. Turned out the OP reformatted the drive to the ext4 file system, then reported this error and lastly came back with the information that he indeed reformatted the drive and had no problems after that.

From what I can see from his logs, he originally ran the WINE prefix from his home directory, which is ext4, and mounted a separate ntfs drive to /mnt… This drive was available under WINE as S:. I think his problem was the combination of two different file systems. When he reformatted the drive as ext4, and probably assigned himself as owner, all problems went away.

If you are on ntfs then this might be a good one to look into. If you are running ext4 then its always good to check permissions.

I run it with ext4, and permission are ok, i did not change it, earlier it worked,after recent update it stopped. Which file is should check permission, or what exacly?

I would investigate the location you are getting the error on.

C:\Program Files (x86)\Steam\bin\cef\cef.win7x64\steamwebhelper.exe

It should be in your prefix. Is it there? Who owns it? What are the permissions?

Right click on the game and choose Browse files. The prefix is usually in the sub-directory called prefix.

Quick question: did you start Lutris as super user? That’s a very common thing users seem to be doing and when it writes files the owner is root, not your account. When you start Lutris with your own account, as is intended, then Lutris doesn’t have access anymore.

Hi it dosn’t work for me with DXVK D9VK Esync and i got black screen on library too

I start Lutris as a user, not root. Also, location that you quoted is rather virtual, because it is message from Wine.

Steam has had an update recently to change the Library to the main view and the way it interacts with wine has changed. Since that update, I have the same issue as those comments above running Borderlands 2, which uses the Lutris wine steam runner.

I can create a brand new wine prefix and get Steam “working visually as intended”, (more or less,) without DXVK or DX9 needed, just using ge-protonified-4.9-x86_64.

The Lutris wine steam runner may need some <3 to get it working with this update.

Yes, I double-checked all permissions, by the way :slight_smile:

@XDqAtG5A8g That’s a good piece of information.

Isn’t it enough to, instead of installing the game again, simply change the WINE version used via Game config screen / Runner options / WINE version?

I see that the installer script for borderlands 2 already contains this version of WINE. Maybe running the installer again will solve it now for those users?

About running as root, the question just popped in my head and I thought: lets ask… :slight_smile:

About the virtual game path which WINE sees, you can easily translate it to a Linux path. As I mentioned, you can open the game directory by right clicking on the game and then choosing Browse files. Then you navigate to:

[gamedir]/prefix/drive_c/Program\ Files\ (x86)/Steam/bin/cef/cef.win7x64/steamwebhelper.exe

Yes that is what i had in mind. I updated steam and i saw that main window with library changed. I use Steam native linux client with Lutris and saw this change. With Steam Wine under Lutris it does not work, while before steam update it worked. Also, mentioned above “steamwebhelper. exe” does not exist in mentioned location at all. Checked it. Thers is not sucha a file. I think that it is something to do with Lutris/Wine and Lutris update, or tweak rather than something with Steam, becasue native linux Steam works.

There is no such file in this location. I don’t have it. Also, changing Wine version does not help at all. Tried that.

There is a central steam location in your home directory.

/home[username]/.local/share/lutris/runners/winesteam/prefix/drive_c/Program\ Files/Steam

Do you have this one?

Yes, I do have the runners in that location.
My Borderlands 2 log references the steamwebhelper.exe via S: rather than C:. It also complains it cannot find it, but it is accessible to the prefix and the location is readable/writable through winetricks -> select default prefix --> windows explorer.

I’m using my custom prefix to play for now, but I’ll get some time tomorrow, and have a better look at the runner.

Keep us posted, I like this kind of problems. :slight_smile:

For steamwebhelper.exe - the simple answers are the best.

Note: This fixes the black screen and lack of “friends” login, although graphically it is a glitchy.

Winecfg shows the runner has an override to disable steamwebhelper.exe.
Winetricks -> select the default wineprefix - run winecfg
Libraries tab… scroll down …steamwebhelper.exe (disabled)

…remove the entry and relaunch - steam library now works, but its glitchy as hell on my Borderlands 2 setup (d9vk 20).
Also confirm the advice from @Tehreal is correct - disabling dxvk and d9vk seem to break that part of Steam now. Esync doesn’t work for me, but if it did, it might fix the glitching a bit :slight_smile:

Winetricks or winecfg you started trough Lutris? How or where?

You can use the WINE config from Lutris too. The key is to change the setting for the prefix your game is using.

Great thread b.t.w. this is how it’s done. Find a solution to a problem and inform the rest of the community to solve their problem. :+1:

Steam is not a game, but launcher and there is no config or button to change wine settings via Lutris (like similar one with Playonlinuxe, where from Playonlinux configuration wine settings could be changed). I read Lutris documentation and it says that Wine is conffigured via commands. I solved my problem, setting Wine from winecfg to WinXP solved black screen problem, but it is glitchyy

TBH since Steam added Proton I hadn’t really installed any game in Winesteam as Proton seems like a generally better solution (only the game itself is run in Wine, which reduces amount of places where this can break by that much). Though I still have to adjust it via winecfg/winetricks (or rather, protontricks), there has been much less issues with rendering.