Lutris doesn't start on Ubuntu LTS

Ubuntu 20.04.1, Lutris 0.5.8.2
Lutris installed from the PPA showed this on startup in the terminal:
+Traceback (most recent call last):
File “/usr/games/lutris”, line 54, in
from lutris.gui.application import Application # pylint: disable=no-name-in-module
File “/usr/lib/python3/dist-packages/lutris/gui/application.py”, line 53, in
from .lutriswindow import LutrisWindow
File “/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py”, line 26, in
from lutris.gui.widgets.sidebar import LutrisSidebar
File “/usr/lib/python3/dist-packages/lutris/gui/widgets/sidebar.py”, line 6, in
from lutris import platforms, runners, services
File “/usr/lib/python3/dist-packages/lutris/platforms.py”, line 19, in
_init_platforms()
File “/usr/lib/python3/dist-packages/lutris/platforms.py”, line 14, in _init_platforms
runner = runners.import_runner(runner_name)()
File “/usr/lib/python3/dist-packages/lutris/runners/wine.py”, line 229, in init
“default”: dxvk.DXVKManager().version,
File “/usr/lib/python3/dist-packages/lutris/util/wine/dxvk.py”, line 56, in version
return self.versions[0]
File “/usr/lib/python3/dist-packages/lutris/util/wine/dxvk.py”, line 45, in versions
self._versions = self.load_dxvk_versions()
File “/usr/lib/python3/dist-packages/lutris/util/wine/dxvk.py”, line 65, in load_dxvk_versions
with open(versions_path, “r”) as dxvk_version_file:
FileNotFoundError: [Errno 2] No such file or directory: ‘/home/user/.local/share/lutris/runtime/dxvk/dxvk_versions.json’

@JxTankblaster open a terminal and type this command:
wget https://cdn.discordapp.com/attachments/538903130704838656/796102070825779250/dxvk_versions.json -P $HOME/.local/share/lutris/runtime/dxvk
Should resolve your issue.

9 Likes

Thanks for that. It works.

Work for me. THX!

Worked for me aswell (mint 20.1). Big thanks from a newbie

1 Like

But but… Do I really have to install some long random file from an untrusted, unrelated source that I don’t understand at all and is full of random URLs and is suggested by a user on some forums?
I believe this is a bug and should be fixed. I would report an issue on GitHub, if they didn’t choose to disable reporting issues for non contributing users…

I understand your reaction Trivia21 but I’m not a lambda user here, I’m part of the Lutris team and one of the Lutris forum moderators (look at the icon next to my account name). So when I give you support, you can trust me. We already know about this bug and it will be resolved in next update.
Meanwhile, users have to use this workaround.

2 Likes

Thanks for your reply. That sounds good, I hope it will be fixed.

OMG you`re so genious.
I definitely had already given up, but it worked here. thankful!

When will the update be?

Thank you stranger you just saved me from a night of stress!!!

When I try using this fix, I get a 403 forbidden error?

I just tested, the url is still valid

Okay, I’m not sure why on my linux system I couldn’t get the file, but I was able to use that link on my phone and then copy the file over to the linux system. Thanks!

It seems like you might be pasting the command into your browser URL field. :thinking: The command has to be (copied from this page or typed) put into your terminal and executed. Wget “gets” the file from GitHub. :+1: Then it helps to execute lutris in the terminal so that you can watch it work. It can take a while but it does it well. :ok_hand:

I was thinking that it would be nice if a GUI interface would open and ask if Lutris can submit the wget command. That way the user knows what’s going on and the files can always be fresh… :thinking: The progress bar could then keep the user notified.

Thanks so much for the fix! :slightly_smiling_face: I’m going to share this on my Facebook wall and in the Linux Fans Group. :ok_hand:

No I was using the terminal lol

Worked for me aswell (mint 20.1 fresh install).

Phew thank goodness I found this. leglu’s post did the trick on a clean install of mint like the last guy. GAME ON!