[League Of Legends] Stuck at login screen

As the title says, my client lol is stuck on the login screen, I think the problem occurred after I upgraded my wine “1.9.2 staging” to the new “2.18 staging” version, I was using the opengl version of the install script of lol. After discovering a new update of the script that promised to increment more fps, I updated my wine to the new version “2.18 staging”,backed up the game files, deleted the lol wine prefix generated by lutris (using lutris), then reinstalled the game, everything went well, until I try to connect to my account, after entering my username and password, the client shows ‘authenticating’, but after a long time nothing happens and the loop repeats …
things I’ve tried:

  • Install the game without backup by the NA client
  • Change server, i’ve tried: Russian,Brazilian,North America
  • Change some settings in lutris, such as: process monitor,csmt,wine version,lutris runtime,etc

Can someone help or suggest something?

Similar problem: https://forums.lutris.net/t/league-of-legends-lol-authentication-login-not-working/594/4


please verify you have installed the required system dependencies for wine in order to run LoL: https://wiki.archlinux.org/index.php/League_of_Legends#Install_the_dependencies this article is for arch but the packages apply to all distros. package names may differ slightly per distro

Thanks for reply.
I checked the list of system dependencies and I think it’s up to date

  • liblcms2-2/xenial,now 2.6-3ubuntu2 i386 [installed]

  • libgnutls30/xenial-updates,xenial-security,now 3.4.10-4ubuntu1.3 i386

  • libldap-2.4-2/xenial-updates,xenial-security,now 2.4.42+dfsg-2ubuntu3.2 i386 [installed]

  • winetricks 20170823 [installed]

  • lib32-alsa-lib [installed]

Wine output after the first error:

err:winediag:wined3d_adapter_init GL_ARB_compatibility not supported, requesting context with GL version 3.2.
fixme:shell:SHGetPropertyStoreForWindow (0x90048 0x6bb27c 0x35de6f8) stub!
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x500a2 0x00000000
fixme:msctf:InputProcessorProfileMgr_GetActiveProfile (0x35ff0c8)->({34745c63-b2f0-4784-8b67-5e12c8701a31} 0x33ea4c)
fixme:ntdll:EtwRegisterTraceGuidsW (0x10144ff0, 0x11fec2e0, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x11fc0360, (null), (null), 0x11fec2f8): stub
fixme:ntdll:EtwRegisterTraceGuidsW register trace class {00000000-0000-0000-0000-000000000000}
fixme:ntdll:EtwRegisterTraceGuidsA (0x6307379f, 0x630b1cf8, {0cfe0455-93ba-440d-a3fe-553973d0b723}, 1, 0x33ece8, (null), (null), 0x630b1d00): stub
fixme:ntdll:EtwRegisterTraceGuidsA (0x6307379f, 0x630b1d18, {797fabac-7b58-4796-b924-d51178a59ce4}, 1, 0x33ece8, (null), (null), 0x630b1d20): stub
fixme:ntdll:EtwEventRegister ({43d1a55c-76d6-4f7e-995c-64c711e5cafe}, 0x6309ce28, (nil), 0x630b1500) stub.
fixme:ntdll:EtwEventRegister ({2f9efe86-4af7-4f37-a40f-94b909a157d6}, 0x483150, 0x6de120, 0x6e76d0) stub.
fixme:ntdll:EtwEventRegister ({ea08c559-95a8-4aa2-afa6-18738eec6d37}, 0x483150, 0x6de1c8, 0x6e76c8) stub.
fixme:ntdll:EtwEventRegister ({10f6728c-ef92-4bf1-8397-49e693a6eb74}, 0x483150, 0x6de158, 0x6e7710) stub.
fixme:ntdll:EtwEventRegister ({46dd7f96-60cb-416b-8085-da5cd8f491dd}, 0x483150, 0x6de190, 0x6e7708) stub.
fixme:ver:GetCurrentPackageId (0x33f4f8 (nil)): stub
fixme:process:SetProcessDEPPolicy (3): stub
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:ntdll:EtwRegisterTraceGuidsW (0x10144ff0, 0x11fec2e0, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x11fc0360, (null), (null), 0x11fec2f8): stub
fixme:ntdll:EtwRegisterTraceGuidsW register trace class {00000000-0000-0000-0000-000000000000}
fixme:gdi:GdiInitializeLanguagePack stub
fixme:ver:GetCurrentPackageId (0x2d9e9d8 (nil)): stub
fixme:font:get_outline_text_metrics failed to read full_nameW for font L"Ani"!
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:win:FlashWindowEx 0x33e504 - semi-stub
fixme:ver:GetCurrentPackageId (0x721e9d8 (nil)): stub
fixme:ntdll:EtwRegisterTraceGuidsA (0x63073bcf, 0x630b3258, {9e3b3947-ca5d-4614-91a2-7b624e0e7244}, 1, 0x43ce0a0, (null), (null), 0x630b3258): stub
fixme:wtsapi:WTSUnRegisterSessionNotification Stub 0x500a2
fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
fixme:win:UnregisterDeviceNotification (handle=0xcafeaffe), STUB!
fixme:iphlpapi:CancelIPChangeNotify (overlapped 0x1b4944): stub
fixme:ntdll:EtwUnregisterTraceGuids deadbeef: stub
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:file:UnlockFileEx Unimplemented overlapped operation
fixme:file:UnlockFileEx Unimplemented overlapped operation

make sure you have the 64 and 32 bit versions installed. I only see 32 bit versions in your list

I am facing the same problem. Can you tell us how you fixed it?