League of Legends Reconnect Loop

After this morning League of Legends just loops when trying to load into the actual game. Here is the log output upon clicking reconnect

(wine:1801): GStreamer-WARNING **: 13:24:18.182: Failed to load plugin ‘/home/myname/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-ge-lol-p8-12-x86_64/lib64/gstreamer-1.0/libgstflac.so’: libFLAC.so.8: cannot open shared object file: No such file or directory

(wine:1801): GStreamer-WARNING **: 13:24:18.182: Failed to load plugin ‘/home/myname/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-ge-lol-p8-12-x86_64/lib64/gstreamer-1.0/libgstsoup.so’: libsoup-2.4.so.1: cannot open shared object file: No such file or directory

(wine:1801): GStreamer-WARNING **: 13:24:18.182: Failed to load plugin ‘/home/myname/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-ge-lol-p8-12-x86_64/lib/gstreamer-1.0/libgstflac.so’: /home/myname/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-ge-lol-p8-12-x86_64/lib/gstreamer-1.0/libgstflac.so: wrong ELF class: ELFCLASS32

(wine:1801): GStreamer-WARNING **: 13:24:18.182: Failed to load plugin ‘/home/myname/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-ge-lol-p8-12-x86_64/lib/gstreamer-1.0/libgstsoup.so’: /home/myname/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-ge-lol-p8-12-x86_64/lib/gstreamer-1.0/libgstsoup.so: wrong ELF class: ELFCLASS32


I went to those file paths and they do in fact exist, so I thought maybe it was a permissions issue and made them 777 and it’s still not working with the same error


I can confirm I’m having the exact same issue, hopefully LoL didn’t patch us out?! :frowning:

My relevant logs:

27429.787:02ec:02e8:info:vkd3d-proton:vkd3d_instance_apply_application_workarounds: Program name: “LeagueClientUxRender.exe” (hash: f676b078b8a3bc16)
27429.787:02ec:02e8:info:vkd3d-proton:vkd3d_instance_deduce_config_flags_from_environment: shader_cache is used, global_pipeline_cache is enforced.
27429.787:02ec:02e8:info:vkd3d-proton:vkd3d_config_flags_init_once: VKD3D_CONFIG=‘’.
27429.793:02ec:02e8:info:vkd3d-proton:vkd3d_get_vk_version: vkd3d-proton - applicationVersion: 2.10.0.
27429.793:02ec:02e8:info:vkd3d-proton:vkd3d_instance_init: vkd3d-proton - build: 88e4f300cc0b5b6.
27429.898:02ec:02e8:info:vkd3d-proton:vkd3d_memory_info_upload_hvv_memory_properties: Topology: UMA-like topology. Using DEVICE_LOCAL | HOST_COHERENT for UPLOAD.
27429.899:02ec:02e8:info:vkd3d-proton:vkd3d_bindless_state_get_bindless_flags: Enabling single descriptor set path for MUTABLE.
27429.899:02ec:02e8:info:vkd3d-proton:vkd3d_bindless_state_get_bindless_flags: Device supports VK_EXT_mutable_descriptor_type.
27429.908:02ec:02e8:info:vkd3d-proton:d3d12_device_caps_init_shader_model: Enabling support for SM 6.6.
27429.908:02ec:02e8:fixme:vkd3d-proton:d3d12_device_caps_init_feature_options1: TotalLaneCount = 1024, may be inaccurate.
27429.908:02ec:02e8:info:vkd3d-proton:vkd3d_pipeline_library_init_disk_cache: Remapping VKD3D_SHADER_CACHE to: vkd3d-proton.cache.
27429.908:02ec:02e8:info:vkd3d-proton:vkd3d_pipeline_library_init_disk_cache: Attempting to load disk cache from: vkd3d-proton.cache.
27429.909:02ec:0388:info:vkd3d-proton:vkd3d_pipeline_library_disk_thread_main: Performing async setup of stream archive …
27429.909:02ec:0388:info:vkd3d-proton:vkd3d_pipeline_library_disk_cache_merge: No write cache exists. No need to merge any disk caches.
27429.910:02ec:0388:info:vkd3d-proton:vkd3d_pipeline_library_disk_cache_initial_setup: Merging pipeline libraries took 0.330 ms.
27429.910:02ec:0388:info:vkd3d-proton:vkd3d_pipeline_library_disk_cache_initial_setup: Failed to map read-only cache: vkd3d-proton.cache.
27429.910:02ec:0388:info:vkd3d-proton:vkd3d_pipeline_library_disk_thread_main: Done performing async setup of stream archive.


I don’t know the exact terminology but you seem to be missing 2 parts (so.8 and so.1) within the .so files libFLAC and libsoup, respectively.


I am having the same problem but I seem to be missing a different variety of .so files


If someone could give me instructions on how to somehow get and edit those file out of the source github (I am a noob).

It would be much appreciated. If I receive instructions for one, I should be able to figure out the rest myself.

Edit: Actually (though while I have a feeling this will not fix the problem as my gut is telling me we are missing the same things and that the league system has just shutdown before getting to the other missing bits (or something like that)) if we are truly missing different pieces, then I actually already made a git repo as a test and have uploaded one of my files that was working working for me but was apparently broken for you if you take a hexdump and compare them and they are different, then we could probably upload and exchange the rest of the broken files for working files too.

1 Like

I downloaded and compared the hexdumps and they are in fact different but I’m going to guess that has to do with our computer hardware being different. I can attempt to replace the files though

Edit: Yeah it’s still erroring on that exact file so it’s something other than the files

I had this same problem since yesterday with the same warnings. I am not sure that these plugins are causing this issue. Hope you’ll find a solution that is working :pray:

I replaced the the gstreamer-1.0 folder with the one from the github released Lutris-GE-lol-p8-12 version.
The warnings are gone, but the problem still remains

this same issue is occuring for me, any fixes yet?

I tried deleting the wine files too so it would be forced to redownload them, still no dice

I am experiencing the same issues. For what I gather, Riot is completely switching to 64 bit. Some older libraries stop working with every passing patches. I tried a fresh install without success. I tried to force the 64 bit Architecture on the runner options without success. I tried reinstalling the libraries without success. I tried to revert to my old GE proton 7 without success. I must have toggled every options back and forth at least twice. I am running out of ideas.

1 Like

i tried and switched because of this error many OS : Fedora, Nobara, OpenSuse. Nothing still same error that loops in reconnect any info by riot about this ?

Same issue, I reinstalled on a new rig and thought i’d broken something. just found this thread and adding my +1.

same problem, lutris on linux mint.

this is a client bug and it has been reported by both linux and windows users
wait for rito to release a fix,
maybe next year if they’re quick


Is this really a client bug? I don’t have issues logging in or messing with client. Game itself that’s broken.

1 Like

the game client or the game itself are technically both clients, they both interact with the master server.

that being said it’s apparently a game launcher bug and not related to the game itself. but in any case lots of linux (if not all) are bieng concerned by this problem along with multiple windows users.

don’t expect rito to give a fuck about us and provide a fix. however, because this is also affecting the main target platform aka microshaft wangblows, a fix should hopefully get released soon



While we don’t (and probably won’t) officially support Linux, I actually use Lutris at home. If y’all could pass me any logs you have, I’ll pass them along to the League folks and hopefully we can get this fixed.


This is my latest log from a custom wine build forked from wine-ge-lol with patches to try and debug it. While it didnt work, behaviour was identical the latest wine-ge-lol used to play the last league patch.

This is a memory dump from the crash

1 Like

Here are the logs from my latest attempt to start a game: Filebin | bk3yio1z7ghz5q2s
The logs corresponding to the actual game starting (or rather, not starting) are from line ~240 onwards.

I have some additional information regarding the issue. It seems the issue is not launcher side but game side. It appears that stub.dll is causing the issue. That is what we know so far. It seems to crash right away with no real errors for most of us. For me, it doesn’t even give a bugsplat. It just dies instantly. The launcher then tries to pass information to it but fails and thus creates the reconnect loop. It is easily reproducible with wine-ge-lol-8.12 which is the current lutris version of wine used for league. Aside from that, the launcher end works without a hitch. Hopefully riot can get to the bottom of this, but the place to look is likely stub.dll and the changes made there.

Here is a copy of the logs for League of Legends.exe

Absolutely based. Thanks!