[League of Legends] Pressing play does nothing [DX], aborts process [OGL]

Just installed Lutris yesterday. I’ve been trying to get League of Legends to work, installing both the DX and OpenGL builds. As mentioned in the title, neither has worked, with DX showing “Playing League of Legends” at the bottom of the Lutris client but no League client popping up. OpenGL starts to run, then crashes with an error:

“Call from 0x7b83f432 to unimplemented function api-ms-win-crt-runtime-l1-1-0.dll._initialize_onexit_table, aborting”.

Unsure if either is a result of me missing packages or something else, but I will try to provide any information I can. Thanks for your help.

1 Like

Hi there!
I just followed this instructions and it worked.

  1. Install Lutris through the Software Center.
  2. Run the install script located here: https://lutris.net/games/league-of-legends/ .
  3. Install vcrun2015.
  4. Open Lutris.
  5. Right click on the League of Legends icon.
  6. Select Winetricks from the dropdown.
  7. Make sure ‘Select the default wineprefix’ is selected.
  8. Hit okay.
  9. Select ‘Install a Windows DLL or Component’.
  10. Hit okay.
  11. Scrolldown until you see vcrun2015.
  12. Select the row with vcrun2015 and hit okay. ( A process bar should appear)
  13. Click cancel until the dialog boxes that pop up disappear.
  14. ???
  15. Run League of Legends.

Source: https://solus-project.com/forums/viewtopic.php?t=8117

script has been updated. please see the following for details:

1 Like